Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 8th December 2011, 10:45
Ripeed Ripeed is offline
Member
 
Join Date: Oct 2011
Posts: 94
Thanks: 13
Thanked 3 Times in 3 Posts
Default

OK, I do the step 3 in (Sites -> webmail.example.com -> Options -> Apache Directives box) not in the examlpe.com as you type. I hope soo it is right.

Then I have it Forbidden

Now what next? Thanks
Reply With Quote
Sponsored Links
  #12  
Old 8th December 2011, 17:35
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 395
Thanks: 30
Thanked 58 Times in 50 Posts
Default

Yes, that's correct; you should be entering the Apache directives in webmail.example.com, not example.com. I apologize for the typo and have corrected my previous post.

Given that you are indeed receiving permission denied errors, your configuration is correct thus far.

The issue now is the permissions on the /usr/share/squirrelmail directory. More specifically, the user with whose credentials the webserver is running lacks sufficient access.

So, you need to set appropriate permissions on the /usr/share/squirrelmail directory. To be able to do this correctly and securely, we need to know which PHP implementation are you using? Mod-PHP, Fast-CGI, SuPHP, etc.

Also, what are the current permissions on this directory? List out the parent directory's contents:

Code:
# ls -lah /usr/share
I'm looking for something like this:

Code:
drwxr-xr-x   4 root root 4.0K Aug 12 07:05 squirrelmail
It would also be helpful if you list the contents of the directory, too, e.g.:

Code:
# ls -lah /usr/share/squirrelmail
We'll await your response...
Reply With Quote
  #13  
Old 8th December 2011, 20:10
Ripeed Ripeed is offline
Member
 
Join Date: Oct 2011
Posts: 94
Thanks: 13
Thanked 3 Times in 3 Posts
Default

Thanks again.

I think I am using mod-php. I proceeded by tutorial The Perfect Server.

I am looking on phpinfo, but i dont find anythink like php implementation...

Code:
# ls -lah /usr/share
drwxr-xr-x  12 root root 4.0K Nov 28 13:07 squirrelmail
Code:
# ls -lah /usr/share/squirrelmail
total 52K
drwxr-xr-x  12 root root 4.0K Nov 28 13:07 .
drwxr-xr-x 145 root root 4.0K Dec  5 10:08 ..
drwxr-xr-x   5 root root 4.0K Nov 28 13:07 class
lrwxrwxrwx   1 root root   17 Nov 28 13:07 config -> /etc/squirrelmail
drwxr-xr-x   4 root root 4.0K Nov 28 13:07 functions
drwxr-xr-x  29 root root 4.0K Nov 28 13:07 help
drwxr-xr-x   2 root root 4.0K Nov 28 13:07 images
drwxr-xr-x   3 root root 4.0K Nov 28 13:07 include
-rw-r--r--   1 root root  671 Aug  8 11:44 index.php
drwxr-xr-x  53 root root 4.0K Nov 28 13:07 locale
drwxr-xr-x  20 root root 4.0K Nov 28 13:07 plugins
drwxr-xr-x   2 root root 4.0K Nov 28 13:07 po
drwxr-xr-x   2 root root 4.0K Nov 28 13:07 src
drwxr-xr-x   3 root root 4.0K Nov 28 13:07 themes
thats it.

Last edited by Ripeed; 8th December 2011 at 20:23.
Reply With Quote
  #14  
Old 13th December 2011, 00:03
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 395
Thanks: 30
Thanked 58 Times in 50 Posts
Default

Quote:
I think I am using mod-php.
It's easy enough to double-check which mode you're using . Just go to Sites -> Website -> example.com and look at the menu selection next to "PHP", near the bottom of the page.

This is on the webmail.example.com domain, by the way.
Reply With Quote
The Following User Says Thank You to cbj4074 For This Useful Post:
Ripeed (13th December 2011)
  #15  
Old 13th December 2011, 01:26
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 395
Thanks: 30
Thanked 58 Times in 50 Posts
Default

After installing SquirrelMail myself and examining the Apache logs concerning the message that you now receive in the browser, "Forbidden: You don't have permission to access / on this server", I found the following:

Code:
[error] [client 184.74.75.65] client denied by server configuration: /usr/share/squirrelmailindex.php
[error] [client 184.74.75.65] client denied by server configuration: /usr/share/squirrelmailfavicon.ico
These messages indicate that the permission denial is happening at the Apache level (not the filesystem level), which is good. Also, your permissions on the /usr/share/squirrelmail directory are correct, so no need to change those. (As a side note, it is undesirable to change the default permissions on files/directories created via package installers. Doing so should always be a last resort.)

To allow access to that directory, it is necessary to add something similar to the following to your Apache configuration (ignore the first [Alias] line if you've already added that):

Code:
Alias / /usr/share/squirrelmail/
<Location />
Options +FollowSymLinks
order allow,deny
allow from all
</Location>
Once ISPConfig has written the change to disk, is the problem resolved?

Last edited by cbj4074; 13th December 2011 at 01:45.
Reply With Quote
The Following User Says Thank You to cbj4074 For This Useful Post:
Ripeed (13th December 2011)
  #16  
Old 13th December 2011, 01:45
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 395
Thanks: 30
Thanked 58 Times in 50 Posts
Default

I should mention also that the method for accessing SquirrelMail at webmail.example.com, as described in the tutorial, does work. (Before attempting it, however, please see my posts in this related thread for common pitfalls regarding the cited tutorial: http://www.howtoforge.com/forums/sho...t=52042&page=4 .)

That said, a more robust implementation would be to create a copy of the default SquirrelMail configuration file for Apache (these instructions are Debian-specific [which includes Ubuntu], so adapt accordingly)

Code:
# cp /usr/share/squirrelmail/config/apache.conf /etc/apache2/.conf/squirrelmail.conf
and then replace the default <VirtualHost></VirtualHost> section

Code:
#<VirtualHost 1.2.3.4>
#  DocumentRoot /usr/share/squirrelmail
#  ServerName webmail.example.com
#</VirtualHost>
with:

Code:
<VirtualHost *:80>
DocumentRoot /usr/share/squirrelmail
ServerName webmail.example.com
</VirtualHost>

<VirtualHost *:443>
DocumentRoot /usr/share/squirrelmail
ServerName webmail.example.com
</VirtualHost>
Don't forget to reload Apache:

Code:
# service apache2 force-reload
This adaptation accounts for any IP address and for SSL connections.

Last edited by cbj4074; 13th December 2011 at 03:29.
Reply With Quote
The Following User Says Thank You to cbj4074 For This Useful Post:
Ripeed (13th December 2011)
  #17  
Old 13th December 2011, 16:26
Ripeed Ripeed is offline
Member
 
Join Date: Oct 2011
Posts: 94
Thanks: 13
Thanked 3 Times in 3 Posts
Default

Quote:
Originally Posted by cbj4074 View Post
it's easy enough to double-check which mode you're using . Just go to sites -> website -> example.com and look at the menu selection next to "php", near the bottom of the page.

This is on the webmail.example.com domain, by the way.
ok its fast-cgi
Reply With Quote
  #18  
Old 13th December 2011, 17:15
Ripeed Ripeed is offline
Member
 
Join Date: Oct 2011
Posts: 94
Thanks: 13
Thanked 3 Times in 3 Posts
Default

OK, now its work!!!!

what i do:

add this:
<VirtualHost *:80>
DocumentRoot /usr/share/squirrelmail
ServerName webmail.example.com
</VirtualHost>

<VirtualHost *:443>
DocumentRoot /usr/share/squirrelmail
ServerName webmail.example.com
</VirtualHost>

that still wont work. After that i added this:
<Location />
Options +FollowSymLinks
order allow,deny
allow from all
</Location>

And NOW IT IS!!!!

THANK YOU SOOO MUTCH!

Last edited by Ripeed; 13th December 2011 at 18:03.
Reply With Quote
  #19  
Old 13th December 2011, 17:23
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 395
Thanks: 30
Thanked 58 Times in 50 Posts
 
Default

Glad to hear it!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting PHP to work with Cherokee maineac Installation/Configuration 3 2nd November 2010 06:31
How to config Proftpd to work with passive mode in ISPConfig 2.2.35 X-admin Installation/Configuration 0 6th June 2010 19:52
Email alias and forward do not work in ISPConfig 3 alecksievici Installation/Configuration 2 11th May 2010 16:12
Pure domain DNS doesn't work SyRenity Installation/Configuration 7 12th December 2006 13:12
Cant get any messenger program to work SimplyMepis 6.0 gtoman Technical 1 13th November 2006 16:26


All times are GMT +2. The time now is 12:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.