Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th December 2011, 13:15
bruno_floyd bruno_floyd is offline
Member
 
Join Date: Aug 2010
Posts: 73
Thanks: 1
Thanked 2 Times in 2 Posts
Default Wrong received email PATH

Hi guys,

I'm using ISPConfig last version, with the multiserver setup. On my Mailserver, I initially installed squirrelmail and then installed Roundcube, following a tutorial I found on Howtoforge...

I changed the maildir on the ISPConfig interface and moved my emails to this folder. I can access the webmail interface, read my old emails, send emails, but I can't received any, because the new incoming email are going to the old folder: "/var/vmail"

I've looked up on the postfix and courier configuration and didn't have any success... does anyone have a clue?

Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 12th December 2011, 13:44
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

The maildir path should never be changed on a server that has mailboxes as this change will break the whole setup. The change that you did in the ispconfig interface is only the path for new maildirs, not for existing ones.

You will have to change the path in the .mailfilter file which is in the mail root folder (normally /var/vmail) and then you will have to change the mail paths for all users in mail_user table.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 12th December 2011, 13:56
bruno_floyd bruno_floyd is offline
Member
 
Join Date: Aug 2010
Posts: 73
Thanks: 1
Thanked 2 Times in 2 Posts
Default

till,

on the database the path is correct, for all the users...

I found the .mailfilter file on /var/vmail. Can I edit the path there, to the new path? The .mailfilter is gonna still there, pointing to the new path?

I appreciate your help!
Thanks

Edit: Till, I changed the path on .mailfillter on /var/vmail and checked that there's the same file on my desired path (/mail).
I created a new account through the interface and everything was created correctly... I'm sending emails but not receiving yet.

Last edited by bruno_floyd; 12th December 2011 at 14:42.
Reply With Quote
  #4  
Old 12th December 2011, 17:43
bruno_floyd bruno_floyd is offline
Member
 
Join Date: Aug 2010
Posts: 73
Thanks: 1
Thanked 2 Times in 2 Posts
 
Default

I found out what was wrong.

I had already moved all my emails to the new format, it was sending with no problems but the emails i received were being sent to the default folder (/var/vmail) while i wanted them to go to somewhere else (/mail).

In the main.cf file on /etc/postfix two parameters were missing:

mail_spool_directory = /mail
home_mailbox = Maildir/

Once i added those the emails started to go to the correct directory.

Thanks till!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix Cannot Receive Email - Smtp Timed Out newbielinx Installation/Configuration 4 26th September 2011 17:14
Squirrelmail reply email address is wrong LazyEyes General 6 16th March 2009 02:09
email forward problem createch General 5 10th December 2008 14:14
'Salutatory Email for Clients' wrong CP and manual URL greenpete Installation/Configuration 4 23rd March 2008 19:12
email going to wrong mailboxes shinzou General 11 18th December 2006 16:12


All times are GMT +2. The time now is 13:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.