Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 5th December 2011, 16:22
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

When you restore a vm image, then it does not matter which other operating systems your host offers as the operating system of the VM is used. So if you host supports vmware based images, then you should be able to run every vmware image independantly of the used operating system.

Regarding your email issue, do you use a email alias or a email domain alias. If you used a email domain alias, then its a known problem in courier setups which has been fixed in svn. You can apply that fix by editing the /var/vmail/.mailfilter file and change the line:

Code:
`echo $SIZE >> {dist_postfix_vmail_mailbox_base}/$HOST/$USER/ispconfig_mailsize`
to:

Code:
`test -e {dist_postfix_vmail_mailbox_base}/$HOST/$USER`
if ( $RETURNCODE == 0 )
{
`echo $SIZE >> {dist_postfix_vmail_mailbox_base}/$HOST/$USER/ispconfig_mailsize`
}

If you used a email alias, then it might be a problem with your setup.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
olimortimer (6th December 2011)
Sponsored Links
  #12  
Old 6th December 2011, 18:12
olimortimer olimortimer is offline
Member
 
Join Date: Nov 2011
Posts: 59
Thanks: 12
Thanked 2 Times in 1 Post
 
Default

Quote:
Originally Posted by chrisphotonic View Post
I actually don't need it anymore, because the perfect setup guide for Ubuntu is very easy to run though.

I setup two servers using your guides over the weekend. Your guides are always excellent. I also bough your billing module. Glad I can help support howtoforge.
I agree that the guides are great, but it feels like I might have missed something, even though I followed the guides step-by-step - maybe because I'm not a Unix administrator, so I might have missed something which I needed to do but wasn't spelt out?

Quote:
Originally Posted by till View Post
When you restore a vm image, then it does not matter which other operating systems your host offers as the operating system of the VM is used. So if you host supports vmware based images, then you should be able to run every vmware image independantly of the used operating system.

Regarding your email issue, do you use a email alias or a email domain alias. If you used a email domain alias, then its a known problem in courier setups which has been fixed in svn. You can apply that fix by editing the /var/vmail/.mailfilter file and change the line:

Code:
`echo $SIZE >> {dist_postfix_vmail_mailbox_base}/$HOST/$USER/ispconfig_mailsize`
to:

Code:
`test -e {dist_postfix_vmail_mailbox_base}/$HOST/$USER`
if ( $RETURNCODE == 0 )
{
`echo $SIZE >> {dist_postfix_vmail_mailbox_base}/$HOST/$USER/ispconfig_mailsize`
}

If you used a email alias, then it might be a problem with your setup.
I'm not using an email alias for my forwards, but applied the above anyway. The error has now changed from:

Code:
(temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied sh: cannot create /var/vmail/example.com/me/ispconfig_mailsize: Directory nonexistent /usr/bin/maildrop: Unable to create a dot-lock at /var/vmail/example.com/me/26050.0.host.server.com.)
me@example.com
...to:

Code:
(temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to create a dot-lock at /var/vmail/example.com/me/26170.0.host.server.com.)
me@example.com

Last edited by olimortimer; 6th December 2011 at 18:16.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Vmware server 2.0.2-x with Ubuntu server 10.04 VMware Remote Console Plug-in letsharehowto HOWTO-Related Questions 12 6th December 2011 20:23
Can't receive mails baicunko Server Operation 12 3rd August 2011 22:02
ISPConfig 3 Installation - Postfix queue stuck andrew971218 Installation/Configuration 21 15th July 2011 14:42
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
Problem with keeping Apache alive bobeq Server Operation 3 29th November 2007 16:11


All times are GMT +2. The time now is 07:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.