Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Developers' Forum

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 1st December 2011, 14:36
redwiz redwiz is offline
Junior Member
 
Join Date: Dec 2011
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default bad permission creating shell user with rsa key

I don't know if this is the right forum to post, but i think i discovered a bug in shelluser creation procedure.

I downloaded and installed ispconfig last version (no sources modification made).

if i try to create a shell user ,both with o without chroot, and also provide a public rsa key evereything works fine, the user is created, and also ~/.ssh and ~/.ssh/authorized_keys are.

The problem is that ~/.ssh and ~/.ssh/authorized_keys are created owned by root , so i had to change manually the permission to let ssh work for that user.

Taking a look inside the sources i realized that in both

shelluser_jailkit_plugin.inc.php
and
shelluser_base_plugin.inc.php

the line that is suposed to give the right owner
(at the very end of the files)

exec("chown -R ".escapeshellcmd($this->data['new']['puser']).":".escapeshellcmd($this->data['new']['pgroup'])." ".$usrdir);


is commented out.

Am i right or i miss something?

thanks in advance to every answer

Andrea Consigli
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't receive mails baicunko Server Operation 12 3rd August 2011 22:02
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
Squirrelmail login failure Cracklefish Installation/Configuration 9 30th June 2010 20:38
Add ons for ISPConfig 3 virtue Installation/Configuration 24 16th October 2009 17:30
Problem with the apache (I can't start ist) M.Behrens Installation/Configuration 11 31st March 2006 10:48


All times are GMT +2. The time now is 22:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.