#1  
Old 29th November 2011, 14:50
DarkBlazer DarkBlazer is offline
Junior Member
 
Join Date: Nov 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default open_basedir problems

Hello to you all,

I have a problem regarding the open_basedir (yes I know, I'm number x about this). This is a site for a customer.

The problem is that i get this everytime:
Code:
Notice (8): Constant LOG_ERROR already defined [APP/config/core.php, line 112]

cake/libs/cache.php (line 218)

/var/www/clients/client1/web1/web/cake/libs/cache/file.php

Warning (2): include() [http://php.net/function.include]: open_basedir restriction in effect. File() is not within the allowed path(s): (/var/www/clients/client1/web1/web:/var/www/clients/client1/web1/tmp:/var/www/ispconfig.qlict.nl/web:/srv/www/ispconfig.qlict.nl/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/www/clients/client1/web1/web/cake/) [CORE/cake/libs/configure.php, line 434]

Warning (2): include() [http://php.net/function.include]: open_basedir restriction in effect. File() is not within the allowed path(s): (/var/www/clients/client1/web1/web:/var/www/clients/client1/web1/tmp:/var/www/ispconfig.qlict.nl/web:/srv/www/ispconfig.qlict.nl/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/www/clients/client1/web1/web/cake/) [CORE/cake/libs/configure.php, line 246]

Warning (2): require() [http://php.net/function.require]: open_basedir restriction in effect. File() is not within the allowed path(s): (/var/www/clients/client1/web1/web:/var/www/clients/client1/web1/tmp:/var/www/ispconfig.qlict.nl/web:/srv/www/ispconfig.qlict.nl/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/www/clients/client1/web1/web/cake/) [CORE/cake/libs/configure.php, line 1060]

Warning (2): require() [http://php.net/function.require]: open_basedir restriction in effect. File() is not within the allowed path(s): (/var/www/clients/client1/web1/web:/var/www/clients/client1/web1/tmp:/var/www/ispconfig.qlict.nl/web:/srv/www/ispconfig.qlict.nl/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/www/clients/client1/web1/web/cake/) [CORE/cake/libs/overloadable.php, line 35]

Warning (2): include() [http://php.net/function.include]: open_basedir restriction in effect. File() is not within the allowed path(s): (/var/www/clients/client1/web1/web:/var/www/clients/client1/web1/tmp:/var/www/ispconfig.qlict.nl/web:/srv/www/ispconfig.qlict.nl/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/www/clients/client1/web1/web/cake/) [CORE/cake/dispatcher.php, line 266]

Warning (2): Cannot modify header information - headers already sent by (output started at /var/www/clients/client1/web1/web/cake/libs/debugger.php:683) [CORE/cake/libs/controller/components/request_handler.php, line 759]
I've look in the lines of the files that are shown above and i can't find any wrong coding what so ever (all is nicely closed).

I've allready disabled the eaccalerator and the open_basedir in the php.ini file and both of them didn't work.

I've even used the chown -R /var/www/clients/clients1/web1/web/* as suggested on the forum and again even that didn't solve my problem.

I've enclosed my directory structure in here as well
Code:
drwxr-xr-x 13 web1 client1 4096 Nov 18 17:32 app
drwxr-xr-x 13 web1 client1 4096 Nov 21 21:22 app_virgin
drwxr-xr-x  6 web1 client1 4096 Nov 23 14:25 cake
drwxr-xr-x  2 web1 client1 4096 Nov  1 16:45 error
-rw-r--r--  1 web1 client1 1848 Nov 21 21:36 index.php
-rw-r--r--  1 web1 client1   20 Nov 21 21:42 info.php
drwxr-xr-x  5 web1 client1 4096 Nov 21 22:18 old
drwxr-xr-x  2 web1 client1 4096 Nov 21 21:36 plugins
-rw-r--r--  1 web1 client1 1055 Nov 21 21:36 README
drwxr-xr-x  2 web1 client1 4096 Nov 29 00:30 stats
drwxr-xr-x  3 web1 client1 4096 Nov 21 21:36 vendors
Please note that cake is from CakePHP that is needed for a web based application written in PHP.

I don't see the problem where the error is located in the directory. As far as I know i've disabled safe_mode and even that didn't work...

Could it be that some files in the webroot needs the executable to fix the problem?

I've installed ISPConfig 3 on a CentOS 6 x86_64 installation according to the manual which is located here on HTF.

After trying to solve the problem i also can't even connect to my administrative panel anymore.

Could someone please help me out?

Thanks in advance
Reply With Quote
Sponsored Links
  #2  
Old 30th November 2011, 18:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
 
Default

Did you adjust the open_basedir setting on the Options tab of the website in ISPConfig?

If that doesn't help, does it work if you empty the field?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems installing LAMP - MySQL and PHP5 JosBR Server Operation 5 19th December 2009 21:00
Courierr Errors were encountered while processing AsDsL General 1 30th November 2009 08:03
E: Sub-process /usr/bin/dpkg returned an error code (1) ergti Installation/Configuration 1 16th August 2009 12:36
Management/system config/settings & /server/settings not working!! dactor Installation/Configuration 9 6th February 2008 09:11
Empty Recycle Bin jon335 General 40 6th May 2006 11:56


All times are GMT +2. The time now is 16:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.