Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th November 2011, 20:25
mjnet mjnet is offline
Member
 
Join Date: Nov 2011
Posts: 44
Thanks: 2
Thanked 2 Times in 1 Post
Default Mailserver trouble: SASL authentication

Hi there!
I'm one of these guys having truble with mail server. I can NOT EVEN connect to it!

I installed my environment using the multiserver tutorial: http://www.howtoforge.com/multiserve...ispconfig-3-p2

But as I said I'm in trouble with mail server. as you can see mail.err:
Code:
Nov 20 17:58:25 domU-12-31-39-10-32-35 postfix/smtpd[28554]: fatal: no SASL authentication mechanisms
Nov 20 18:04:13 mail postfix/smtpd[1774]: fatal: no SASL authentication mechanisms
Nov 20 18:05:14 mail postfix/smtpd[2130]: fatal: no SASL authentication mechanisms
Nov 20 18:10:01 mail postfix/smtpd[3384]: fatal: no SASL authentication mechanisms
Nov 20 18:15:01 mail postfix/smtpd[4737]: fatal: no SASL authentication mechanisms
Nov 20 18:18:03 mail postfix/smtpd[5569]: fatal: no SASL authentication mechanisms
Nov 20 18:19:04 mail postfix/smtpd[5837]: fatal: no SASL authentication mechanisms
Nov 20 18:19:12 mail postfix/smtpd[5876]: fatal: no SASL authentication mechanisms
Nov 20 18:20:13 mail postfix/smtpd[6186]: fatal: no SASL authentication mechanisms
Nov 20 18:24:11 mail postfix/smtpd[7245]: fatal: no SASL authentication mechanisms
Nov 20 18:25:01 mail postfix/smtpd[7480]: fatal: no SASL authentication mechanisms
Nov 20 18:25:12 mail postfix/smtpd[7558]: fatal: no SASL authentication mechanisms
Nov 20 18:29:15 mail postfix/smtpd[1508]: fatal: no SASL authentication mechanisms
Nov 20 18:30:16 mail postfix/smtpd[1575]: fatal: no SASL authentication mechanisms
Nov 20 18:34:14 mail postfix/smtpd[2517]: fatal: no SASL authentication mechanisms
Nov 20 18:34:32 mail postfix/smtpd[2596]: fatal: no SASL authentication mechanisms
mail.log:
Code:
Nov 20 19:02:25 mail amavis[775]: Found secondary av scanner ClamAV-clamscan at /usr/bin/clamscan
Nov 20 19:02:25 mail amavis[775]: Creating db in /var/lib/amavis/db/; BerkeleyDB 0.48, libdb 5.1
Nov 20 19:02:25 mail spamd[777]: logger: removing stderr method
Nov 20 19:02:28 mail spamd[779]: spamd: server started on port 783/tcp (running version 3.3.2)
Nov 20 19:02:28 mail spamd[779]: spamd: server pid: 779
Nov 20 19:02:28 mail spamd[779]: spamd: server successfully spawned child process, pid 782
Nov 20 19:02:28 mail spamd[779]: spamd: server successfully spawned child process, pid 799
Nov 20 19:02:28 mail spamd[779]: prefork: child states: IS
Nov 20 19:02:28 mail spamd[779]: prefork: child states: II
Nov 20 19:02:38 mail postfix/master[1312]: daemon started -- version 2.8.5, configuration /etc/postfix
Nov 20 19:02:40 mail postfix/smtpd[1519]: connect from localhost[127.0.0.1]
Nov 20 19:02:41 mail postfix/smtpd[1519]: 04B393D34: client=localhost[127.0.0.1]
Nov 20 19:02:41 mail postfix/cleanup[1528]: 04B393D34: message-id=<mailman.0.1321811165.23050.mailman@mail.codag.net>
Nov 20 19:02:41 mail postfix/qmgr[1317]: 04B393D34: from=<mailman-bounces@mail.codag.net>, size=2063, nrcpt=1 (queue active)
Nov 20 19:02:41 mail postfix/smtpd[1519]: disconnect from localhost[127.0.0.1]
Nov 20 19:02:41 mail postfix/smtpd[1533]: connect from localhost[127.0.0.1]
Nov 20 19:02:41 mail postfix/smtpd[1533]: B12455356: client=localhost[127.0.0.1]
Nov 20 19:02:41 mail postfix/cleanup[1528]: B12455356: message-id=<mailman.0.1321811165.23050.mailman@mail.codag.net>
Nov 20 19:02:41 mail postfix/qmgr[1317]: B12455356: from=<mailman-bounces@mail.codag.net>, size=2486, nrcpt=1 (queue active)
Nov 20 19:02:41 mail amavis[780]: (00780-01) Passed CLEAN, LOCAL [127.0.0.1] [127.0.0.1] <mailman-bounces@mail.codag.net> -> <mj@codag.net>, Message-ID: <mailman.0.1321811165.23050.mailman@mail.codag.net>, mail_id: COT7w4Ko9TzR, Hits: -1, size: 2063, queued_as: B12455356, 695 ms
Nov 20 19:02:41 mail postfix/smtp[1529]: 04B393D34: to=<mj@codag.net>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.8, delays=0.07/0.03/0.01/0.69, dsn=2.0.0, status=sent (250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as B12455356)
Nov 20 19:02:41 mail postfix/qmgr[1317]: 04B393D34: removed
Nov 20 19:02:41 mail postfix/pipe[1534]: B12455356: to=<mj@codag.net>, relay=dovecot, delay=0.25, delays=0.03/0.02/0/0.2, dsn=4.3.0, status=deferred (temporary failure. Command output: doveconf: Warning: NOTE: You can get a new clean config file with: doveconf -n > dovecot-new.conf doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:24: 'imaps' protocol is no longer necessary, remove it doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:24: 'pop3s' protocol is no longer necessary, remove it doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:529: mail_executable has been replaced by service { executable } doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:587: mail_executable has been replaced by service { executable } doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:664: protocol managesieve {} has been replaced by protocol sieve { } doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:681: sieve has been moved into plugin {} section doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:686: sieve_storage has been moved into plugin { sieve_dir } doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:813: add auth_ prefix to all settings inside auth {} and remove the auth {} section completely doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:924: passdb sql {} has been replaced by passdb { driver=sql } doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:985: userdb sql {} has been replaced by userdb { driver=sql } doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:1014: auth_user has been replaced by service auth { user } doveconf: Fatal: Error in configuration file /etc/dovecot/dovecot.conf: mail_plugin_dir: access(/usr/lib/dovecot/modules/lda) failed: No such file or directory )
Nov 20 19:04:24 mail postfix/master[1312]: terminating on signal 15
Nov 20 19:04:24 mail postfix/master[2271]: daemon started -- version 2.8.5, configuration /etc/postfix
What I did/tried untill now:

installed packages described in this post:
Code:
http://www.howtoforge.com/forums/showpost.php?p=265831&postcount=25
Went through this post and installed packages:
Code:
http://www.howtoforge.com/forums/showthread.php?t=54644&highlight=SASL+authentication+mechanisms
As a try, I also commented out this lines in postfix main.cf
Code:
dovecot_destination_recipient_limit = 1
smtpd_sasl_type = dovecot
smtpd_sasl_path = private/auth
and a..:
Code:
postconf -e 'virtual_transport = maildrop'
now i have nooo idea!

maybe for information my nestat -tap:
Code:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 localhost:spamd         *:*                     LISTEN      779/spamd.pid   
tcp        0      0 *:www                   *:*                     LISTEN      1391/apache2    
tcp        0      0 *:ssh                   *:*                     LISTEN      522/sshd        
tcp        0      0 *:smtp                  *:*                     LISTEN      2271/master     
tcp        0      0 localhost:10024         *:*                     LISTEN      775/amavisd (master
tcp        0      0 localhost:10025         *:*                     LISTEN      2271/master     
tcp        0      0 localhost:mysql         *:*                     LISTEN      634/mysqld      
tcp        0      0 domU-12-31-39-10-:33311 instance-data.ec2.i:www TIME_WAIT   -               
tcp        0   1392 domU-12-31-39-10-32:ssh 80-218-79-166.dcl:49683 ESTABLISHED 1538/sshd: ubuntu [
tcp        0      0 domU-12-31-39-10-:33313 instance-data.ec2.i:www TIME_WAIT   -               
tcp        0      0 localhost:mysql         localhost:50430         ESTABLISHED 634/mysqld      
tcp        1      0 localhost:54069         localhost:10025         CLOSE_WAIT  780/amavisd (ch1-av
tcp        0      0 domU-12-31-39-10-:33312 instance-data.ec2.i:www TIME_WAIT   -               
tcp        0      0 domU-12-31-39-10-:33310 instance-data.ec2.i:www TIME_WAIT   -               
tcp        0      0 localhost:50430         localhost:mysql         ESTABLISHED 780/amavisd (ch1-av
tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      522/sshd

would be great if you have any further ideas! thank you!
mj
Reply With Quote
Sponsored Links
  #2  
Old 21st November 2011, 08:26
mjnet mjnet is offline
Member
 
Join Date: Nov 2011
Posts: 44
Thanks: 2
Thanked 2 Times in 1 Post
Default

after a reinstall of system, it's still the same error
Reply With Quote
  #3  
Old 21st November 2011, 09:14
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,166
Thanks: 829
Thanked 5,412 Times in 4,255 Posts
Default

There is no imap server started on your system. Which Linux distribution and version do you use?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 21st November 2011, 09:58
mjnet mjnet is offline
Member
 
Join Date: Nov 2011
Posts: 44
Thanks: 2
Thanked 2 Times in 1 Post
Default

wow :S

it's ubuntu 11.1 64bit on ec2 (https://help.ubuntu.com/community/EC2StartersGuide)
Reply With Quote
  #5  
Old 21st November 2011, 10:06
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,166
Thanks: 829
Thanked 5,412 Times in 4,255 Posts
Default

The guide you used is for Debian, so it might not work with Ubuntu.

The error messages that you get are a bug in ubuntu:

http://www.howtoforge.com/forums/sho...1&postcount=25
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 21st November 2011, 10:27
mjnet mjnet is offline
Member
 
Join Date: Nov 2011
Posts: 44
Thanks: 2
Thanked 2 Times in 1 Post
Default

thanks for link, but as you can see in first post, i already installed these packages...
Reply With Quote
  #7  
Old 22nd November 2011, 13:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

I wonder why you had a Dovecot configuration in your main.cf (see post #1). saslauthd is used only in conjunction with Courier, not Dovecot (Dovecot handles authentication by itself). Are you sure you followed the guide to the letter?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig3 mail doesn't work pehden Installation/Configuration 20 9th December 2013 14:05
sasl / fail2ban vs. postfix/smtpd warnings) eko_taas Installation/Configuration 4 17th May 2011 16:04
Fail2ban + sasl problem and Solution pititis General 1 2nd March 2011 07:02
Cannot login to SquirrelMail sellotape Installation/Configuration 13 26th October 2010 11:03
Need some Hints to "The Perfect Server - Debian Lenny (Debian 5.0) [ISPConfig 3]" wahid HOWTO-Related Questions 10 25th August 2010 15:18


All times are GMT +2. The time now is 08:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.