Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 14th November 2011, 09:23
psychop psychop is offline
Member
 
Join Date: Apr 2010
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Default can't receive mail from GMAIL

Hi.
Have 20 acc. on my server. Can send and receive all mail except from gmail.
When send mail to info@anydomainonserver.com from gmail no mail arrives and gmail set's an error, but from all other it arrives ok.

Error is:
Code:
Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 550 550-5.1.1 The email account that you tried to reach does not exist. Please try
550-5.1.1 double-checking the recipient's email address for typos or
550-5.1.1 unnecessary spaces. Learn more at...
Reply With Quote
Sponsored Links
  #2  
Old 14th November 2011, 09:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,241 Times in 4,108 Posts
Default

Which error message do you get in the mail log file?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 14th November 2011, 10:12
psychop psychop is offline
Member
 
Join Date: Apr 2010
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Default

no errors !
Reply With Quote
  #4  
Old 14th November 2011, 11:01
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,241 Times in 4,108 Posts
Default

And no delivery attemps from google? Then there might be a problem with the dns MX records of that domain.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 14th November 2011, 13:29
psychop psychop is offline
Member
 
Join Date: Apr 2010
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Default

DNS records for one site looks like this:
Code:
Domain NS records 	Nameserver records returned by the parent servers are:

ns1.server.com.   ['9x.1x.xx.xx'] (NO GLUE)   [TTL=86400]
ns2.server.com.   ['9x.1x.xx.xx'] (NO GLUE)   [TTL=86400]

Pass 	Your nameservers are listed 	Good. The parent server ns8.arnes.si has your nameservers listed. This is a must if you want to be found as anyone that does not know your DNS servers will first ask the parent nameservers.
Info 	DNS Parent sent Glue 	The parent nameserver ns8.arnes.si is not sending out GLUE for every nameservers listed, meaning he is sending out your nameservers host names without sending the A records of those nameservers. It's ok but you have to know that this will require an extra A lookup that can delay a little the connections to your site. This happens a lot if you have nameservers on different TLD (domain.com for example with nameserver ns.domain.org.)

Pass 	Nameservers A records 	Good. Every nameserver listed has A records. This is a must if you want to be found.
NS 	Info 	NS records from your nameservers	NS records got from your nameservers listed at the parent NS are:

ns1.server.com  ['9x.1x.xx.xx']   [TTL=86400]
ns2.server.com  ['9x.1x.xx.xx']   [TTL=86400]

Pass 	Recursive Queries 	Good. Your nameservers (the ones reported by the parent server) do not report that they allow recursive queries for anyone.
Pass 	Same Glue 	The A records (the GLUE) got from the parent zone check are the same as the ones got from your nameservers. You have to make sure your parent server has the same NS records for your zone as you do according to the RFC. This tests only nameservers that are common at the parent and at your nameservers. If there are any missing or stealth nameservers you should see them below!
Information 	Glue for NS records 	INFO: GLUE was not sent when I asked your nameservers for your NS records.This is ok but you should know that in this case an extra A record lookup is required in order to get the IPs of your NS records. The nameservers without glue are:
9x.1x.xx.xx
You can fix this for example by adding A records to your nameservers for the zones listed above.
Pass 	Mismatched NS records 	OK. The NS records at all your nameservers are identical.
Pass 	DNS servers responded 	Good. All nameservers listed at the parent server responded.
Pass 	Name of nameservers are valid 	OK. All of the NS records that your nameservers report seem valid.
Pass 	Multiple Nameservers 	Good. You have multiple nameservers. According to RFC2182 section 5 you must have at least 3 nameservers, and no more than 7. Having 2 nameservers is also ok by me.
Pass 	Nameservers are lame 	OK. All the nameservers listed at the parent servers answer authoritatively for your domain.
Pass 	Missing nameservers reported by parent 	OK. All NS records are the same at the parent and at your nameservers.
Pass 	Missing nameservers reported by your nameservers 	OK. All nameservers returned by the parent server ns8.arnes.si are the same as the ones reported by your nameservers.
Pass 	Domain CNAMEs 	OK. RFC1912 2.4 and RFC2181 10.3 state that there should be no CNAMEs if an NS (or any other) record is present.
Pass 	NSs CNAME check 	OK. RFC1912 2.4 and RFC2181 10.3 state that there should be no CNAMEs if an NS (or any other) record is present.
Warn 	Different subnets 	WARNING: Not all of your nameservers are in different subnets
Pass 	IPs of nameservers are public 	Ok. Looks like the IP addresses of your nameservers are public. This is a good thing because it will prevent DNS delays and other problems like
Pass 	DNS servers allow TCP connection 	OK. Seems all your DNS servers allow TCP connections. This is a good thing and useful even if UDP connections are used by default.
Warn 	Different autonomous systems 	WARNING: Single point of failure
Pass 	Stealth NS records sent 	Ok. No stealth ns records are sent
SOA 	Info 	SOA record	The SOA record is:
Primary nameserver: ns1.server.com
Hostmaster E-mail address: admin@email.com
Serial #: 2011111302
Refresh: 28800
Retry: 7200
Expire: 604800   1 weeks
Default TTL: 86400
Pass 	NSs have same SOA serial 	OK. All your nameservers agree that your SOA serial number is 2011111302.
Pass 	SOA MNAME entry 	OK. ns1.server.com That server is listed at the parent servers.
Pass 	SOA Serial 	Your SOA serial number is: 2011111302. This appears to be in the recommended format of YYYYMMDDnn.
Pass 	SOA REFRESH 	OK. Your SOA REFRESH interval is: 28800. That is OK
Pass 	SOA RETRY 	Your SOA RETRY value is: 7200. Looks ok
Pass 	SOA EXPIRE 	Your SOA EXPIRE number is: 604800.Looks ok
Pass 	SOA MINIMUM TTL 	Your SOA MINIMUM TTL is: 86400. This value was used to serve as a default TTL for records without a given TTL value and now is used for negative caching (indicates how long a resolver may cache the negative answer). RFC2308 recommends a value of 1-3 hours. Your value of 86400 is OK.
MX 	Info 	MX Records	Your MX records that were reported by your nameservers are:

20   ns1.server.com   9x.1x.xx.xx
10   aspmx.l.google.com   74.125.39.27 (no glue)

[These are all the MX records that I found. If there are some non common MX records at your nameservers you should see them below. ]
Pass 	Different MX records at nameservers 	Good. Looks like all your nameservers have the same set of MX records. This tests to see if there are any MX records not reported by all your nameservers and also MX records that have the same hostname but different IPs
Pass 	MX name validity 	Good. I did not detect any invalid hostnames for your MX records.
Pass 	MX IPs are public 	OK. All of your MX records appear to use public IPs.
Pass 	MX CNAME Check 	OK. No problems here.
Pass 	MX A request returns CNAME 	OK. No CNAMEs returned for A records lookups.
Pass 	MX is not IP 	OK. All of your MX records are host names.
Pass 	Number of MX records 	Good. Looks like you have multiple MX records at all your nameservers. This is a good thing and will help in preventing loss of mail.
Pass 	Mismatched MX A 	OK. I did not detect differing IPs for your MX records.
Pass 	Duplicate MX A records 	OK. I have not found duplicate IP(s) for your MX records. This is a good thing.
Pass 	Reverse MX A records (PTR) 	Your reverse (PTR) record:
183.132.103.93.in-addr.arpa ->  9x-1x-xx-xx.static.isp.net
27.39.125.74.in-addr.arpa ->  fx-in-f27.1e100.net
You have reverse (PTR) records for all your IPs, that is a good thing.
WWW 	Info 	WWW A Record 	Your www.mysite.com A record is:
www.mysite.com  [9x.1x.xx.xx] 
Pass 	IPs are public 	OK. All of your WWW IPs appear to be public IPs.
Pass 	WWW CNAME 	OK. No CNAME
Reply With Quote
  #6  
Old 21st November 2011, 22:18
psychop psychop is offline
Member
 
Join Date: Apr 2010
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here are outputs:

dig MX mysite.com
Code:
; <<>> DiG 9.6.1-P3 <<>> MX mysite.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 31019
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0

;; QUESTION SECTION:
;mysite.com.                        IN      MX

;; ANSWER SECTION:
mysite.com.         86400   IN      MX      10 ns1.server.com.

;; AUTHORITY SECTION:
mysite.com.         86400   IN      NS      ns2.server.com.
mysite.com.         86400   IN      NS      ns1.server.com.

;; Query time: 185 msec
;; SERVER: 192.168.123.254#53(192.168.123.254)
;; WHEN: Mon Nov 21 22:30:14 2011
;; MSG SIZE  rcvd: 103
and dig A ns1.server.com
Code:
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 20141
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 5, ADDITIONAL: 10

;; QUESTION SECTION:
;ns1.server.com.            IN      A

;; ANSWER SECTION:
ns1.server.com.     60      IN      A       9x.1x.xx.xx
can't find the problem. Today tested all other 'outside' mail my clients have and all mail arrived except from gmail.
Reply With Quote
  #7  
Old 22nd November 2011, 13:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,727 Times in 2,565 Posts
Default

Please check your domain on www.intodns.com.

Also, can you check if you're blacklisted? http://mxtoolbox.com/blacklists.aspx I'm not sure, but maybe Gmail refuses to send mails to blacklisted servers.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 23rd December 2011, 09:08
psychop psychop is offline
Member
 
Join Date: Apr 2010
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Got it all working now.

So here it goes... had to reinstall complete postfix with factory settings one more time, then configure it and same with courier and that did the trick. Guess something was wrong in any of these two .conf files.

Hope it helps someone else in future.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SquirrelMail login not working glenneh Installation/Configuration 13 9th April 2011 20:01
Need help get mail to work (can't recieve and apperently can't send) omega13a Installation/Configuration 19 20th August 2009 21:06
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39
Postfix reject connections gabrix Server Operation 27 25th January 2007 08:37
Can not recieve mail with de virtual mail adress Mounir Installation/Configuration 9 24th July 2006 23:16


All times are GMT +2. The time now is 05:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.