Prev Previous Post   Next Post Next
  #1  
Old 12th November 2011, 23:33
MetZ MetZ is offline
Junior Member
 
Join Date: Aug 2011
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default Moving to nginx failing

Hi..
I am struggling with ISPconfig latest and moving to nginx.

I have even tried to completely re-install my server, before installing ispconfig
http://www.howtoforge.com/perfect-se...ispconfig-3-p7

It looks like ISPconfig does not start, I can not find it in my processes list. I tried to do an update on it, and it spits out a couple of error messages:
Code:
Configuring Apps vhost
PHP Warning:  symlink(): No such file or directory in /tmp/ispconfig3_install/install/lib/installer_base.lib.php on line 1515
Configuring Database
Configuring Bastille Firewall
Updating ISPConfig
PHP Notice:  Undefined property: installer::$ispconfig_interface_installed in /tmp/ispconfig3_install/install/update.php on line 333
Reconfigure Crontab? (yes,no) [yes]:
When doing a fresh-install, some symlink error appeared (I have tried 3-4 times now, almost giving up and going back to apache2).

Any suggestions? any logs I can check? Try to load ispconfig manually?

Thanks for any help!
-Tom

EDIT:
After more research on this, I have figured more out. I think it has something to do with nginx. Now I receive a 403 Forbidden message when domain.com:8080
If I go to domain.com (phpinfo in index.php), the phpinfo display with FPM/FastCGI as server API.
I have tried to look at the ispconfig.vhost file, but as I am totally new to nginx, I am not sure where to start. it is the default vhost file installed with installer.
Any suggestions?

Last edited by MetZ; 13th November 2011 at 00:46.
Reply With Quote
Sponsored Links
 

Bookmarks

Tags
ispconfig 3, nginx, startup

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Nginx doesnt restart after installation of ISPConfig 3 cyprus Installation/Configuration 2 6th November 2011 18:48
A Working Nginx Catchall with ISPConfig 3. renders Tips/Tricks/Mods 4 15th April 2011 21:53
Perfect SpamSnake 10.10 - nginx install.. colskinet HOWTO-Related Questions 7 16th January 2011 04:33
Nginx and PHP and Fastcgi Paladinemishakal Installation/Configuration 1 4th January 2011 13:45
Nginx on Fedora 11 Nammut HOWTO-Related Questions 1 3rd October 2009 16:35


All times are GMT +2. The time now is 14:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.