Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th November 2011, 21:44
Skprorok Skprorok is offline
Member
 
Join Date: Jun 2009
Posts: 56
Thanks: 8
Thanked 0 Times in 0 Posts
Exclamation imap_open() Couldn't open stream

Hi all

I have created my own webmail client and i have used it with no problems. I have migrate my whole server content to other server and now I have problem with connection to the imap server. PHP function imap_open(xxx.my.ip.xxx/novalidate-cert, .....); which i used on old server now doesn't work. Of course i changed IP of the server, i tried to use localhost/novalidate-cert, localhost:143/novalidate-cert but still same error. Squirrelmail (which have in config.php file: localhost:143) works fine. Can u help me please?

Thanks in advance
Reply With Quote
Sponsored Links
  #2  
Old 10th November 2011, 21:51
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,340
Thanks: 810
Thanked 5,169 Times in 4,053 Posts
Default

You should use "localhost" as hostname or "127.0.0.1" as IP in the imap_open function and not the Ip of the server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 10th November 2011, 22:07
Skprorok Skprorok is offline
Member
 
Join Date: Jun 2009
Posts: 56
Thanks: 8
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
You should use "localhost" as hostname or "127.0.0.1" as IP in the imap_open function and not the Ip of the server.

Thanks for answer.

When I use localhost or 127.0.0.1 same error: imap_open(): Couldn't open stream {127.0.0.1/novalidate-cert}INBOX in...

I used IP of the server on the older server and it worked fine... Now nothing works and I dont know why
Reply With Quote
  #4  
Old 10th November 2011, 22:14
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,340
Thanks: 810
Thanked 5,169 Times in 4,053 Posts
Default

Which errors do you get in the mail log?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 10th November 2011, 22:30
Skprorok Skprorok is offline
Member
 
Join Date: Jun 2009
Posts: 56
Thanks: 8
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
Which errors do you get in the mail log?
No errors in mail error log, and in the mail log: Nov 10 22:22:06 servervg2 imapd: Connection, ip=[::1] (i ran script and 22:22 and this has been written)
Reply With Quote
  #6  
Old 14th November 2011, 01:16
Skprorok Skprorok is offline
Member
 
Join Date: Jun 2009
Posts: 56
Thanks: 8
Thanked 0 Times in 0 Posts
 
Default

Anyone can help me please?
Reply With Quote
Reply

Bookmarks

Tags
imap_open, server

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't receive mails baicunko Server Operation 12 3rd August 2011 22:02
Add ons for ISPConfig 3 virtue Installation/Configuration 24 16th October 2009 17:30
High on Lenny - Lvm Mount Problem Serverman Technical 1 23rd June 2009 16:26
have problems with OpenSuse 11.1 + IspConfig 3 virtual appliance mariuscotan Installation/Configuration 11 31st May 2009 12:52
Improve the Firewall rules vaio1 Installation/Configuration 0 10th May 2008 20:44


All times are GMT +2. The time now is 22:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.