Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th November 2011, 12:47
hoenes hoenes is offline
Junior Member
 
Join Date: Nov 2011
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problems after upgrading to 3.0.4

I am running a multi server enviroment.

After upgrading to 3.0.4 on my servers if have some problems.

1. Changing af user e-mail password in IPSConfig, does not change the user e-mail password on the mail server.

2. Creating a new user database in ISPConfig does not create the database on the database server.

Maby it because i had, and still have, some problems upgrading my master ISPConfig server.
Reply With Quote
Sponsored Links
  #2  
Old 7th November 2011, 12:53
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,340
Thanks: 810
Thanked 5,171 Times in 4,055 Posts
Default

Please check the file /usr/local/ispconfig/server/lib/config.inc.php on the slave server if they contain the correct login details for the master server in the master login section (the user must be named ispcsrv plus a number). If they are correct, please check that the server_id number in the config file matches the server_id number for that server in the server table of the master ispconfig database.

All servers in a cluster must run the same ispconfig version, otherwise the replication can fail due to different database table layouts.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 7th November 2011, 13:20
hoenes hoenes is offline
Junior Member
 
Join Date: Nov 2011
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The informations in config.inc.php is correct.

If i compare dbispconfig database on then mailserver, and dbispconfig on then admin/master server they hold the same data.

I guess this means, that the password acutally changes, but the user is not able to logon with the new password.

When i try to update my master server i get this error ( i made a post about this friday, but i can't find it)


--------------------------------------------------------------------------------
_____ ___________ _____ __ _ ____
|_ _/ ___| ___ \ / __ \ / _(_) /__ \
| | \ `--.| |_/ / | / \/ ___ _ __ | |_ _ __ _ _/ /
| | `--. \ __/ | | / _ \| '_ \| _| |/ _` | |_ |
_| |_/\__/ / | | \__/\ (_) | | | | | | | (_| | ___\ \
\___/\____/\_| \____/\___/|_| |_|_| |_|\__, | \____/
__/ |
|___/
--------------------------------------------------------------------------------


>> Update

Operating System: Debian 6.0 (Squeeze/Sid) or compatible

This application will update ISPConfig 3 on your server.
Checking ISPConfig database .. OK
PHP Notice: Uninitialized string offset: 0 in /tmp/ispconfig3_install/install/lib/update.lib.php on line 127
PHP Fatal error: Cannot use string offset as an array in /tmp/ispconfig3_install/install/lib/update.lib.php on line 127
root@admin:/tmp/ispconfig3_install/install#
Reply With Quote
  #4  
Old 7th November 2011, 13:27
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,340
Thanks: 810
Thanked 5,171 Times in 4,055 Posts
Default

Please check the file /usr/local/ispconfig/server/lib/config.inc.php on the master server if it contains the correct login details of the user "ispconfig" for the mysql master database. Then check the file /usr/local/ispconfig/server/lib/mysql_clientdb.conf if it contains the correct mysql root password for the master mysql server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 7th November 2011, 13:36
hoenes hoenes is offline
Junior Member
 
Join Date: Nov 2011
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Both files have the correct informations.
Reply With Quote
  #6  
Old 7th November 2011, 13:53
hoenes hoenes is offline
Junior Member
 
Join Date: Nov 2011
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Actually the mail problem is due to the failed update on the master server, so if some one could help me with the above 'update error', i think my other problems are solved.
Reply With Quote
  #7  
Old 7th November 2011, 14:38
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,340
Thanks: 810
Thanked 5,171 Times in 4,055 Posts
Default

The error message means that the updater is not able to retrieve a value from the server configuration of the master server. The server configuration is stored in the "server" database table of the master ispconfig database in the field "config" It is a ini style configuration and the missing setting is "homedir_path" in the [mail] section. The default value for that field is "/var/vmail".
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 7th November 2011, 14:45
hoenes hoenes is offline
Junior Member
 
Join Date: Nov 2011
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

In the server table the master server is not present at all.

I only have my DNS servers, mail server, db server and web servers.
Reply With Quote
  #9  
Old 7th November 2011, 14:50
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,340
Thanks: 810
Thanked 5,171 Times in 4,055 Posts
 
Default

So you currently have no server with ID 1 in that table?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mailserver problem after upgrading to 3.0.4 zenny Installation/Configuration 3 7th November 2011 10:20
Problems upgrading to ISPConfig-2.2.33 zalo Installation/Configuration 16 6th November 2009 15:06
Hack to Fix SMTP problems after upgrading from Sarge to Etch Ardesco Server Operation 0 20th October 2007 23:37
Problems with clamscan after upgrading to ISPConfig-2.2.10 wheatie Installation/Configuration 13 28th February 2007 20:46
Problems upgrading :( woleium Installation/Configuration 3 24th January 2007 11:41


All times are GMT +2. The time now is 05:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.