Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 5th November 2011, 16:07
cyprus cyprus is offline
Member
 
Join Date: Oct 2011
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Question Nginx doesn´t restart after installation of ISPConfig 3

Okay here I am the last 3 days I was setting up a server from scratch with one focus getting ISPConfig running.

I used debian with bind & courier nginx as serversoftware thttpd for cgi implemented fastcgi and squirrelmail and walked a long way.
Everything worked fine and then I installed ISPConfig.
In the first moment everything seems to be okay. But I couldn´t call my server via browser got a "bad gateway".
I tried to restart nginx and got this:
Quote:
root@v10300122146:~# /etc/init.d/nginx restart
Restarting nginx: nginx: [emerg] SSL_CTX_use_certificate_chain_file("/etc/nginx/cert.pem") failed (SSL: error:02001002:system library:fopen:No such file or directory error:20074002:BIO routines:FILE_CTRL:system lib error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib)
nginx: configuration file /etc/nginx/nginx.conf test failed
It looks like an SSL problem but there aren´t any *.pem files in my nginx folder. And I ain´t got no idea how to fix it.

Thanx for every hint

Cyprus
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hosting multiple websites and webmail dmwcool Installation/Configuration 8 30th March 2010 03:15
Ftp problems timeout reny2000 General 6 23rd December 2009 11:09
ISPConfig 3.0: Multiple Server Installation Mentor Installation/Configuration 9 12th September 2009 06:55
Host and Domain problems in ISPConfig Installation script atjensen11 Installation/Configuration 1 31st January 2009 00:57
Ispconfig Installation Problems 2XTREME4U Installation/Configuration 6 21st June 2007 11:43


All times are GMT +2. The time now is 08:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.