Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th October 2011, 09:43
skoena skoena is offline
Senior Member
 
Join Date: Sep 2009
Location: Emmen, Netherlands
Posts: 421
Thanks: 77
Thanked 14 Times in 12 Posts
Send a message via MSN to skoena Send a message via Skype™ to skoena
Default Joomla installation

I try to install a website with Joomla.
(I choose Fast-cgi and enable SuEXEC.)

When I go to the site I get a 500 Internal Server Error. I checked the log and found this:

Quote:
[Wed Oct 26 08:39:27 2011] [notice] mod_fcgid: call /var/www/mcgeurope.nl/web/index.php with wrapper /var/www/php-fcgi-scripts/web63/.php-fcgi-starter
[Wed Oct 26 08:39:29 2011] [notice] mod_fcgid: call /var/www/mcgeurope.nl/web/index.php with wrapper /var/www/php-fcgi-scripts/web63/.php-fcgi-starter
[Wed Oct 26 08:39:30 2011] [notice] mod_fcgid: call /var/www/mcgeurope.nl/web/index.php with wrapper /var/www/php-fcgi-scripts/web63/.php-fcgi-starter
[Wed Oct 26 08:39:31 2011] [notice] mod_fcgid: call /var/www/mcgeurope.nl/web/index.php with wrapper /var/www/php-fcgi-scripts/web63/.php-fcgi-starter
[Wed Oct 26 08:39:31 2011] [notice] mod_fcgid: process /var/www/mcgeurope.nl/web/index.php(31090) exit(communication error), get unexpected signal 11
[Wed Oct 26 08:39:31 2011] [notice] mod_fcgid: process /var/www/mcgeurope.nl/web/index.php(31088) exit(communication error), get unexpected signal 11
[Wed Oct 26 08:39:31 2011] [notice] mod_fcgid: process /var/www/mcgeurope.nl/web/index.php(31086) exit(communication error), get unexpected signal 11
Reply With Quote
Sponsored Links
  #2  
Old 26th October 2011, 13:43
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

Which log did you check? Please take a look into the error.log which is in the log directory of the website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 26th October 2011, 13:53
skoena skoena is offline
Senior Member
 
Join Date: Sep 2009
Location: Emmen, Netherlands
Posts: 421
Thanks: 77
Thanked 14 Times in 12 Posts
Send a message via MSN to skoena Send a message via Skype™ to skoena
Default

I got these entries form: /var/log/apache2/error.log

This is from the error log from the website itself:
Quote:
[Wed Oct 26 12:46:37 2011] [warn] (104)Connection reset by peer: mod_fcgid: read data from fastcgi server error.
[Wed Oct 26 12:46:37 2011] [error] [client 62.173.206.33] Premature end of script headers: index.php
Reply With Quote
  #4  
Old 26th October 2011, 17:13
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

Please check that all files and folders in /var/www/mcgeurope.nl/web/ are owned by the web user and client group of this server. If they are owned by a wrong user, e.g. root, then fastcgi will fail with the above error.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 26th October 2011, 18:01
skoena skoena is offline
Senior Member
 
Join Date: Sep 2009
Location: Emmen, Netherlands
Posts: 421
Thanks: 77
Thanked 14 Times in 12 Posts
Send a message via MSN to skoena Send a message via Skype™ to skoena
Default

Here's the ls -l

Quote:
drwxr-xr-x 10 web63 client10 4096 2011-08-10 10:02 administrator
drwxr-xr-x 2 web63 client10 4096 2011-08-10 10:02 cache
drwxr-xr-x 12 web63 client10 4096 2011-08-10 10:05 components
-rw-r--r-- 1 web63 client10 1844 2011-09-27 15:10 configuration.ph
-rw-r--r-- 1 web63 client10 1777 2011-10-26 08:25 configuration.php
drwxr-xr-x 2 root root 4096 2011-10-26 08:25 error
-rw-r--r-- 1 web63 client10 3189 2011-04-07 07:47 htaccess.txt
drwxr-xr-x 4 web63 client10 4096 2011-08-10 10:06 images
drwxr-xr-x 2 web63 client10 4096 2011-08-10 10:06 includes
-rw-r--r-- 1 web63 client10 1389 2011-02-21 09:45 index.php
drwxr-xr-x 4 web63 client10 4096 2011-08-10 10:19 language
drwxr-xr-x 6 web63 client10 4096 2011-08-10 10:24 libraries
-rw-r--r-- 1 web63 client10 17816 2009-12-12 05:44 LICENSE.txt
drwxr-xr-x 2 web63 client10 4096 2011-08-10 10:24 logs
drwxr-xr-x 8 web63 client10 4096 2011-08-10 10:32 media
drwxr-xr-x 25 web63 client10 4096 2011-08-10 10:34 modules
drwxr-xr-x 10 web63 client10 4096 2011-08-10 10:37 plugins
-rw-r--r-- 1 web63 client10 4493 2011-01-08 16:40 README.txt
-rw-r--r-- 1 web63 client10 849 2011-04-02 16:43 robots.txt
drwxr-xr-x 2 root root 4096 2011-10-02 00:30 stats
drwxr-xr-x 6 web63 client10 4096 2011-08-10 10:49 templates
drwxr-xr-x 2 web63 client10 4096 2011-08-10 10:49 tmp
-rw-r--r-- 1 web63 client10 1811 2011-04-07 07:30 web.config.txt
Reply With Quote
  #6  
Old 26th October 2011, 19:47
skoena skoena is offline
Senior Member
 
Join Date: Sep 2009
Location: Emmen, Netherlands
Posts: 421
Thanks: 77
Thanked 14 Times in 12 Posts
Send a message via MSN to skoena Send a message via Skype™ to skoena
Default

I reinstalled the site from scratch. Enabled suEXEC and fast-cgi on creation of the new website.

I follow the installation of joomla no problems. When it;s finished I can''t get on the index.php page because of the 500 inter server error. I can get into the administration area...

Sites error log:
Quote:
[Wed Oct 26 18:41:48 2011] [warn] (104)Connection reset by peer: mod_fcgid: read data from fastcgi server error.
[Wed Oct 26 18:41:48 2011] [error] [client 94.213.81.212] Premature end of script headers: index.php, referer: http://mcgeurope.nl/installation/ind...?view=complete
[Wed Oct 26 18:41:50 2011] [warn] (104)Connection reset by peer: mod_fcgid: read data from fastcgi server error.
[Wed Oct 26 18:41:50 2011] [error] [client 94.213.81.212] Premature end of script headers: index.php, referer: http://mcgeurope.nl/installation/ind...?view=complete
[Wed Oct 26 18:41:51 2011] [warn] (104)Connection reset by peer: mod_fcgid: read data from fastcgi server error.
[Wed Oct 26 18:41:51 2011] [error] [client 94.213.81.212] Premature end of script headers: index.php, referer: http://mcgeurope.nl/installation/ind...?view=complete
[Wed Oct 26 18:41:52 2011] [warn] (104)Connection reset by peer: mod_fcgid: read data from fastcgi server error.
[Wed Oct 26 18:41:52 2011] [error] [client 94.213.81.212] Premature end of script headers: index.php, referer: http://mcgeurope.nl/installation/ind...?view=complete
[Wed Oct 26 18:41:53 2011] [warn] (104)Connection reset by peer: mod_fcgid: read data from fastcgi server error.
[Wed Oct 26 18:41:53 2011] [error] [client 94.213.81.212] Premature end of script headers: index.php, referer: http://mcgeurope.nl/installation/ind...?view=complete
[Wed Oct 26 18:41:54 2011] [warn] (104)Connection reset by peer: mod_fcgid: read data from fastcgi server error.
[Wed Oct 26 18:41:54 2011] [error] [client 94.213.81.212] Premature end of script headers: index.php, referer: http://mcgeurope.nl/installation/ind...?view=complete
Reply With Quote
  #7  
Old 27th October 2011, 09:28
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

Ok, so the joomla installer itself worked first and when the installation is finished, it begins to fail?

Then the problem is maybe related to a apache directive in a .htaccess file. Please check if there is a .htaccess file in the web folder and try to rename it to see if the site starts working then.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 27th October 2011, 10:17
skoena skoena is offline
Senior Member
 
Join Date: Sep 2009
Location: Emmen, Netherlands
Posts: 421
Thanks: 77
Thanked 14 Times in 12 Posts
Send a message via MSN to skoena Send a message via Skype™ to skoena
Default

Till,
There's a .htaccess file but it is empty. I also renamed it to htaccess but still the 500 internal server error.

Last edited by skoena; 27th October 2011 at 10:19.
Reply With Quote
  #9  
Old 27th October 2011, 10:54
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

Ok, but I understand it correctly that the installation scripts indeed worked in that website but joomla fails after install? Thats really strange, maybe there is a missing php module or so and the php error message is not shown.

May you please switch the website to mod_php, wait a minute and then test if the joomla page loads.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 27th October 2011, 20:24
skoena skoena is offline
Senior Member
 
Join Date: Sep 2009
Location: Emmen, Netherlands
Posts: 421
Thanks: 77
Thanked 14 Times in 12 Posts
Send a message via MSN to skoena Send a message via Skype™ to skoena
 
Default

The installation went well and Joomla site does not work ater install. Only the administratration area is available.

I changed to mod_php but the site is not available after, no 500 error. When I change back fo fast-cgi the 500 error is back.

Rudolf.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Joomla installation problem kennethwu Installation/Configuration 5 13th June 2011 02:28
ISPConfig installation into multiple OpenVZ containers letezo Installation/Configuration 11 3rd March 2009 23:47
Automatic Joomla installation SamTzu Tips/Tricks/Mods 9 16th October 2008 18:59


All times are GMT +2. The time now is 06:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.