#1  
Old 2nd April 2010, 16:44
fireba11 fireba11 is offline
Member
 
Join Date: Jan 2007
Location: Germany
Posts: 67
Thanks: 0
Thanked 4 Times in 3 Posts
Default DNS improvements

* add spf record to the default template
* add "Allow zone transfers to these IPs" as option for the template

spf records (when set correctly) are always a good idea to have ..
currently the template does not allow predefining IPs for AXFR, usually you always use the same secondary DNS servers though, so that would be nice to have in the template
Reply With Quote
The Following User Says Thank You to fireba11 For This Useful Post:
DiscipleGeek (30th August 2011)
Sponsored Links
  #2  
Old 27th April 2010, 13:29
ImaniAbigailWilliams ImaniAbigailWilliams is offline
Junior Member
 
Join Date: Apr 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

tried both versions and I couldn't get either to work.

I couldn't get them to hold the configuration settings. After saving the router settings the router went back to the default.

Maybe its something I'm doing wrong. If some else gets them to work I'll have another try?
Reply With Quote
  #3  
Old 2nd August 2011, 14:13
coldfried coldfried is offline
Junior Member
 
Join Date: Aug 2011
Posts: 1
Thanks: 1
Thanked 0 Times in 0 Posts
Default Dynamic DNS

* native support for zone options such as "update-policy" and "allow-update" in /etc/bind/named.conf.local for the zone.
* native support to store a secret in /etc/bind/named.conf.keys (my config) for the dynamic zones.

I am running a dynamic dns zone on my name server controlled by ISPconfig3, and I've just discovered that when I make any changes to the name server within ISPconfig afterwards, it rewrites the conf file for the zone and removes my modifications that permit dynamic updates. It would be great if these dynamic update settings could be supported by (or included in) ISPConfig 3 so that we would not need to devise a workaround to get it to keep the changes.
Reply With Quote
  #4  
Old 2nd August 2011, 14:37
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,715
Thanks: 819
Thanked 5,321 Times in 4,174 Posts
Default

ISPConfig supports already custom BIND config files.

To make your changes persistent, copy the bind_* files from /usr/local/ispconfig/server/conf to /usr/local/ispconfig/server/conf-custom/ and then edit the files in the conf-custom directory to suit your needs.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
coldfried (2nd August 2011)
  #5  
Old 30th August 2011, 18:10
DiscipleGeek DiscipleGeek is offline
Junior Member
 
Join Date: Aug 2011
Posts: 6
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by fireba11 View Post
* add spf record to the default template
* add "Allow zone transfers to these IPs" as option for the template

spf records (when set correctly) are always a good idea to have ..
currently the template does not allow predefining IPs for AXFR, usually you always use the same secondary DNS servers though, so that would be nice to have in the template
These would definitely be welcome additions.
Reply With Quote
  #6  
Old 16th October 2011, 18:17
maumar maumar is offline
Senior Member
 
Join Date: May 2009
Location: San Costanzo (PU - Italy)
Posts: 134
Thanks: 8
Thanked 11 Times in 11 Posts
Send a message via MSN to maumar Send a message via Skype™ to maumar
 
Default

I would add this to this problematic

Code:
allow-transfer {none;};
there 2 requirements about it>
1.

as fireba11 asked for, add "Allow zone transfers to these IPs" as option for the template (I was not able to customize it working on

Code:
/usr/local/ispconfig/server/conf/bind_named.conf.local.master
2.
there at the moment 3 fields
-> Allow zone transfers to these IPs (comma separated list)
-> Also Notify
-> Update ACL

if you let empty 2^ one and 3^ one, "Also Notify" and "Update ACL", nothing is written to

Code:
zone "zonename" {
        type master;
        allow-transfer {none;};
        file "/etc/bind/pri.zonename";
};
but if u left empty the 1^ filed:

"Allow zone transfers to these IPs (comma separated list)"

you get
Code:
allow-transfer {none;};
I expect "none" there if and only if i input "none into the form field, and i expect no line regarding allow-transfer if i left field empty

in this way, i could configure my preferred
allow-transfer
ip's into general file:

Code:
/etc/bind/named.conf.options
without losing this setting with

Code:
allow-transfer {none;};
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Squid Proxy Caching on Linux obzerver Installation/Configuration 4 13th August 2008 19:51
Google Apps dayjahone General 19 29th March 2008 17:25
DNS Configuration Problems VMartins Installation/Configuration 10 24th July 2007 14:40
Unable send receive emails vassilis3 Installation/Configuration 15 19th May 2007 14:34
No SPF record. beryl Installation/Configuration 6 17th May 2007 19:52


All times are GMT +2. The time now is 12:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.