Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th October 2011, 02:29
Salital Salital is offline
Member
 
Join Date: Jul 2011
Posts: 48
Thanks: 5
Thanked 0 Times in 0 Posts
Default User FTP COnnection doesn't work

Hi Guys,

I tried with Client FTP Filezilla to connect to my ISPConfig ftp server but I can't connect (the normal ssh connection for the user works!)

You can see the follow client ftp log

Quote:
Status: Connecting to 192.168.1.106:21...
Status: Connection established, waiting for welcome message...
Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response: 220-You are user number 1 of 50 allowed.
Response: 220-Local time is now 15:57. Server port: 21.
Response: 220-This is a private system - No anonymous login
Response: 220-IPv6 connections are also welcome on this server.
Response: 220 You will be disconnected after 15 minutes of inactivity.
Command: USER salx
Response: 331 User salx OK. Password required
Command: PASS **********
Response: 530 Login authentication failed
Error: Critical error
Error: Could not connect to server
Status: Connecting to 192.168.1.106:21...
Status: Connection established, waiting for welcome message...
Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response: 220-You are user number 1 of 50 allowed.
Response: 220-Local time is now 16:12. Server port: 21.
Response: 220-This is a private system - No anonymous login
Response: 220-IPv6 connections are also welcome on this server.
Response: 220 You will be disconnected after 15 minutes of inactivity.
Command: USER salx
Response: 331 User salx OK. Password required
Command: PASS **********
Response: 530 Login authentication failed
Error: Critical error
Error: Could not connect to server

I Enabled debugging in pure FTPD as described in the ISPConfig FAQ

http://www.faqforge.com/linux/contro...-debian-linux/

and this is the file syslog file

Quote:
Oct 4 16:09:01 server1 /USR/SBIN/CRON[10313]: (root) CMD ( [ -x /usr/lib/php5/maxlifetime ] && [ -d /var/lib/php5 ] && find /var/lib/php5/ -type f -cmin +$(/usr/lib/php5/maxlifetime) -delete)
Oct 4 16:10:01 server1 /USR/SBIN/CRON[10697]: (getmail) CMD (/usr/local/bin/run-getmail.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Oct 4 16:10:01 server1 /USR/SBIN/CRON[10698]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Oct 4 16:10:35 server1 postfix/postqueue[10934]: warning: Mail system is down -- accessing queue directly
Oct 4 16:11:01 server1 /USR/SBIN/CRON[11095]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Oct 4 16:12:01 server1 /USR/SBIN/CRON[11478]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Oct 4 16:12:51 server1 pure-ftpd: (?@192.168.1.103) [INFO] New connection from 192.168.1.103
Oct 4 16:12:51 server1 pure-ftpd: (?@192.168.1.103) [DEBUG] Command [user] [salx]
Oct 4 16:12:51 server1 pure-ftpd: (?@192.168.1.103) [DEBUG] Command [pass] [<*>]
Oct 4 16:12:51 server1 pure-ftpd: (?@192.168.1.103) [INFO] PAM_RHOST enabled. Getting the peer address
Oct 4 16:12:57 server1 pure-ftpd: (?@192.168.1.103) [WARNING] Authentication failed for user [salx]
Oct 4 16:12:57 server1 pure-ftpd: (?@192.168.1.103) [INFO] Logout.
Oct 4 16:13:01 server1 /USR/SBIN/CRON[11852]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
I don't know if something wrong

thanks anyway,

S

Last edited by Salital; 5th October 2011 at 06:43.
Reply With Quote
Sponsored Links
  #2  
Old 5th October 2011, 03:14
Overcrook Overcrook is offline
Junior Member
 
Join Date: Jan 2010
Posts: 11
Thanks: 3
Thanked 2 Times in 2 Posts
Default

Hi Salital,

it looks like the password is wrong.
Have you added a new FTP User for the user "Salx" in ISPConfig 3 ?
'Cause with the Shell-User (username+password) you can't connect to FTP, only to SFTP.
Reply With Quote
The Following User Says Thank You to Overcrook For This Useful Post:
Salital (5th October 2011)
  #3  
Old 5th October 2011, 06:56
Salital Salital is offline
Member
 
Join Date: Jul 2011
Posts: 48
Thanks: 5
Thanked 0 Times in 0 Posts
 
Default

Hi Overcrook,

Quote:
it looks like the password is wrong.
you are right, the password was incorrect when I put it on the FTP Client

Quote:
Have you added a new FTP User for the user "Salx" in ISPConfig 3 ?
yes

Quote:
'Cause with the Shell-User (username+password) you can't connect to FTP, only to SFTP.
thanks dude

S
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with services!! banzaiwebstudio.com Installation/Configuration 7 19th May 2010 22:13
Slow download from own FTP (vsftpd + proftpd) Overcrook Installation/Configuration 0 12th January 2010 22:41
Cant get Mail to work samcamfilms General 7 31st July 2009 18:59
ftp is very slow and asks for user/passwd continuously chico58 Installation/Configuration 7 8th October 2008 13:43
Users can't acces their folders with Web-FTP kvdd Installation/Configuration 9 1st November 2007 20:52


All times are GMT +2. The time now is 23:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.