Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 22nd September 2011, 12:38
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

According to http://forums.freebsd.org/showthread.php?t=21041 you should increase the TimeOut directive value in Apache.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
lusso64 (23rd September 2011)
Sponsored Links
  #12  
Old 21st May 2014, 21:18
dan-v dan-v is offline
Junior Member
 
Join Date: May 2014
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by FeraTechInc View Post
Even with these modifications I am still getting the following error:

Code:
[Mon Apr 05 19:48:47 2010] [warn] mod_fcgid: read data timeout in 40 seconds
[Mon Apr 05 19:48:47 2010] [error] [client XX.XX.XX.XX] Premature end of script headers: index.php, referer: http://www.website.com/index.php
Any ideas? I was under the impression that "IPCCommTimeout" was what was causing the timeout... But even setting it to 7200 didn't help.
You are correct, this is the right directive for setting the fastCGI timeout. However, in many installations, this directive is is placed in several config files, and the last one wins. So unless you hit by chance the last place where this parameter is set, you are screwed.

It took me about a day's work to I finally figure out where to put this directive in a Debian/Linux system managed under Plesk. The files is
/var/www/vhosts/<yourhostname>/vhost.conf

This file vhost.conf will usually not exist, unless you have already done some non-standard vhost configuring already. So you need to create it.

Then just put contents like:

# set time limit to be greater than the longest reasonable php module
# execution time
#
# Note: some (drupal..) modules advertize themselves as long and tell you
# to tweak php set_time_limit(). But this is ineffective by itself, unless you
# are running PHP as a module. For PHP in CGI and FasCGI modes, the
# shorter of the php time limit and cgi time limit will win, so you need to
# relax both constraints

Code:
<IfModule mod_fcgid.c>
IPCCommTimeout 900
</IfModule>
Reply With Quote
Reply

Bookmarks

Tags
ipcconnecttimeout, mod_fcgid

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ftp problems timeout reny2000 General 6 23rd December 2009 11:09
Security problem 2 ???? the revenge :) albertux Installation/Configuration 2 22nd September 2009 18:44
Spamsnake - Problem with spamassassin, FuzzyOcr and MySQL debuguser HOWTO-Related Questions 6 16th September 2008 18:37
Help with Bluetooth PAND josto HOWTO-Related Questions 1 7th August 2007 20:53
spamassasin/clamAV not working Daisy Installation/Configuration 32 15th February 2007 00:09


All times are GMT +2. The time now is 18:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.