Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 14th September 2011, 23:24
erocha_resendiz erocha_resendiz is offline
Junior Member
 
Join Date: Sep 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Squirrel Mail Unknown user or password incorrect. (CentOS 5.6)

hi everyone,

This is my first post and i seriously need your help for finish my installation of my server CentOS 5.6; i use the tutorial http://www.howtoforge.com/perfect-se...64-ispconfig-3 and everything seems to go well, till i try to log in with a test account that i create on the ISPConfig 3.0.3 that i have on my server, the squirrelmail log in panel gives me this message:

Quote:
User unknow and password incorrect.
i check the /etc/maillog, and it got this:

Quote:
Sep 14 15:00:02 d2 dovecot: imap-login: Disconnected: rip=127.0.0.1, lip=127.0.0.1, secured
Sep 14 15:00:02 d2 dovecot: pop3-login: Disconnected: rip=127.0.0.1, lip=127.0.0.1, secured
Sep 14 15:00:02 d2 postfix/smtpd[21362]: connect from localhost.localdomain[127.0.0.1]
Sep 14 15:00:02 d2 postfix/smtpd[21362]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Sep 14 15:00:02 d2 postfix/smtpd[21362]: disconnect from localhost.localdomain[127.0.0.1]
Sep 14 15:05:01 d2 dovecot: pop3-login: Disconnected: rip=127.0.0.1, lip=127.0.0.1, secured
Sep 14 15:05:01 d2 dovecot: imap-login: Disconnected: rip=127.0.0.1, lip=127.0.0.1, secured
Sep 14 15:05:01 d2 postfix/smtpd[21595]: connect from localhost.localdomain[127.0.0.1]
Sep 14 15:05:01 d2 postfix/smtpd[21595]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Sep 14 15:05:01 d2 postfix/smtpd[21595]: disconnect from localhost.localdomain[127.0.0.1]
Sep 14 15:08:57 d2 dovecot: imap-login: Aborted login: user=<test1@mendeng.net>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
Sep 14 15:10:01 d2 dovecot: imap-login: Disconnected: rip=127.0.0.1, lip=127.0.0.1, secured
Sep 14 15:10:01 d2 dovecot: pop3-login: Disconnected: rip=127.0.0.1, lip=127.0.0.1, secured
Sep 14 15:10:01 d2 postfix/smtpd[21850]: connect from localhost.localdomain[127.0.0.1]
Sep 14 15:10:01 d2 postfix/smtpd[21850]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Sep 14 15:10:01 d2 postfix/smtpd[21850]: disconnect from localhost.localdomain[127.0.0.1]
and i saw something else, when i run the next command it give's me this:

Quote:
[root@d2 ~]# /etc/init.d/httpd restart

Stopping httpd: [ OK ]
Starting httpd: [Wed Sep 14 15:12:31 2011] [warn] NameVirtualHost 209.190.28.2:80 has no VirtualHosts
[Wed Sep 14 15:12:31 2011] [warn] NameVirtualHost 209.190.28.2:443 has no VirtualHosts
[Wed Sep 14 15:12:31 2011] [warn] NameVirtualHost *:80 has no VirtualHosts
[ OK ]
i'm not very familiar with linux and stuff, i can tell u that this are the things that i guess are important right now but if you need more information, please let me know how to get it.

PD: CentOS 5.6 and Squirrelmail version 1.4.8-5.el5.centos.10 if you're asking what version i have install

thank you all for the patient and the help of course.
Reply With Quote
Sponsored Links
  #2  
Old 15th September 2011, 12:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Are there any other errors in your mail log?

Is SELinux disabled?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 16th September 2011, 22:57
CD_PlaYeR CD_PlaYeR is offline
Junior Member
 
Join Date: Mar 2011
Posts: 16
Thanks: 3
Thanked 0 Times in 0 Posts
Default update ispconfig 3

you should try to update ispconfig installation so it set up you services, prolly you installed squirrelmail after ispconfig3 or something messed up during installation. do it by typing:

cd /tmp
wget http://www.ispconfig.org/downloads/I...-stable.tar.gz
tar xfz ISPConfig-3-stable.tar.gz
cd ispconfig3_install/install/

php -q update.php

that will updaet ispconfig3 and set-up services
Reply With Quote
  #4  
Old 19th September 2011, 18:08
erocha_resendiz erocha_resendiz is offline
Junior Member
 
Join Date: Sep 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
Are there any other errors in your mail log?

Is SELinux disabled?
__________________
Falko
i already have the SELinux disable, i checked with the command "system-config-securitylevel-tui" and appears disabled.

Quote:
Originally Posted by CD_PlaYeR View Post
you should try to update ispconfig installation so it set up you services, prolly you installed squirrelmail after ispconfig3 or something messed up during installation. do it by typing:

cd /tmp
wget http://www.ispconfig.org/downloads/I...-stable.tar.gz
tar xfz ISPConfig-3-stable.tar.gz
cd ispconfig3_install/install/

php -q update.php

that will updaet ispconfig3 and set-up services
i did what you suggest and i got this during the update:

Reconfigure Crontab? (yes,no) [yes]: yes

Updating Crontab
Restarting services ...
Stopping MySQL: [ OK ]
Starting MySQL: [ OK ]
Shutting down postfix: [ OK ]
Starting postfix: [ OK ]
Stopping saslauthd: [ OK ]
Starting saslauthd: [ OK ]
Daemon [13470] terminated by SIGTERM
Shutting down amavisd: [ OK ]
amavisd stopped
Starting amavisd: [ OK ]

Stopping Clam AntiVirus Daemon: [ OK ]
Starting Clam AntiVirus Daemon: Bytecode: Security mode set to "TrustSigned".
[ OK ]
Stopping Dovecot Imap: [FAILED]
Error: Error in configuration file /etc/dovecot.conf line 715: Unknown protocol name (section changed in /etc/dovecot.conf at line 709)
Fatal: Invalid configuration in /etc/dovecot.conf
Starting Dovecot Imap: [FAILED]

Stopping httpd: [ OK ]
[Mon Sep 19 09:42:06 2011] [warn] NameVirtualHost *:80 has no VirtualHosts
Starting httpd: [ OK ]
Stopping pure-ftpd: [ OK ]
Starting pure-ftpd: [ OK ]
Update finished.

i enter into the file on the specific lines and there is:

Quote:
# Support for dynamically loadable plugins. mail_plugins is a space separated
# list of plugins to load.
#mail_plugins =
#mail_plugin_dir = /usr/lib/dovecot/pop3
mail_plugins = quota
mail_plugin_dir = /usr/lib/dovecot/pop3

# Workarounds for various client bugs:
# outlook-no-nuls:
# Outlook and Outlook Express hang if mails contain NUL characters.
# This setting replaces them with 0x80 character.
# oe-ns-eoh:
# Outlook Express and Netscape Mail breaks if end of headers-line is
# missing. This option simply sends it if it's missing.
# The list is space-separated.
#pop3_client_workarounds =
}

##
## ManageSieve specific settings
##

protocol managesieve {
# Login executable location.
#login_executable = /usr/libexec/dovecot/managesieve-login
what i need to do know??
Reply With Quote
  #5  
Old 19th September 2011, 20:31
CD_PlaYeR CD_PlaYeR is offline
Junior Member
 
Join Date: Mar 2011
Posts: 16
Thanks: 3
Thanked 0 Times in 0 Posts
Default

try commencting out the mail_plugin and mail_plugin_dir
Reply With Quote
  #6  
Old 19th September 2011, 22:11
CD_PlaYeR CD_PlaYeR is offline
Junior Member
 
Join Date: Mar 2011
Posts: 16
Thanks: 3
Thanked 0 Times in 0 Posts
Default

while fixing postfix on my Centos Server i thought about this,
did you remove dovecot that is installed when you install the OS?
if you haven't that's prolly the problem, you need to reinstall it with MYSQL support, here's the tuto so you can see -> http://www.howtoforge.com/perfect-se...ispconfig-3-p4

else did you got an error after setting quota?
Reply With Quote
  #7  
Old 19th September 2011, 22:26
erocha_resendiz erocha_resendiz is offline
Junior Member
 
Join Date: Sep 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by CD_PlaYeR View Post
while fixing postfix on my Centos Server i thought about this,
did you remove dovecot that is installed when you install the OS?
if you haven't that's prolly the problem, you need to reinstall it with MYSQL support, here's the tuto so you can see -> http://www.howtoforge.com/perfect-se...ispconfig-3-p4

else did you got an error after setting quota?
i did exactly what the tuto has on it and i see something curious, when you run the command yum install dovecot dovecot-sieve, it install the dovecot correctly but dovecot-sieve wasn't.

Could this maybe a problem?

and the problem of the dovecot i removed it first and then install without trouble; something else i reviewed on the ispconfig control panel, was the services status and everything its just fine, but i can get into test account yet.

Could be dovecot-sieve not install, the principal problem for not login?
Or what else could it be?

thank you for all the help.
Reply With Quote
  #8  
Old 20th September 2011, 11:27
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Quote:
Originally Posted by erocha_resendiz View Post
i did exactly what the tuto has on it and i see something curious, when you run the command yum install dovecot dovecot-sieve, it install the dovecot correctly but dovecot-sieve wasn't.

Could this maybe a problem?
Yes, this is the problem. What does your /etc/yum.repos.d/atrpms.repo look like, and what's the output of
Code:
uname -a
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 20th September 2011, 15:14
CD_PlaYeR CD_PlaYeR is offline
Junior Member
 
Join Date: Mar 2011
Posts: 16
Thanks: 3
Thanked 0 Times in 0 Posts
Default

like falko said you must do the modification as in the tuto to /etc/yum.repos.d/atrpms.repo

and then you must import the gpg key as told in the tuto by diong:

wget http://ATrpms.net/RPM-GPG-KEY.atrpms

rpm --import RPM-GPG-KEY.atrpms
Reply With Quote
  #10  
Old 20th September 2011, 18:05
erocha_resendiz erocha_resendiz is offline
Junior Member
 
Join Date: Sep 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by falko View Post
Yes, this is the problem. What does your /etc/yum.repos.d/atrpms.repo look like, and what's the output of
Code:
uname -a
?
the atrpms.repo looks like this:

Code:
[atrpms]
name=Red Hat Enterprise Linux 5 - x86_64 - ATrpms
baseurl=http://dl.atrpms.net/el5-x86_64/atrpms/stable
failovermethod=priority
exclude=dovecot-2*
includepkgs=dovecot dovecot-sieve

#
# requires stable
#
[atrpms-testing]
name=Red Hat Enterprise Linux 5 - x86_64 - ATrpms testing
baseurl=http://dl.atrpms.net/el5-x86_64/atrpms/testing
failovermethod=priority
enabled=1
exclude=dovecot-2*
includepkgs=dovecot dovecot-sieve

#
# requires stable and testing
#
[atrpms-bleeding]
name=Red Hat Enterprise Linux 5 - x86_64 - ATrpms bleeding
baseurl=http://dl.atrpms.net/el5-x86_64/atrpms/bleeding
failovermethod=priority
enabled=0
and the output of the uname -a is:

Linux d2.d.de.static.xlhost.com 2.6.18-238.19.1.el5 #1 SMP Fri Jul 15 07:32:29 EDT 2011 i686 i686 i386 GNU/Linux
Reply With Quote
Reply

Bookmarks

Tags
centos 5.6, dovecot, ispconfig 3.0.3, postfix, squirrelmail ispconfig

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How cai remove amavis from postfix ? gabrix Server Operation 16 2nd October 2012 10:58
Email being accepted but not delivered punto Installation/Configuration 8 25th May 2011 01:13
dovecot: lda: Fatal: Unknown user dpicella Installation/Configuration 1 22nd August 2010 03:59
Mail server using Postfix, Dovecot, Mysql... Postfix virtual maps doesn't work?? tarasbuljba HOWTO-Related Questions 33 28th May 2010 15:33
Postfix + postfixadmin = SMTP errors... Rashef Server Operation 4 25th June 2009 17:12


All times are GMT +2. The time now is 12:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.