Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st September 2011, 15:52
JEU JEU is offline
Member
 
Join Date: Jan 2008
Location: Argentina
Posts: 30
Thanks: 2
Thanked 4 Times in 4 Posts
Question phpmyadmin Error #1045

Hi, im getting that error when i try to log over web on phpmyadmin using a user and its password for a database. I can login as root user without a problem in phpmyadmin, and i can access to the database with the user/pass from the command line with mysql so i know that the user/pass are both fine, is just when i try to login trought phpmyadmin that i have the problem, any hints??

Thks in advance.


P.S.: Im using debian squeeze + ispconfig3 last version.
Reply With Quote
Sponsored Links
  #2  
Old 1st September 2011, 18:22
Ben Ben is offline
Moderator
 
Join Date: Jul 2006
Posts: 1,029
Thanks: 7
Thanked 62 Times in 56 Posts
Default

What is the exact error message, not only the error code?

Did you maybe restrict the user to allow access from loopback, only but configured mysql to access the public IP?
Reply With Quote
  #3  
Old 1st September 2011, 18:39
JEU JEU is offline
Member
 
Join Date: Jan 2008
Location: Argentina
Posts: 30
Thanks: 2
Thanked 4 Times in 4 Posts
Default

Quote:
What is the exact error message, not only the error code?
"#1045 El servidor MySQL no autorizó su ingreso" (spanish)

Quote:
Did you maybe restrict the user to allow access from loopback, only but configured mysql to access the public IP?
mysql is on default config (or the config that ispconfig3 installer modified by itself)

Let me clarify:

I created a client "myclient"
I created a site "mysite" for that client and then a database "mysitedb" for that site, then i created a user "dbadmin" for "mysitedb", when i try to log him over phpmyadmin to access his db (mysitedb) i got that error.

Besides, if i log in phpmyadmin with root / rootpass does work (and i see mysitedb), if i test the user "dbadmin" in command line, works fine against mysql and i can access "mysitedb", the problem is when i try to log with that user over phpmyadmin to access its database.

Last edited by JEU; 1st September 2011 at 18:44.
Reply With Quote
  #4  
Old 2nd September 2011, 10:40
Ben Ben is offline
Moderator
 
Join Date: Jul 2006
Posts: 1,029
Thanks: 7
Thanked 62 Times in 56 Posts
Default

Well maybe sb. else can help regarding the mysql users created with ispconfig 3 as I do not know the process.

Quote:
Besides, if i log in phpmyadmin with root / rootpass does work (and i see mysitedb), if i test the user "dbadmin" in command line, works fine against mysql and i can access "mysitedb", the problem is when i try to log with that user over phpmyadmin to access its database.
So how is your mysql server configured in phpmyadmin? When configuring it to use "localhost" it ignores the port and uses the local socket instead (as the mysql client does on the commandline). If entering the IP-Adress (127.0.0.1 or the external host IP) it does not.
If then the mysql user you are referring to is added with no remote access allowed the authentication will fail.

So what you should check, is the "Host" entry in the User-table of the mysql database for the referred users:
Quote:
use mysql;
SELECT Host, User FROM `user`;
localhost means no remote connection, whereas e.g. % means connections from anywhere.

After that you should check the configuration of your mysql server in phpmyadmin.
Reply With Quote
The Following User Says Thank You to Ben For This Useful Post:
JEU (2nd September 2011)
  #5  
Old 2nd September 2011, 12:06
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,041
Thanks: 826
Thanked 5,384 Times in 4,231 Posts
Default

Please post a screenshot of the database settings of this databse in ispconfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 2nd September 2011, 18:30
JEU JEU is offline
Member
 
Join Date: Jan 2008
Location: Argentina
Posts: 30
Thanks: 2
Thanked 4 Times in 4 Posts
Default

Quote:
Originally Posted by till View Post
Please post a screenshot of the database settings of this databse in ispconfig.
Code:
cat /etc/phpmyadmin/config-db.php

<?php
##
## database access settings in php format
## automatically generated from /etc/dbconfig-common/phpmyadmin.conf
## by /usr/sbin/dbconfig-generate-include
## Thu, 25 Aug 2011 16:21:19 -0300
##
## by default this file is managed via ucf, so you shouldn't have to
## worry about manual changes being silently discarded.  *however*,
## you'll probably also want to edit the configuration file mentioned
## above too.
##
$dbuser='';
$dbpass='';
$basepath='';
$dbname='';
$dbserver='';
$dbport='';
$dbtype='mysql';
Attached Images
 
Reply With Quote
  #7  
Old 2nd September 2011, 19:32
JEU JEU is offline
Member
 
Join Date: Jan 2008
Location: Argentina
Posts: 30
Thanks: 2
Thanked 4 Times in 4 Posts
Default

Update!!

Following the advice of Ben Fixed It!!

Thks guys u r really awesome
Reply With Quote
  #8  
Old 2nd September 2011, 22:04
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
Default

How did you fix it? did you add a remote IP in the panel?
Reply With Quote
  #9  
Old 2nd September 2011, 22:18
JEU JEU is offline
Member
 
Join Date: Jan 2008
Location: Argentina
Posts: 30
Thanks: 2
Thanked 4 Times in 4 Posts
Default

No, checked myphpadmin configuration and was fine, then logged on mysql and checked the user rows on the users table of mysql and was a mess, so i fixed that, cleared cookies on ffox and then it worked
Reply With Quote
  #10  
Old 2nd September 2011, 22:23
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
 
Default

Quote:
Originally Posted by JEU View Post
No, checked myphpadmin configuration and was fine, then logged on mysql and checked the user rows on the users table of mysql and was a mess, so i fixed that, cleared cookies on ffox and then it worked
So, in mysql database you replace localhost for IP of server with phpmyadmin for every user?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
phpmyadmin stops authenticating, mysql does fine isn General 2 8th January 2010 16:57
Phpmyadmin update error code 1? treavle Installation/Configuration 1 16th December 2009 13:35
httpd and phpmyadmin recirect issue moglia Developers' Forum 5 11th August 2009 12:52
phpMyAdmin goes PHP5 & MySQL5 Hans General 5 28th September 2008 20:46
phpmyadmin problem on ubuntu mail server virtual domains almeister9 HOWTO-Related Questions 1 19th September 2008 16:52


All times are GMT +2. The time now is 10:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.