#1  
Old 16th August 2011, 07:05
xalu xalu is offline
Junior Member
 
Join Date: Aug 2011
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default Ispconfig stopped working

I installed ispconfig following one of the tutorials here for "The Perfect Server" on ubuntu 10.10.

Everything worked fine. Now, I am having issues with creating sites.When I add a new website, the folders aren't created and the website is on the "It works" page rather than the index for ispconfig.

I don't believe I did any changes but I can't be sure. Any advice on debugging the issue would be awesome.
Reply With Quote
Sponsored Links
  #2  
Old 16th August 2011, 11:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,037
Thanks: 841
Thanked 5,659 Times in 4,466 Posts
Default

Do you see any pending jobs in the jobqueue of the ispconfig monitor?
Are there any errors in the ispconfig system log in the monitor?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 16th August 2011, 11:36
xalu xalu is offline
Junior Member
 
Join Date: Aug 2011
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have 5 pages of Jobqueue. I am guessing this is the issue.

Nothing abnormal in the system log.
Reply With Quote
  #4  
Old 16th August 2011, 11:41
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,037
Thanks: 841
Thanked 5,659 Times in 4,466 Posts
Default

Which ISPConfig version do you have installed?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 16th August 2011, 11:42
xalu xalu is offline
Junior Member
 
Join Date: Aug 2011
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have 3.0.3.3
Reply With Quote
  #6  
Old 16th August 2011, 13:24
xalu xalu is offline
Junior Member
 
Join Date: Aug 2011
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I used /usr/local/ispconfig/server/server.sh to get it to run. That cleared my queue. Apparently my cron is broken somewhere.

After the queue cleared the domain is pointing to a 403 error that looks like its through ispconfig.

I am getting this in the domains error log

[Tue Aug 16 06:16:56 2011] [error] [client xx.xxx.xx.xx] client denied by server configuration: /var/www/domain.com/web
Reply With Quote
  #7  
Old 16th August 2011, 13:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,037
Thanks: 841
Thanked 5,659 Times in 4,466 Posts
Default

Please post the output of:

ls -la /var/www/domain.com/web
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 16th August 2011, 13:50
xalu xalu is offline
Junior Member
 
Join Date: Aug 2011
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I figured it out. It was being caused by the fact that I deleted and added the site back before the cron could run. So, once I deleted the site, ran the cron, added the site, ran the cron. Everything is working. Now I just have to fix the cron.

Thanks for the help.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Updated to 3.0.3.3 and SSL/8080 stopped working eko_taas Installation/Configuration 6 24th April 2011 05:34
SquirrelMail login not working glenneh Installation/Configuration 13 9th April 2011 21:01
Sites stopped working Toucan Installation/Configuration 21 4th January 2010 00:27
ISPConfig stopped working malder General 3 8th December 2006 11:22
ISPConfig - receivng mails from external not working gallen Server Operation 1 30th November 2006 10:17


All times are GMT +2. The time now is 03:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.