Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th August 2011, 21:33
mmidgett mmidgett is offline
Senior Member
 
Join Date: Aug 2006
Location: Mooresville, North Carolina - USA
Posts: 117
Thanks: 5
Thanked 14 Times in 13 Posts
Default php not working for just one site

I have one site that will not display any php. Can you help me find out why. All other sites just work just fine. HTML works as expected.

I am getting segmentation faults in my error logs, can this be the cause of it.

I am using ubuntu 10.04 32bit on this virtual host. Initially I had down graded php when 5.3 was released. I have then moved to 5.3 and everything was working fine for 2 weeks then the client called and said the site wasn't working. I almost didn't believe them because all other sites are not affected.

Its a Joomla 1.6 site that I'm having issues with.
Reply With Quote
Sponsored Links
  #2  
Old 10th August 2011, 23:52
mmidgett mmidgett is offline
Senior Member
 
Join Date: Aug 2006
Location: Mooresville, North Carolina - USA
Posts: 117
Thanks: 5
Thanked 14 Times in 13 Posts
Default

Update

I deleted the site and waited a few and re-created the site. Then my php info test worked but when I unzipped the site and put it back it still doesn't load. I'm Kinda scratching my head on this one, I have checked ownership and file permissions but cant figure it out. I have turned off SEF and still nothing goes. I'll have to look further now I can get a php info test to display.

If you want I'll give the line for the php test

Last edited by mmidgett; 12th August 2011 at 21:24.
Reply With Quote
  #3  
Old 11th August 2011, 12:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Can you post the errors from the Apache error log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 12th August 2011, 21:20
mmidgett mmidgett is offline
Senior Member
 
Join Date: Aug 2006
Location: Mooresville, North Carolina - USA
Posts: 117
Thanks: 5
Thanked 14 Times in 13 Posts
Default

mmidgett@webster:~$ sudo /usr/local/ispconfig/server/server.sh
finished.
/usr/local/ispconfig/server/server.sh: line 7: 17318 Segmentation fault /usr/bin/php -q /usr/local/ispconfig/server/server.php
mmidgett@webster:~$ sudo service apache2 stop
* Stopping web server apache2 [ OK ]
mmidgett@webster:~$ sudo service apache2 start
* Starting web server apache2 [ OK ]
mmidgett@webster:~$ vi /var/log/apache2/error.log
[Fri Aug 12 14:10:06 2011] [notice] child pid 18949 exit signal Segmentation fault (11)
[Fri Aug 12 14:10:07 2011] [notice] child pid 18950 exit signal Segmentation fault (11)
[Fri Aug 12 14:10:08 2011] [error] [client 69.132.116.10] PHP Notice: Undefined variable: html_server in /usr/local/ispconfig/interface/web/monitor/show_sys_state.php on line 237, referer: https://webster.trickhosting.biz:8080/index.php
[Fri Aug 12 14:10:08 2011] [error] [client 69.132.116.10] PHP Notice: Undefined index: unknown in /usr/local/ispconfig/interface/web/monitor/show_sys_state.php on line 255, referer: https://webster.trickhosting.biz:8080/index.php
[Fri Aug 12 14:10:08 2011] [error] [client 69.132.116.10] PHP Notice: Undefined index: info in /usr/local/ispconfig/interface/web/monitor/show_sys_state.php on line 256, referer: https://webster.trickhosting.biz:8080/index.php
[Fri Aug 12 14:10:08 2011] [error] [client 69.132.116.10] PHP Notice: Undefined index: critical in /usr/local/ispconfig/interface/web/monitor/show_sys_state.php on line 258, referer: https://webster.trickhosting.biz:8080/index.php
[Fri Aug 12 14:10:08 2011] [error] [client 69.132.116.10] PHP Notice: Undefined index: error in /usr/local/ispconfig/interface/web/monitor/show_sys_state.php on line 259, referer: https://webster.trickhosting.biz:8080/index.php
[Fri Aug 12 14:10:08 2011] [error] [client 69.132.116.10] PHP Notice: Undefined variable: description in /usr/local/ispconfig/interface/web/monitor/show_sys_state.php on line 72, referer: https://webster.trickhosting.biz:8080/index.php
@ 10722,1 99%
Reply With Quote
  #5  
Old 13th August 2011, 10:58
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,736
Thanks: 840
Thanked 5,597 Times in 4,408 Posts
 
Default

Please post the errors from the error.log of the website that is not working. The errors you posted above are from the global error.log file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PHP code for PHPMyAdmin is not parsed parkerj Installation/Configuration 3 26th May 2009 14:40
Really Simple DNS Question andysm849 Server Operation 4 21st October 2008 00:32
Slightly Confused (DNS & Server Help) JohnnyBGoode Installation/Configuration 26 14th August 2007 10:54
new site is pointed main site mishko Installation/Configuration 3 27th January 2007 14:58
ubuntu ispconfig joomla .htaccess steve1084 General 8 6th January 2007 16:55


All times are GMT +2. The time now is 03:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.