Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th July 2011, 11:56
qiubosu qiubosu is offline
Senior Member
 
Join Date: Jan 2010
Posts: 141
Thanks: 2
Thanked 0 Times in 0 Posts
Default How to create a SSL website in ISPConfig 3?

I follow the ISPConfig 3 tutorial to create a SSL website. After select the "Create Certificate" and wait for nearly 30 minutes, but there is still no information filled in the SSL request, SSL certificate and SSL bundle fields. Why?

several months ago, I created a SSL website (within the same LAN and with the same IP) in the same way and it worked, then I deleted the SSL certificate very soon, because I didn't need a SSL website then. Does this have any impact to the SSL certificate I tried to create now?

By the way, the IP address is static local IP, i.e. 192.168.x.x.

Last edited by qiubosu; 30th July 2011 at 12:31.
Reply With Quote
Sponsored Links
  #2  
Old 31st July 2011, 16:02
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

1) Make sure that you use the latest ispconfig version (3.0.3.3)
2) Check that you have not entered any special chars beside of a-z and 0-9 into the input firlds for the certificate details. Special chars might cause that openssl fails to create the ssl certificate.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 1st August 2011, 03:52
qiubosu qiubosu is offline
Senior Member
 
Join Date: Jan 2010
Posts: 141
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default

1) Make sure that you use the latest ispconfig version (3.0.3.3)

i'm using 3.0.3.1 at the moment, but when run ispconfig_update.sh, got
"sh: update_from_tgz.sh: No such file or directory" error, why?

2) Check that you have not entered any special chars beside of a-z and 0-9 into the input firlds for the certificate details. Special chars might cause that openssl fails to create the ssl certificate.

it is empty in any of the certificate detail fields.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Adding SSL certificate to Site snowfly Installation/Configuration 2 31st May 2011 13:54
Creating SSL website with Trusted SSL certificate Stown Installation/Configuration 2 12th November 2010 19:20
Ftp problems timeout reny2000 General 6 23rd December 2009 12:09
Install a Comodo InstantSSL Certificate for ISPconfig Apache, Postfix, Imap & Pop gwa7 Tips/Tricks/Mods 1 30th September 2009 19:08
ISPConfig 2.3.2-dev released till General 9 4th June 2007 11:46


All times are GMT +2. The time now is 21:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.