Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th July 2011, 23:30
midcarolina midcarolina is offline
Senior Member
 
Join Date: Jul 2011
Posts: 254
Thanks: 1
Thanked 5 Times in 5 Posts
Default Public IP Vs. Private IP, DNS, and NAT

Ok, after an extremely successful install of ISPConfig 3 using HowToForge's tutorial (walk-through) for Fedora version 14 x86_64, I am a bit stumped. I am having trouble wrapping my head around proper IP usage, and DNS in the system. Ok, first let me say that during install, I created a static IP for the server using 192.168.1.XX. Inside the network, I can access 192.168.1.XX:8080 perfectly. If I leave of :8080 (still inside my network), the Fedora / Apache test page resolves. Publicly, (remote access) does not work. I have the proper port forwarding using a Cisco E1000 router.

Here is the part that has me mixed-up. My public IP (modem) is 173.93.151.XX This IP (without :8080 for ISPC access) also resolves the Fedora test page. Adding :8080 to the modem IP is page not found.

Using the "Monitor" tab to check the system, everything is a greenlight (online). So, here are the bottom line issues I am trying to remedy:

Am I using the proper static IP 192.168.1.XX and if so, why is port forwarding not working correctly?

What are the correct DNS IP's? Are they the ones from my ISP, or can I create my own?

Finally, there are so many various options for static DNS and NAT settings in the router configuration that I simply do know what to use. I have been messing with DNS records and VDS or VPServers for quite some time, but this is my first experience creating my own "at home" production webserver, so I have now become a DNS / IP dummy. I am attaching a small screenshot of what ISPConfig shows under "Monitor".

Thanks in advance for the help.
Attached Images
 
Reply With Quote
Sponsored Links
  #2  
Old 18th July 2011, 10:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by midcarolina View Post
Adding :8080 to the modem IP is page not found.
You must configure your router to forward port 8080 to your ISPConfig server.

Quote:
Originally Posted by midcarolina View Post
Am I using the proper static IP 192.168.1.XX and if so, why is port forwarding not working correctly?
When you created your sites in ISPConfig, make sure you used your internal IP (192.168.1.x). Also, you router must forward port 80 to your ISPConfig server (I guess it does this already because you get the Fedora test page). Also, make sure you access your web sites using their domain names - if you use the public IP, you will always get the Fedora test page. Of course, for this to work, the domain's DNS records must point to your public IP.

Quote:
Originally Posted by midcarolina View Post
What are the correct DNS IP's? Are they the ones from my ISP, or can I create my own?
For DNS records, you must use the public IP because otherwise nobody from outside your LAN can access your sites.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 18th July 2011, 18:24
midcarolina midcarolina is offline
Senior Member
 
Join Date: Jul 2011
Posts: 254
Thanks: 1
Thanked 5 Times in 5 Posts
Default

Hi Falko,

Ok, this is the part that gets me. Port forwarding is on in the router for a number of ports that I would need for the server to operate (i.e., 21-ftp,22-ssh,25-smtp, etc. this includes 80 for http:// and 8080) Still no go? So this I am still stumped on.

The answer for DNS helped a bit, except one item. Do I use the two DNS ips assigned by my ISP for DNS? They are of course the same, except one ends in 51 and the other 52. Or do I use the single public modem IP, in which case their is only one. My nameservers I created myself at my domain registrar, godaddy.
They are accepted (by godaddy) using the public modem ip and the ISP provider's two DNS ips, using ns1.example.com, and ns2.example.com.

Much appreciate your time!
Reply With Quote
  #4  
Old 19th July 2011, 10:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by midcarolina View Post
Ok, this is the part that gets me. Port forwarding is on in the router for a number of ports that I would need for the server to operate (i.e., 21-ftp,22-ssh,25-smtp, etc. this includes 80 for http:// and 8080) Still no go? So this I am still stumped on.
Check your router's firewall. It is also possible that your ISP blocks some ports.

Quote:
Originally Posted by midcarolina View Post
The answer for DNS helped a bit, except one item. Do I use the two DNS ips assigned by my ISP for DNS? They are of course the same, except one ends in 51 and the other 52. Or do I use the single public modem IP, in which case their is only one. My nameservers I created myself at my domain registrar, godaddy.
They are accepted (by godaddy) using the public modem ip and the ISP provider's two DNS ips, using ns1.example.com, and ns2.example.com.
If you refer to /etc/resolv.conf, you can put your ISP's DNS servers there (but you don't have to if name resolution is working already).
For your zones, you must use the public modem IP, and as the nameservers in your zones, you use ns1 and ns2.example.com.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 19th July 2011, 18:02
midcarolina midcarolina is offline
Senior Member
 
Join Date: Jul 2011
Posts: 254
Thanks: 1
Thanked 5 Times in 5 Posts
 
Default

Hi Falko,
Ok, regarding the router. I did two things. I called my ISP and (I looked-up the FCC laws on this too) informed them that US law states that an ISP - under no circumstance has the right to block any port range from 1 - 65535. They told me that none of the ports were blocked in the modem. So, I temporarily disabled the modem firewall. Still no go. Only within the network.

The DNS IPs are showing-up just fine in ISPConfig as active, they are included in /etc/hosts (per ISPConfig manual) and in /etc/resolv.conf Only I get a DNS error page from my ISP (Time Warner) when I tried to launch a simple site.

I could use godaddy's nameservers and point the A record @ to the public IP of the modem, but theoretically I would lose mail control in ISPConfig and this would have to be done through godaddy which I really don't want to do.

Thanks for your patience.
Reply With Quote
Reply

Bookmarks

Tags
dns, nat, public ips

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
NAT Gateway, Iptables, Port Forwarding, DNS And DHCP Setup - Ubuntu 8.10 Server av1611 HOWTO-Related Questions 1 31st August 2009 12:10
1:1 NAT on Ubuntu Server Seth HOWTO-Related Questions 5 21st January 2009 02:19
ispconfig behind firewall using NAT bigger_travis Installation/Configuration 3 5th November 2008 18:54
DNS Issues Alam Installation/Configuration 3 11th November 2006 13:57
DNS, rDNS, NAT and vhosts, oh my! Hyakugei Installation/Configuration 2 19th May 2006 16:23


All times are GMT +2. The time now is 00:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.