Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th June 2011, 13:51
mike_p mike_p is offline
Senior Member
 
Join Date: Mar 2010
Location: Surrey, England
Posts: 140
Thanks: 9
Thanked 28 Times in 17 Posts
Default DNS Potentially causing problems for mail server

Hi

I've got a ISPConfig/Centos5 server that has recently been running very happily.

Unfortunately I have started to come across news that various people trying to send email to one of the domains on my server are having them returned with the message

"Sorry, I couldn't find any host by that name. (#4.1.2)
Despite repeated attempts, this message could not be delivered."

BUT mail from other companies is arriving very happily.

When my client first reported some emails not arriving, I checked my mail logs and cannot find any attempts by the other company's server to connect and deliver. (But did find frequent emails being received from that company up until the 10th June)

I have checked my DNS settings using DIG. Everything seems in order.
When checking the domain, an MX record was found. When digging the mx record, an 'A' record with the correct IP address is found.

The PTR record for the IP address appears to be correctly set.

Any ideas about what is going on?

Last edited by mike_p; 30th June 2011 at 13:52. Reason: typo
Reply With Quote
Sponsored Links
  #2  
Old 30th June 2011, 15:57
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
 
Default

What values do you have for TTL (and others) for your entire zone?

Here in Argentina, some ISP have problems when have to refresh information for domains, if the TTL is larger... I had to set it to 7200-14400 (2-4 hs) to fix this. I have no problems right now.

When it was set to 24hs, sometimes my domain was not responding to ping...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPconfig setup - DNS, router and general access problems ingvar Installation/Configuration 6 31st July 2010 13:13
Debian 5 Ajax error + network interface always shutting down ev0css Installation/Configuration 3 5th June 2010 12:58
ISPConfig3 Mail Warn Errors reason8 General 3 25th November 2009 13:58
DNS Configuration Problems VMartins Installation/Configuration 10 24th July 2007 14:40
Problems with Postfix Mysql Courier PatrickAdrichem Installation/Configuration 3 13th April 2007 15:44


All times are GMT +2. The time now is 22:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.