Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 12th May 2006, 00:22
sw33t sw33t is offline
Junior Member
 
Join Date: May 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem with retrieving mail after using ISPConfig

I am a newbie user and I setup the latest version of ISPConfig.

I used the Debian Sarge Howto to setup my box. I am using

Postfix -> Courier POP+IMAP -> Procmail -> Maildir

I am able to send and receive email but the only problem is I can't retrieve it via Thunderbird (POP3 or IMAP over TLS). Everything is authenticated and Thunderbird communicates with the mail server (my box). I am not sure what I am doing wrong.. Here are some relevant snippets..

A. Sending email from user@gmail.com to ray@myvirtualdomain1.com

FROM /var/log/mail.log

May 11 17:14:54 s79648 postfix/smtpd[7747]: connect from nf-out-0910.google.com[64.233.182.187]
May 11 17:14:54 s79648 postfix/smtpd[7747]: 6C08C3081F2: client=nf-out-0910.google.com[64.233.182.187]
May 11 17:14:54 s79648 postfix/cleanup[7750]: 6C08C3081F2: message-id=<a5e73b760605111513p74d48fffm2a1a63a694cb898b@m ail.gmail.com>
May 11 17:14:54 s79648 postfix/qmgr[7593]: 6C08C3081F2: from=<user@gmail.com>, size=1669, nrcpt=1 (queue active)
May 11 17:14:55 s79648 postfix/pickup[7592]: 65B6A30820C: uid=10002 from=<web5_ray>
May 11 17:14:55 s79648 postfix/cleanup[7750]: 65B6A30820C: message-id=<20060511221454.65B6A30820C@s79648.servername.c om>
May 11 17:14:55 s79648 postfix/qmgr[7593]: 65B6A30820C: from=<web5_ray@servername.com>, size=363, nrcpt=1 (queue active)
May 11 17:14:55 s79648 postfix/local[7768]: 65B6A30820C: to=<admispconfig@localhost>, relay=local, delay=1, status=sent (delivered to command: /usr/bin/procmail -f-)
May 11 17:14:55 s79648 postfix/qmgr[7593]: 65B6A30820C: removed
May 11 17:14:57 s79648 postfix/local[7751]: 6C08C3081F2: to=<web5_ray@servername.com>, orig_to=<ray@virtualdomain1.com>, relay=local, delay=3, status=sent (delivered to command: /usr/bin/procmail -f-)
May 11 17:14:57 s79648 postfix/qmgr[7593]: 6C08C3081F2: removed


B. POSTFIX CONFIG FILE: /etc/postfix/main.cf
----------------------------------------------
# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
localhost
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command =
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
home_mailbox = Maildir/
virtual_maps = hash:/etc/postfix/virtusertable
mydestination = /etc/postfix/local-host-names


C. VIRTUAL MAPS - /etc/postfix/virtusertable

###################################
#
# ISPConfig virtusertable Configuration File
# Version 1.0
#
###################################
ray@www.virtualdomain1.com web5_ray
web5_ray@www.virtualdomain1.com web5_ray
ray@virtualdomain1.com web5_ray
web5_ray@virtualdomain1.com web5_ray
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
web5_ray@servername.com web5_ray



D. LOCAL HOST NAMES: /etc/postfix/local-host-names

###################################
#
# ISPConfig local-host-names Configuration File
# Version 1.0
#
###################################
localhost
s79648.servername.com
localhost.s79648.servername.com
localhost.servername.com
www.virtualdomain1.com
virtualdomain1.com
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
servername.com





Any input will be highly appreciated.

Thanks.

Sw33t
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Not receiving any incoming mail. Jcorrea920 General 11 3rd April 2010 13:08
ISPCONFIG and mail appearance problem pirinas1980 Installation/Configuration 1 11th March 2006 14:02
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 11:47
Problem sending mail to 2nd SMTP server inside network kisong Server Operation 2 2nd March 2006 18:05
Traffic Exceedance Mail Problem krishol General 4 17th February 2006 10:38


All times are GMT +2. The time now is 06:37.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.