Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st June 2011, 09:17
thibotus01 thibotus01 is offline
Member
 
Join Date: Oct 2009
Posts: 89
Thanks: 2
Thanked 2 Times in 2 Posts
Question Ispconfig panel Change to port 80

Hi,

I have just installed on default port 8080, but I'd like to change it to port 80, that I can access to the panel directly without ":8080".

How can I change this? I cannot find any correct answer... (not using reverse proxy...)

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 21st June 2011, 09:49
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,981
Thanks: 825
Thanked 5,371 Times in 4,218 Posts
Default

You can only change the port to 80 when you do not run any websites on this server. Otherwise port 80 is required for the websites vhosts and you have to use a port like 8080 for ispconfig.

So if you do not run any websites or other vhosts on port 80, then you can change the port number of the ispconfig vhost in the ispconfig.vhost file in /etc/apache2/sites.available/ and restart apache afterwards.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 21st June 2011, 10:51
thibotus01 thibotus01 is offline
Member
 
Join Date: Oct 2009
Posts: 89
Thanks: 2
Thanked 2 Times in 2 Posts
Default

The panel has his own IP so it's fine.

With SSL, it must be like this :

Code:
# Listen 80
NameVirtualHost *:80

<VirtualHost _default_:443>
It works Thanks
Reply With Quote
  #4  
Old 21st June 2011, 16:01
thibotus01 thibotus01 is offline
Member
 
Join Date: Oct 2009
Posts: 89
Thanks: 2
Thanked 2 Times in 2 Posts
Default

Is it normal that I can't access to phpmyadmin via https ?

https = 404 (https://ispconfig.panel.com/phpmyadmin
http = works fine (http://ispconfig.panel.com/phpmyadmin)

I set the URL in the "Interface config".
Reply With Quote
  #5  
Old 21st June 2011, 16:03
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,981
Thanks: 825
Thanked 5,371 Times in 4,218 Posts
Default

phpmyadmin works on the apache default vhost configured by the linux distribution. Do if you have a defauklt vhost for https, you should be able to access phpmyadmin trogh https as well. Otherwise you can access phpmyadmin only with http.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 21st June 2011, 16:07
thibotus01 thibotus01 is offline
Member
 
Join Date: Oct 2009
Posts: 89
Thanks: 2
Thanked 2 Times in 2 Posts
Default

As I paste before, My default vhost for https is ispconfig.

error log : File does not exist: /usr/local/ispconfig/interface/web/phpmyadmin
Reply With Quote
  #7  
Old 21st June 2011, 16:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,981
Thanks: 825
Thanked 5,371 Times in 4,218 Posts
Default

ISPConfig is not the default vhost of a server. ISPConfig has its own separate vhost file. The default vhost file is named default and comes from the linux distribution. You can find it in the sites-enabled directory.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 21st June 2011, 16:34
thibotus01 thibotus01 is offline
Member
 
Join Date: Oct 2009
Posts: 89
Thanks: 2
Thanked 2 Times in 2 Posts
 
Default

Hum... That's what I thought but in default I got :

<VirtualHost *:80>

If I put 443, all the websites will turn on https?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
port ssh 22 and ispconfig port 81 userman General 2 11th April 2011 15:19
Weird problem: ISPconfig 3 control Panel not reachable while sites work fine sheshes Installation/Configuration 2 3rd February 2010 19:29
Mail Question: installed smf forum on centos perfect server setup with ispconfig happz Installation/Configuration 7 22nd August 2008 13:15
[SOLVED] no access to control panel (port 81) atrias Installation/Configuration 6 22nd June 2008 23:21
Change URI of ISPConfig and put on port 80, still using https DualFusion Installation/Configuration 9 14th December 2007 13:11


All times are GMT +2. The time now is 19:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.