Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 16th June 2011, 07:10
comex comex is offline
Junior Member
 
Join Date: Jun 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi, I"m also facing the same issue, but on a VM with CentOs5.6 and ISPConfig3.
Reply With Quote
Sponsored Links
  #12  
Old 27th September 2011, 09:13
Thesee Thesee is offline
Junior Member
 
Join Date: Apr 2010
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default solved?

Did you solved?
I migrated all the production vhost on a second server, all is working great.
Then I re-installed centos but without the required software setup for ispconfig3
All was working good.
Then i reinstalled centos with the software required for ispconfig 3:
apache hangs without traffic!!!

Probably is related to some software configuration (i followed the how-to guide) but i dont know what to check.

Regards.
Reply With Quote
  #13  
Old 27th September 2011, 10:01
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,175
Thanks: 829
Thanked 5,412 Times in 4,255 Posts
Default

Which errors do you get in the apache error.log file?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #14  
Old 27th September 2011, 13:23
Thesee Thesee is offline
Junior Member
 
Join Date: Apr 2010
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

here the lines before crash

Code:
[error] server reached MaxClients setting, consider raising the MaxClients setting
This happen because httpd hangs and then all requests are queued, within minutes the queue becomes full

httpd config

Code:
Timeout 150
KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 8
<IfModule prefork.c>
    StartServers          30
    MinSpareServers       10
    MaxSpareServers      20
    ServerLimit		100
    MaxClients          100
    MaxRequestsPerChild   8000
</IfModule>

Last edited by Thesee; 27th September 2011 at 13:26. Reason: added apache config
Reply With Quote
  #15  
Old 27th September 2011, 14:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,175
Thanks: 829
Thanked 5,412 Times in 4,255 Posts
Default

It might be that perl modules are missing on your server which causes the apache vhost logging /vlogger) to fail. Please search the error log if there are any errors for vlogger inside.

You can also run the command:

vlogger -v

to see if you get any errors.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #16  
Old 27th September 2011, 14:52
Thesee Thesee is offline
Junior Member
 
Join Date: Apr 2010
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

vlogger -v
Code:
vlogger -v
VLogger 1.3 (apache logfile parser)
Written by Steve J. Kondik <shade@chemlab.org>

This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
no vlogger entries on log files, seems is working good.

any clue?
Reply With Quote
  #17  
Old 27th September 2011, 15:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,175
Thanks: 829
Thanked 5,412 Times in 4,255 Posts
Default

Ok. Just to be absolutely sure that not vlogger is causing this, edit the ispconfig.vhost file (which is in the sites-available folder in the /etc/httpd config folder) and comment out the custom_log directive and then restart apache.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #18  
Old 27th September 2011, 16:09
Thesee Thesee is offline
Junior Member
 
Join Date: Apr 2010
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Till,
on ispconfig.vhost file the custom_log directive is already commented out.

there is an ispconfig.conf file with
Code:
CustomLog "| /usr/local/ispconfig/server/scripts/vlogger -s access.log -t \"%Y%m%d-access.log\" -d \"/etc/vlogger-dbi.conf\" /var/log/ispconfig/httpd" combined_ispconfig
maybe you was referring to this file?
should i also comment out this?
Reply With Quote
  #19  
Old 27th September 2011, 16:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,175
Thanks: 829
Thanked 5,412 Times in 4,255 Posts
Default

you are right, i meant that file please comenr it out in ispconfig.conf
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #20  
Old 27th September 2011, 16:37
Thesee Thesee is offline
Junior Member
 
Join Date: Apr 2010
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Ok commented out!
Code:
#CustomLog "| /usr/local/isp.....
httpd restarted

I'll let you know
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPconfig is not processing apache logs: the web Traffic overview and stats are gone KingBeto General 12 15th January 2010 18:00
trying to install roundcubemail ressel Installation/Configuration 13 24th December 2009 20:13
problems with suexec gobokster Installation/Configuration 7 7th May 2009 13:33
CENTOS 5 Ping Problem gAnDo Server Operation 11 28th March 2008 20:58
Problem with the installation of Dokeos (LMS) in ISPConfig jofranco General 4 28th April 2006 00:45


All times are GMT +2. The time now is 16:50.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.