Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th May 2011, 17:40
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Unhappy Cronjob: Mailserver doesn't work as well

Hi guys

I get this error in my mail server:

Code:
root@mailserver:~# /usr/local/ispconfig/server/server.sh
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626+lfs/gd.so' - /usr/lib/php5/20090626+lfs/gd.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626+lfs/imap.so' - /usr/lib/php5/20090626+lfs/imap.so: cannot open shared object file: No such file or directory in Unknown on line 0
sh: repquota: not found
sh: repquota: not found
/usr/bin/fail2ban-client
finished.
what have I to do?

Last edited by vaio1; 18th May 2011 at 17:57.
Reply With Quote
Sponsored Links
  #2  
Old 20th May 2011, 01:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Which distribution do you use?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 20th May 2011, 09:16
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

I am using the Debian distro.
Reply With Quote
  #4  
Old 22nd May 2011, 21:27
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Try to install the missing packages as follows:

Code:
apt-get install php5-gd php5-imap
Restart Apache afterwards.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 22nd May 2011, 22:49
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

Good evening Falko,

thanks for your reply but the server is the mail server not the webserver. Is it a multiserver tutorial problem?

thanks
Reply With Quote
  #6  
Old 23rd May 2011, 10:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Not sure what happened, but somehow these libraries are referenced in your PHP configuration, but not installed. You can either try to install the missing packages (as outlined before) or try to remove the references from the /etc/php5/conf.d/ directory.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 23rd May 2011, 10:26
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

So these libraries are not mandatories in the mail server, right?
Reply With Quote
  #8  
Old 24th May 2011, 17:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

I don't think so.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
vaio1 (24th May 2011)
  #9  
Old 24th May 2011, 18:00
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
 
Default

Perfect! Seems that the problem is disappeared.

Quote:
root@mailserver:~# /usr/local/ispconfig/server/server.sh
finished.
Reply With Quote
Reply

Bookmarks

Tags
cronjob, errors, gd.so, imap.so, mailservers

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
make this work please peacengell Programming/Scripts 2 4th February 2009 08:55
running a mailserver fom vmware work station wiseman Server Operation 5 6th January 2009 10:20
Virtual users... Ubuntu 8.04 spaceuser HOWTO-Related Questions 12 19th June 2008 09:04
Mailserver 554 Permanent Problems Message asyadiqin Server Operation 7 15th November 2007 16:09
Cant get any messenger program to work SimplyMepis 6.0 gtoman Technical 1 13th November 2006 16:26


All times are GMT +2. The time now is 04:16.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.