Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th May 2011, 03:40
Djamu Djamu is offline
Member
 
Join Date: Sep 2007
Posts: 51
Thanks: 2
Thanked 13 Times in 7 Posts
Default ispconfig_update.sh > where did bind9 go ? EDIT: FIXED

Edit: ignore / delete this post... have it fixed already

After updating php to v5.3 I noticed numerous errors when (trying) opening ispconfig.
I ran ispconfig_update.sh and kept the default answers assuming it should be ok..
noticed > Configuring MyDNS
and don't seem to have a a functioning DNS server.. ( had bind9 installed )

server is running over a year now (was debian lenny > partially upgraded to squeeze > didn't do a full upgrade yet as it's a production server.)

I don't have a personal preference bind9 / mydns as long as it's functional.

ispconfig was 3.0.1 ( or even lower ).... long time ago....

thanks in advance
__________________
Windows, the only virus you pay for

Last edited by Djamu; 20th May 2011 at 03:54.
Reply With Quote
Sponsored Links
  #2  
Old 20th May 2011, 12:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,499 Times in 4,328 Posts
Default

Seems as if Bind is not installed on your server in a way that ispconfig was able to detect it. How did you install BIND and which Linux Distribution do you use?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 20th May 2011, 19:27
Djamu Djamu is offline
Member
 
Join Date: Sep 2007
Posts: 51
Thanks: 2
Thanked 13 Times in 7 Posts
Default

Thanks Till for your prompt reply.

As stated I've had it fixed already.
( it's a heavily customized Debian lenny setup, partially upgraded to squeeze )

I didn't have time yet to look at / find the ispconfig install logs to see what went wrong.. just re-installed bind and replaced all related stuff from my backup ... and it's now happily humming again ...


Still have to solve some weird mail issues, as it seems that it rejects mails from www-data@http4.howtoforge.com on my primary domain.
Code:
do not list domain xxxxxxxxxxx in BOTH mydestination and 
virtual_mailbox_domains
I found that the updatescript changed this in my postfix main.cfg, which is incorrect


Jan
__________________
Windows, the only virus you pay for
Reply With Quote
  #4  
Old 21st May 2011, 09:27
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,499 Times in 4,328 Posts
 
Default

Seems as if the hostname of your server is invorrect then. Please set the hostname to a correct domain that is identical to the domain used in postfix main.cf. Please be aware that the hostname shall not be identical to a domain that is ued for email, so use something like server1.yourdomain.tld as hostname and not just ourdomain.tld
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
bind9, ispconfig_update.sh, mydns

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Converting from MyDNS to bind9 on Ubuntu 9.04 DantePasquale Installation/Configuration 2 6th August 2010 14:24
apt-get install bind9 <-- error stormer Installation/Configuration 13 25th January 2008 16:45
apt-get install bind9 badben Installation/Configuration 10 31st December 2007 02:00
IPSConfig 2.2.9 -> Bind9 config problem bitonw General 2 18th January 2007 10:31
Management -> Server Settings -> DNS -> Default MX doesn't work :-( ddelbia General 6 14th January 2006 14:26


All times are GMT +2. The time now is 03:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.