Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th May 2011, 19:53
MacGoose MacGoose is offline
Member
 
Join Date: Aug 2010
Posts: 37
Thanks: 2
Thanked 1 Time in 1 Post
Default Deny directory indexes doesn't work

I'm managing my server using ISPConfig. All the sites set up in ISPConfig have no problems denying directory content. If I create a new directory via ftp I will get a 403 Forbidden trying to access it.

However the default Apache site /var/www, answering on my servers IP adress on a http request, shows all directory content except for some directories like /clients. If I create a new directory via ftp it will be open for directory listing.

I've been setting Options -Indexes in .htaccess files and httpd.conf and indexes are still open.

Any ideas what to do? Am I missing something?

, MacGoose
Reply With Quote
Sponsored Links
  #2  
Old 12th May 2011, 00:58
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
Default

You must edit default settings for "default" (directory /var/www/)

In the debian, with default installation with no changes in both files, you can use it... if you have another distro or this is not your scenario, just edit manually (add "-" in Options Indexes for Directory /var/www/)

sed -i 's/Options Indexes/Options -Indexes/1' /etc/apache2/sites-available/default
sed -i 's/Options Indexes/Options -Indexes/1' /etc/apache2/sites-available/default-ssl

Regards

Edit: I am new to this... if this is not the best way, please post! :P
Reply With Quote
  #3  
Old 12th May 2011, 07:14
MacGoose MacGoose is offline
Member
 
Join Date: Aug 2010
Posts: 37
Thanks: 2
Thanked 1 Time in 1 Post
 
Default

Thanx! Worked like a charm. I'm on Ubuntu 10.04 btw...

, MacGoose
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig install issues... flyingaggie Installation/Configuration 2 18th July 2008 10:46
ISPConfig on a RaQ2 mattm Installation/Configuration 12 23rd January 2008 18:17
The PHP binary coming with ISPConfig does not work properly on your system! KalishNikova Installation/Configuration 6 6th November 2007 14:52
setup fails on debian 3.1 dtrumbower Installation/Configuration 7 7th March 2006 13:42
Update to 2.2.0 question brianetilley Installation/Configuration 10 4th March 2006 17:02


All times are GMT +2. The time now is 03:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.