#1  
Old 10th May 2011, 19:48
BoloMarkIII BoloMarkIII is offline
Member
 
Join Date: Nov 2008
Posts: 31
Thanks: 2
Thanked 0 Times in 0 Posts
Default 3rd Site e-mail problem

Ispconfig2 on Opensuse 11.3

I have a server running 3 sites everything works accept the 3rd sites email.
I have the roundcube mail add on.
The problem with the 3rd sites email is none of the accounts can receive mail.
On the 3rd site I can login to an e-mail account /w roundcubemail using the username & password but not with e-mail address and password. I can send e-mail from account but the received e-mail states it is from xxx@localhost.xxxx.com and not from the domain (xxx@xyz.com).

Here is my local-host-names
Code:
###################################
#
# ISPConfig local-host-names Configuration File
#         Version 1.0
#
###################################
localhost
vserver1.xxxx.com
localhost.vserver1.xxxx.com
localhost.xxxx.com
localhost.localdomain
www.zzz.net
www.yyy.com
www.xyz.com
zzz.net
yyy.com
xyz.com
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
The virtusertable file seems to be in order, entries for 3rd sites users are the same format as other 2 sites that work, don't really want to post it.

What else can I check ?
Reply With Quote
Sponsored Links
  #2  
Old 10th May 2011, 19:56
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Which exact error message do you get in the mail.log?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 10th May 2011, 20:57
BoloMarkIII BoloMarkIII is offline
Member
 
Join Date: Nov 2008
Posts: 31
Thanks: 2
Thanked 0 Times in 0 Posts
Default

I get this error.
Code:
Recipient address rejected: User unknown in local recipient table
Reply With Quote
  #4  
Old 10th May 2011, 21:54
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Is the recipient address listed in /etc/virtusertable ?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 10th May 2011, 22:32
BoloMarkIII BoloMarkIII is offline
Member
 
Join Date: Nov 2008
Posts: 31
Thanks: 2
Thanked 0 Times in 0 Posts
Default

virtusertable is in /etc/postfix
YES as stated above I did not want to post it.
Yes recipient is listed and all seems to be in order as the listings have the same format as users listed in the other 2 sites.
Reply With Quote
  #6  
Old 11th May 2011, 13:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Please try this:
Code:
postmap /etc/postfix/virtusertable
/etc/init.d/postfix restart
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 11th May 2011, 16:37
BoloMarkIII BoloMarkIII is offline
Member
 
Join Date: Nov 2008
Posts: 31
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Thx Falco I tried that did not work I even renamed the virtusertable.db so it would write a new one but no joy.

Ok after staring at the virtusertable file I noticed that the first site adds 4 enties:
name@www.xyz.com web1_name
web1_name@www.xyz.com web1_name
name@xyz.com web1_name web1_name
web1_name@xyz.com web1_name

Second and third site adds only 2 entries:
name@www.yyy.com web2_name
web2_name@www.yyy.com web2_name

So Ispconfig is not adding 2 entries to the virtusertable file.
Reply With Quote
  #8  
Old 11th May 2011, 17:01
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

I guess in the website www.yyy.com, the co-domain yyy.com (with empty hostname field) is missing. Or you have set this co-domain to external mailserver which disables mail for that domain.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
BoloMarkIII (11th May 2011)
  #9  
Old 11th May 2011, 21:48
BoloMarkIII BoloMarkIII is offline
Member
 
Join Date: Nov 2008
Posts: 31
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default

Thx till that fixed my problem in the co-domain tab for 2nd and third site, www.xyz.com was listed instead of xyz.com changed it now all is well thank you again.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPconfig 3.0.3.2 postfix not relaying outgoing attachments mychoice2009 Installation/Configuration 3 13th April 2011 17:42
Postfix Problem (Possible Trojan/Spam) bluegrass Server Operation 10 4th August 2010 07:37
421 Unexpected failure Lizard King Installation/Configuration 20 7th July 2009 20:43
CentoS doesn't send the emails vaio1 Installation/Configuration 18 5th November 2008 17:51
Postfix reject connections gabrix Server Operation 27 25th January 2007 08:37


All times are GMT +2. The time now is 12:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.