#1  
Old 8th June 2009, 10:46
planet_fox planet_fox is offline
Senior Member
 
Join Date: Jun 2006
Location: Munic
Posts: 308
Thanks: 14
Thanked 8 Times in 6 Posts
Send a message via Skype™ to planet_fox
Default KVM Server CPU use 100%

Hi

I have install KVM install on Debian Lenny 64. The Server uses when it run two Lenny Clients 99-100 % CPU .Is it normal ? than my debian guests runs so slowly . My Server have 4GB Ram and the clients become 512 MB ram my CPU have

here my system


Code:
 lsmod
Module                  Size  Used by
tun                    14084  2
kvm_amd                29580  0
kvm                   127464  1 kvm_amd
ipv6                  288328  24
bridge                 53544  0
ext2                   66448  1
sbp2                   25356  0
loop                   19468  0
parport_pc             31016  0
parport                41776  1 parport_pc
k8temp                  9216  0
pcspkr                  7040  0
snd_usb_audio          91296  0
snd_pcm                81672  1 snd_usb_audio
snd_timer              25744  1 snd_pcm
snd_page_alloc         13072  1 snd_pcm
snd_usb_lib            20224  1 snd_usb_audio
snd_rawmidi            26784  1 snd_usb_lib
snd_seq_device         11668  1 snd_rawmidi
snd_hwdep              12040  1 snd_usb_audio
snd                    63688  6 snd_usb_audio,snd_pcm,snd_timer,snd_rawmidi,snd_seq_device,snd_hwdep
soundcore              12064  1 snd
button                 11680  0
i2c_nforce2            10752  0
i2c_core               27936  1 i2c_nforce2
evdev                  14208  0
ext3                  124944  2
jbd                    51240  1 ext3
mbcache                12804  2 ext2,ext3
dm_mirror              20608  0
dm_log                 13956  1 dm_mirror
dm_snapshot            19400  0
dm_mod                 58864  8 dm_mirror,dm_log,dm_snapshot
sd_mod                 29376  5
ata_generic            10116  0
sata_nv                27528  3
8139too                28288  0
amd74xx                13448  0 [permanent]
libata                165600  2 ata_generic,sata_nv
scsi_mod              160760  3 sbp2,sd_mod,libata
dock                   14112  1 libata
8139cp                 23808  0
mii                     9856  2 8139too,8139cp
forcedeth              54032  0
ohci1394               32692  0
ieee1394               93816  2 sbp2,ohci1394
ide_pci_generic         9220  0 [permanent]
ide_core              128284  2 amd74xx,ide_pci_generic
ehci_hcd               35980  0
ohci_hcd               25092  0
thermal                22816  0
processor              42304  1 thermal
fan                     9352  0
thermal_sys            17728  3 thermal,processor,fan
Quote:
cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 15
model : 67
model name : Dual-Core AMD Opteron(tm) Processor 1214
stepping : 2
cpu MHz : 2211.332
cache size : 1024 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy
bogomips : 4425.27
TLB size : 1024 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc

processor : 1
vendor_id : AuthenticAMD
cpu family : 15
model : 67
model name : Dual-Core AMD Opteron(tm) Processor 1214
stepping : 2
cpu MHz : 2211.332
cache size : 1024 KB
physical id : 0
siblings : 2
core id : 1
cpu cores : 2
apicid : 1
initial apicid : 1
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy
bogomips : 4422.72
TLB size : 1024 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc
My create script for guests

Quote:
virt-install --connect qemu:///system -n lenny -r 512 --vcpus=1 --file /samba/kvm/lenny.img -s 10 -c /home/pool/debian-500-i386-netinst.iso --vnc :5 --noautoconsole --os-type linux --os-variant DebianLenny --accelerate --network=bridge:br0
Is my Server to slow for runnning 2 Clients ?
Reply With Quote
Sponsored Links
  #2  
Old 9th June 2009, 16:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Normally this should be no problem. Did you take a look at
Code:
top
on the host to find out what's eating up your resources?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 3rd May 2011, 11:46
EISGE EISGE is offline
Junior Member
 
Join Date: Apr 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi all

I have the same problem,
The CPU is always at 100%
and CPU is very slow ....

Here is how I setup a VM :

sudo dd if=/dev/zero of=nom_systeme.qcow2 bs=1024 count=5000000

virt-install --connect qemu:///system -n wiki -r 512 --vcpus=2 -f VM01.qcow2 -s 12 -c /path_iso/mini.iso --vnc --noautoconsole --os-type linux --accelerate --network=bridge:br0 --hvm

How can I have better CPU performance ?
For information the CPU, is an AMD64 and allow virtualization.

Thanks for your help

Regards
Reply With Quote
  #4  
Old 3rd May 2011, 12:39
planet_fox planet_fox is offline
Senior Member
 
Join Date: Jun 2006
Location: Munic
Posts: 308
Thanks: 14
Thanked 8 Times in 6 Posts
Send a message via Skype™ to planet_fox
Default

Whats Distribution, do you use
Reply With Quote
  #5  
Old 3rd May 2011, 14:49
EISGE EISGE is offline
Junior Member
 
Join Date: Apr 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

for the hypervisor : Ubuntu Server
Linux 2.6.35-28-server #50-Ubuntu SMP Fri Mar 18 18:59:25 UTC 2011 x86_64 GNU/Linux

for the guest : Ubuntu 10-10
Linux 2.6.35-28-generic #49-Ubuntu SMP Tue Mar 1 14:39:03 UTC 2011 x86_64 GNU/Linux
Reply With Quote
  #6  
Old 3rd May 2011, 15:10
planet_fox planet_fox is offline
Senior Member
 
Join Date: Jun 2006
Location: Munic
Posts: 308
Thanks: 14
Thanked 8 Times in 6 Posts
Send a message via Skype™ to planet_fox
Default

Can you testing on the same Maschine with an other Distribution likes Centos or Fedora. I have Yesterdays the Problem with Debian Etch and have see with an other Distribution I havent the Problem and I have solve the Problem with an Installation of Debian Squeeze. Check the Version of your livirt and Kvm Software.
Reply With Quote
  #7  
Old 3rd May 2011, 15:18
EISGE EISGE is offline
Junior Member
 
Join Date: Apr 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well

I tryed CentOS for the guest
But it doesn't change a lot of things ...


If I have to re-install the hypervisor, I think, I will try with Proxmox..

But if someone have an idea for this CPU performance, it will be great.
Reply With Quote
  #8  
Old 3rd May 2011, 16:22
planet_fox planet_fox is offline
Senior Member
 
Join Date: Jun 2006
Location: Munic
Posts: 308
Thanks: 14
Thanked 8 Times in 6 Posts
Send a message via Skype™ to planet_fox
 
Default

Its not the Problem of the Guest System, The Host System I think .
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail -Ubuntu 8.04 c4rdinal HOWTO-Related Questions 112 23rd August 2011 10:49
What can be wrong martin_rudowicz Installation/Configuration 9 11th May 2008 19:42
Problem with keeping Apache alive bobeq Server Operation 3 29th November 2007 16:11
550-The recipient cannot be verified email problem safoo Installation/Configuration 7 29th November 2006 19:55
Server sometimes (1 or 2 hrs) down :/ edge Server Operation 25 31st July 2006 13:44


All times are GMT +2. The time now is 09:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.