Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 25th April 2011, 13:58
FractalizeR FractalizeR is offline
Member
 
Join Date: Aug 2008
Posts: 44
Thanks: 0
Thanked 2 Times in 2 Posts
Question PostFix null client and multiple domains (virtual hosting)?

Hello.

I'm running PostFix on my server in null-client configuration. So postfix is used to send email only. I receive email via external email provider (Yandex mail for domains). I set my domains MX records to point to provider ones.

The problem is that my machine has several domains running on it (with php in fast-cgi configuration). And when PostFix sends email in SMTP session it says something like:

Quote:
C: HELO hostname.com
S: 250 Hello hostname.com, I am glad to meet you
C: MAIL FROM:<username@hostname.com>
Where username is the name of the system user, that invoked sendmail, and hostname is the hostname of the server.

Body of email message contains a valid email address in headers.

The problem is that many email servers reject emails on MAIL FROM command with invalid email address specified.

How do I correctly set PostFix mapping so that each Linux user had a corresponding email address to be used in SMTP communication?

I've tried to setup mapping in the /etc/aliases file and putting them to alias_map directive of main.cf, but somehow it doesn't work.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting Email Working ISPConfig3 Squirrelmail and Courier etc Ian Wilson Installation/Configuration 17 19th June 2013 22:58
mail authentication failure - unknown user or password evok Installation/Configuration 9 16th October 2010 06:37
dovecot: lda: Fatal: Unknown user dpicella Installation/Configuration 1 22nd August 2010 02:59
ERROR: Connection dropped by IMAP server. [Centos 5.4, courier imap,squirrel, etc] darevil HOWTO-Related Questions 7 9th June 2010 14:49
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39


All times are GMT +2. The time now is 12:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.