Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 29th March 2011, 14:55
Xenocide Xenocide is offline
Member
 
Join Date: Sep 2010
Posts: 54
Thanks: 12
Thanked 6 Times in 5 Posts
Default One of my servers cron's keep freezing

Hi Guys,

I've been scratching my head for a while, wonder if you can help me?

We have a multi server setup that's been working fine for ages. However now one of the webserver's crons run but keep running. The lock file is still there and the php process is still running:

Code:
[root@tupac ~]# ps aufx | grep server
root     20988  0.0  0.0  61164   716 pts/0    S+   13:50   0:00                      \_ grep server
root      5052  0.0  0.0   8704   984 ?        Ss   12:50   0:00      \_ /bin/sh -c /usr/local/ispconfig/server/server.sh >> /var/log/xeno_ispconfig_log
root      5053  0.0  0.0  63844  1224 ?        S    12:50   0:00      |   \_ /bin/sh /usr/local/ispconfig/server/server.sh
root      5090  0.0  3.8 352176 157204 ?       S    12:50   0:00      |       \_ /usr/bin/php -q /usr/local/ispconfig/server/server.php
(I modified the cron slightly so it puts all the output to a file - it's the same without the modification though )

Said log is basically full up with
Quote:
29.03.2011-13:45 - DEBUG - There is already an instance of server.php running. Exiting.
29.03.2011-13:46 - DEBUG - There is already an instance of server.php running. Exiting.
29.03.2011-13:47 - DEBUG - There is already an instance of server.php running. Exiting.
29.03.2011-13:48 - DEBUG - There is already an instance of server.php running. Exiting.
29.03.2011-13:49 - DEBUG - There is already an instance of server.php running. Exiting.
29.03.2011-13:50 - DEBUG - There is already an instance of server.php running. Exiting.
29.03.2011-13:51 - DEBUG - There is already an instance of server.php running. Exiting.
The last bit of juicy info in the file is:

Code:
29.03.2011-12:48 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
29.03.2011-12:48 - DEBUG - No Updated records found, starting only the core.
29.03.2011-12:48 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
finished.
29.03.2011-12:49 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
29.03.2011-12:49 - DEBUG - No Updated records found, starting only the core.
29.03.2011-12:49 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
finished.
29.03.2011-12:50 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
29.03.2011-12:50 - DEBUG - Found 2 changes, starting update process.
29.03.2011-12:51 - DEBUG - There is already an instance of server.php running. Exiting.
29.03.2011-12:52 - DEBUG - There is already an instance of server.php running. Exiting.
29.03.2011-12:53 - DEBUG - There is already an instance of server.php running. Exiting.
and before that:

Code:
29.03.2011-11:19 - DEBUG - Calling function 'insert' from plugin 'ftpuser_base_plugin' raised by event 'ftp_user_insert'.
29.03.2011-11:19 - DEBUG - Processed datalog_id 4774
29.03.2011-11:19 - DEBUG - Replicated from master: REPLACE INTO ftp_user -----REMOVED------
29.03.2011-11:19 - DEBUG - Calling function 'insert' from plugin 'ftpuser_base_plugin' raised by event 'ftp_user_insert'.
29.03.2011-11:19 - DEBUG - Processed datalog_id 4779
29.03.2011-11:19 - DEBUG - Calling function 'restartHttpd' from module 'web_module'.
29.03.2011-11:19 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
finished.
29.03.2011-11:20 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
29.03.2011-11:20 - DEBUG - No Updated records found, starting only the core.
I can't find anything which might cause the problem, I've rebooted the server but the problem continues.

If you kill all of the server instances, delete the lock file and run server.sh then it all goes through as you'd expect without any errors.

Any ideas?

Thanks in advance.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to host a forum with multiple web servers? itwillcome Technical 3 11th February 2011 01:26
Help:two isp3 servers primary and secondary dns u4david Installation/Configuration 6 17th June 2010 20:53
DNS data from Standalone servers to Primary DNS server SamTzu Tips/Tricks/Mods 7 15th November 2009 13:38
Unable send receive emails vassilis3 Installation/Configuration 15 19th May 2007 14:34
No SPF record. beryl Installation/Configuration 6 17th May 2007 19:52


All times are GMT +2. The time now is 07:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.