Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 28th March 2011, 14:23
acrobal acrobal is offline
Junior Member
 
Join Date: Apr 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default problem with mirror setup and multiserver setup

Hi,

I installed ispconfig3 on 3 servers. 2 servers installed with mirror setup with this tutorial

http://www.howtoforge.com/installing...th-ispconfig-3

with all service except DNS.

It worked well but when I had the third server to DNS service with this tutorial

http://www.howtoforge.com/installing...th-ispconfig-3

I had this problem
Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'ispconfig'@'localhost' (using password: YES) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php

to resolv this problem I pasted the password found on /usr/local/ispconfig/server/lib/config.inc.php

and i do this command

mysql -u root -p
use mysql;
mysql> update user set password=PASSWORD("Password found on th file") where User='ispconfig';
flush privileges;
quit

I resolv the problem but I have a new error

PHP Warning: mysql_connect(): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 78
PHP Warning: mysql_error() expects parameter 1 to be resource, boolean given in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 63
PHP Warning: mysql_error() expects parameter 1 to be resource, boolean given in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 64

Any idea?? please
Thank you for all your answers
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail send/recieve problem DKLeader Installation/Configuration 14 22nd February 2011 15:13
Multiserver setup with mysql-only server Croydon Developers' Forum 4 21st February 2011 22:04
Multiserver Setup on Centos 5.5 dfinehub Installation/Configuration 3 24th October 2010 12:47
multiserver setup IzFazt Installation/Configuration 8 8th August 2010 17:58
Multiserver setup design documentation agoston Developers' Forum 4 4th June 2009 13:53


All times are GMT +2. The time now is 10:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.