Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th February 2011, 00:14
talkingnews talkingnews is offline
Member
 
Join Date: Jan 2011
Posts: 65
Thanks: 15
Thanked 5 Times in 5 Posts
Default FTP cannot login, lots of warnings in ISPconfig too

Right now, my website it up, my ispconfig can be access, and I can ssh to the vps server. But ftp won't connect. Waits for welcome message, then nothing ever happens. All accounts.

Restarted with service pure-ftpd-mysql restart
Nothing
Rebooted whole VPS. Nothing.

Rebooted router to get a fresh IP in case it was some weird banning thing.
Nothing.

This has happened before, but I didn't do anything, and next day it had cleared itself.

What I DID notice was errors suddenly in ispconfig like

Code:
Notice: Undefined index: on_after_update in /usr/local/ispconfig/interface/lib/classes/plugin.inc.php on line 140 Notice: Undefined index: sites:on_after_update in /usr/local/ispconfig/interface/lib/classes/plugin.inc.php on line 140 Notice: Undefined index: sites:ftp_user:on_after_update in /usr/local/ispconfig/interface/lib/classes/plugin.inc.php on line 140 Notice: Undefined variable: wb in /usr/local/ispconfig/interface/lib/app.inc.php on line 187
I've read a few threads about checking the DB - repaired all ispconfig and mysql tables, all were OK except for:

mysql.general_log check Error You can't use locks with log tables.
mysql.slow_log check Error You can't use locks with log tables.

Does anyone know how I can get back into my ftp?
Reply With Quote
Sponsored Links
  #2  
Old 10th February 2011, 09:47
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,388 Times in 4,233 Posts
Default

To fix the php notices, please set the correct error_reporting level in the php.ini file(s) and rstart apache:

error_reporting = E_ALL & ~E_NOTICE

Regarding the FTP issue, please post the output of:

cat /proc/user_beancounters
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 10th February 2011, 11:52
talkingnews talkingnews is offline
Member
 
Join Date: Jan 2011
Posts: 65
Thanks: 15
Thanked 5 Times in 5 Posts
Default

Quote:
Originally Posted by till View Post
To fix the php notices, please set the correct error_reporting level in the php.ini file(s) and rstart apache:

error_reporting = E_ALL & ~E_NOTICE
Ah, that was just me trying to find a way of getting apache to show me errors.
Didn't work anyway, so changed it back now.

Quote:
Originally Posted by till View Post
Regarding the FTP issue, please post the output of:
cat /proc/user_beancounters
No such file, searched the whole filesystem. And then this forum.
It appears this has something to do with VPS, and I'm on a VPS, but I don't run it. Could it be something to do with the host machine then?
Reply With Quote
  #4  
Old 10th February 2011, 12:00
talkingnews talkingnews is offline
Member
 
Join Date: Jan 2011
Posts: 65
Thanks: 15
Thanked 5 Times in 5 Posts
Default

Quote:
Originally Posted by dfgd456fg45 View Post
some times when cookies are turned off or does not have the qualifications for login,some one can not login into the account.

login with firefox and let the cookies be turned on.
Cookies and Firefox in FTP? That's a new one for me!

I'm using filezilla as my ftp client, but was also using pspad. Both are working fine this morning. Nothing to do with browsers, this is FTP.
Reply With Quote
  #5  
Old 22nd March 2011, 19:27
nababan nababan is offline
Junior Member
 
Join Date: Nov 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i am install pure-ftpd-mysql on debian and cannot login via filezilla.
Reply With Quote
  #6  
Old 23rd March 2011, 15:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Which guide (URL) did you use?

Did you try both active and passive transfers in your FTP client?

Do you have any error messages that you can share with us?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 23rd March 2011, 17:16
nababan nababan is offline
Junior Member
 
Join Date: Nov 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
Which guide (URL) did you use?

Did you try both active and passive transfers in your FTP client?

Do you have any error messages that you can share with us?
I am using this guide: http://www.howtoforge.com/pureftpd_m...irtual_hosting

I don't know about both active and passive transfers in FTP client
Could you explain to me?

Sorry, i am just a newbie on UNIX/Linux Debian
Reply With Quote
  #8  
Old 24th March 2011, 14:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What Debian version do you use?

You can configure your FTP client to use active or passive mode for an FTP connection. I suggest you try both. If one succeeds while the other does not, it's most likely a firewall problem.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 24th March 2011, 16:07
nababan nababan is offline
Junior Member
 
Join Date: Nov 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
What Debian version do you use?

You can configure your FTP client to use active or passive mode for an FTP connection. I suggest you try both. If one succeeds while the other does not, it's most likely a firewall problem.
I use Debian 6 Squeeze on Virtual Private Server wit OpenVZ
Reply With Quote
  #10  
Old 25th March 2011, 14:27
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Please try chapter 20.1 from http://www.howtoforge.com/perfect-se...ispconfig-3-p6
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Tags
ftp timeout pure-ftpd, ispconfig3, mysql, pure-ftpd-mysql

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3 Send/Receive mail not working. Acidut General 6 4th April 2010 11:24
FTP & ISPconfig: no luck bidevi Installation/Configuration 3 19th July 2007 10:38
Can't access login enter ispconfig web ftp domain hostname Dekalb Installation/Configuration 1 3rd June 2007 13:22
LOTS of FTP timeouts (centos 4.4, perfect install, ispconfig) ThE-LyNX Server Operation 10 13th December 2006 20:41
FTP Error joshabts Installation/Configuration 3 4th November 2006 16:19


All times are GMT +2. The time now is 16:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.