#1  
Old 14th March 2011, 09:57
cyberfido cyberfido is offline
Junior Member
 
Join Date: Mar 2011
Posts: 5
Thanks: 1
Thanked 1 Time in 1 Post
Default [SOLVED] Waitings with pure-ftpd

Hi all,
I'm new Italian user of this community and a newbie user of Linux Ubuntu Server.
I'd need a help with a problem that is annoying me since a week.
I have pure-ftpd server installed on my server and sometime it doesn't answer until request goes on timeout. If you try to contact immediately the ftp server it answers correctly and let you work, but some minutes or seconds after it "freezes" again until timeout.
Before of this week, it has never given a problem.
I thought that I was the cause of this problem, because I've modified some parameters on the server, but non related to pure-ftp.
I made changes on nsswitch.conf for NIS and on ISPConfig, I've only changed root password.
I also saw on var/log/messages if there's anything wrong, but it doesn't reveal any anomalies.
I really don't have a good knowledge, so I'm stuck here.
The server is hosted away from my office and other branches connecting to its ftp service meet the same problem, so I think it's not a LAN or firewall problem.
Do you have any ideas about it? Let me know if you need any other information.

Last edited by cyberfido; 18th March 2011 at 17:53. Reason: I've solved the problem
Reply With Quote
Sponsored Links
  #2  
Old 15th March 2011, 14:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,900
Thanked 2,702 Times in 2,545 Posts
Default

Did you try both active and passive transfers in your FTP client?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 15th March 2011, 15:05
cyberfido cyberfido is offline
Junior Member
 
Join Date: Mar 2011
Posts: 5
Thanks: 1
Thanked 1 Time in 1 Post
Default

no, only passive mode, because the main programs that use ftp service use passive mode.
I've never changed the mode since server first installation.
Reply With Quote
  #4  
Old 16th March 2011, 13:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,900
Thanked 2,702 Times in 2,545 Posts
Default

Can you try with active mode?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 16th March 2011, 13:51
cyberfido cyberfido is offline
Junior Member
 
Join Date: Mar 2011
Posts: 5
Thanks: 1
Thanked 1 Time in 1 Post
Default

Do I need to modify some setting on pure-ftpd to try with active mode ?

can you explain me briefly what it could mean if active mode works and on other hand if active mode doesn't work?

I'm grateful to you.
Reply With Quote
  #6  
Old 17th March 2011, 18:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,900
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by cyberfido View Post
Do I need to modify some setting on pure-ftpd to try with active mode ?
No, you must select active mode in your FTP client.

Quote:
Originally Posted by cyberfido View Post
can you explain me briefly what it could mean if active mode works and on other hand if active mode doesn't work?
Most likely it's a firewall problem then.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
cyberfido (18th March 2011)
  #7  
Old 18th March 2011, 13:05
cyberfido cyberfido is offline
Junior Member
 
Join Date: Mar 2011
Posts: 5
Thanks: 1
Thanked 1 Time in 1 Post
Default

falko, this morning maybe i've resolved the problem.
Ill'wait to "sing victory" as in italy we are usde to say.
The problem maybe it's due to the option of zywall usg200 called "Enable link sticking"
This option permits to mantain the same session active to a long time.
This option was disabled and so I think pcs change session every time after authentication so they don't receive data. I'll inform you during the day about the reactions of clients.
Reply With Quote
  #8  
Old 18th March 2011, 17:52
cyberfido cyberfido is offline
Junior Member
 
Join Date: Mar 2011
Posts: 5
Thanks: 1
Thanked 1 Time in 1 Post
 
Default

ok. I've ascertained that wae a firewall problem.
problem solved.
thaks a lot!
Reply With Quote
The Following User Says Thank You to cyberfido For This Useful Post:
falko (19th March 2011)
Reply

Bookmarks

Tags
pure-ftpd, ubuntu, waiting

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pure Ftpd MySQL authorisation problem davebamford General 11 21st May 2011 09:40
SSL/TLS Pure FTPD bboy8012 General 6 9th December 2010 16:18
Pure FTPd not running andreasnrb Installation/Configuration 8 20th March 2010 01:01
Pure domain DNS doesn't work SyRenity Installation/Configuration 7 12th December 2006 12:12
Pure https site erk Installation/Configuration 2 9th January 2006 20:45


All times are GMT +2. The time now is 13:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.