Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th March 2011, 13:21
Sir Jake Sir Jake is offline
Junior Member
 
Join Date: Mar 2011
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Arrow [Resolved] Phpmyadmin & ISPCONFIG3 Issue

I followed the Ubuntu 10.10 perfect server guide. The issue I'm having is getting phpmyadmin working, I've been stuck on this for the last few days and after hours of searching google I thought I'd make a post here asking for some help.

When I go to my website link xx.xx.xx.xx/phpmyadmin I get nothing.
"Not Found
The requested URL /phpmyadmin was not found on this server."

From inside of ispconfig the link looks like this "http://xx.xx.xx.xx:8080/sites/database_phpmyadmin.php?id=1"
Any help for this would be great.
Thanks in advance.

Last edited by Sir Jake; 9th March 2011 at 03:29. Reason: Issue was resolved, changed topic title.
Reply With Quote
Sponsored Links
  #2  
Old 7th March 2011, 18:37
germinator germinator is offline
Member
 
Join Date: Nov 2010
Location: /root
Posts: 51
Thanks: 7
Thanked 16 Times in 9 Posts
Default

do you have a symlink or apache directory linking the phpmyadmin alias to your acctual phpmyadmin directory ?
Reply With Quote
  #3  
Old 8th March 2011, 00:14
Sir Jake Sir Jake is offline
Junior Member
 
Join Date: Mar 2011
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I can't seem to find any links to phpmyadmin, looking in the www folder I see nothing and same as in the clients sections I can't find any symbolic links

Used this to install everything.
"http://www.howtoforge.com/perfect-server-ubuntu-10.10-maverick-meerkat-ispconfig-3-p4"

Everything else seems to be working fine just the database part for some reason.
Reply With Quote
  #4  
Old 8th March 2011, 16:56
germinator germinator is offline
Member
 
Join Date: Nov 2010
Location: /root
Posts: 51
Thanks: 7
Thanked 16 Times in 9 Posts
Default

you cant find any symlink since there is none for phpmyadmin to be created in the tutorial ...
you have probably created one for sqiurrelmail .. simply do
Code:
ln -s /usr/share/phpmyadmin/ /var/www/phpmyadmin
and a simlink is created ..
however if you want all websites created in your ispconfig system to have the alias, then you have to add an apache directory ..
to do that go to /etc/apache2/conf.d and create a new file called phpmyadmin by running the command
Code:
touch phpmyadmin
then edit the file and set the settings for your apache directory.. this example should probably work
Code:
Alias /phpmyadmin /usr/share/phpmyadmin
<Directory /usr/share/phpmyadmin>
Order allow,deny
Allow from all
</Directory>
hope this could help
Reply With Quote
The Following User Says Thank You to germinator For This Useful Post:
Sir Jake (9th March 2011)
  #5  
Old 9th March 2011, 03:27
Sir Jake Sir Jake is offline
Junior Member
 
Join Date: Mar 2011
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thank you very much, this helped a lot!!
Now I've got everything moved to one of my new servers and its working great.
Hope this is able to help others with the same issue.
Reply With Quote
  #6  
Old 9th March 2011, 15:46
germinator germinator is offline
Member
 
Join Date: Nov 2010
Location: /root
Posts: 51
Thanks: 7
Thanked 16 Times in 9 Posts
 
Default

always happy to help
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPconfig3 and PhpMyAdmin otger Installation/Configuration 20 15th September 2010 20:42
Phpmyadmin issue skorph HOWTO-Related Questions 1 2nd July 2010 13:00
amavis rejects all inbound emails aclhkaclhk Installation/Configuration 5 28th February 2010 05:24
phpMyAdmin on an ISPConfig3 server Hans Installation/Configuration 3 26th October 2009 14:20
httpd and phpmyadmin recirect issue moglia Developers' Forum 5 11th August 2009 13:52


All times are GMT +2. The time now is 02:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.