Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd March 2011, 01:10
PhoNull PhoNull is offline
Junior Member
 
Join Date: Mar 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default uipdated ISPConfig 3.0.3.2 php stop working

I updated my ispconfig 3 on debian 5 server. I created a new client and website and went to install wordpress and the page is just blank tho phpinfo.php works. This happens with every new site I create since the update.

Last edited by PhoNull; 2nd March 2011 at 01:42.
Reply With Quote
Sponsored Links
  #2  
Old 2nd March 2011, 08:48
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,951
Thanks: 825
Thanked 5,362 Times in 4,209 Posts
Default

Please ensure that you selected php-fcgi as php method and that suexec is enabled for that website.

Beside that, have you modified the vhost template file or do you use a custom vhost template?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 2nd March 2011, 20:26
PhoNull PhoNull is offline
Junior Member
 
Join Date: Mar 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes the site is set to php-fcgi and suexec is enabled and I haven't modified the vhost file.
Reply With Quote
  #4  
Old 2nd March 2011, 20:43
PhoNull PhoNull is offline
Junior Member
 
Join Date: Mar 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok I found out it's not php its mysql.. any new clients i create can't access phpmyadmin or login with there user/pass so when I go to install wordpress nothing comes up cuz it can't connect to sql
Reply With Quote
  #5  
Old 3rd March 2011, 00:52
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,951
Thanks: 825
Thanked 5,362 Times in 4,209 Posts
Default

Most likely you changed the mysql root password and forgot to change it also in the file /usr/local/ispconfig/server/lib/mysql_clientdb.conf
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 3rd March 2011, 19:37
PhoNull PhoNull is offline
Junior Member
 
Join Date: Mar 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

No I haven't changed anything and its only with new clients. Mysql works with all my other websites on my first client I created, every client after that it won't work
Reply With Quote
  #7  
Old 4th March 2011, 12:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,951
Thanks: 825
Thanked 5,362 Times in 4,209 Posts
 
Default

1) Any jobs left in the jobqueue in the monitor?
2) Are you able to login to mysql with the login details in the file /usr/local/ispconfig/server/lib/mysql_clientdb.conf
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Multiserver setup: repquota command not found. CSsab Installation/Configuration 2 27th January 2011 15:11
Apache not restart after change php mode wiss Installation/Configuration 15 3rd November 2010 15:43
Unable to install ISPConfig bdonecker Installation/Configuration 21 26th May 2009 08:20
Newly Installed ISPConfig3 on Ubuntu 8.04 : login redirect fail ? cripperz Installation/Configuration 5 22nd March 2009 12:15
ISPConfig stop working after i add a new site xTiNcTion Installation/Configuration 4 5th January 2007 23:55


All times are GMT +2. The time now is 06:37.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.