Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th February 2011, 21:24
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default PHPMYADMIN not found or wrong link in the ISPConfig 3

Hi guys,

maybe I have found a little error in the ispconfig layout. If I click at the connection database link button at the database management page, I am redirected at the http://dbserver.mydomain.com/phpmyadmin.

As described in the manual the phpmyadmin has been installed in the webserver and not in the dbserver.

So what happens?
Attached Images
 
Reply With Quote
Sponsored Links
  #2  
Old 19th February 2011, 10:57
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

The problem is within the Interface Config.

The default phpmyadmin link must be http://webserver.mydomain.com/phpmyadmin

At the moment the link is http://dbserver.mydomain.com/phpmyadmin

Furthermore the phpmyadmin config file is wrong:

Code:
  GNU nano 2.2.4                    File: config.inc.php                                              

<?php
/**
 * Please, do not edit this file. The configuration file for Debian
 * is located in the /etc/phpmyadmin directory.
 */

// Load secret generated on postinst
include('/var/lib/phpmyadmin/blowfish_secret.inc.php');

// Load autoconf local config
include('/var/lib/phpmyadmin/config.inc.php');

// Load user's local config
include('/etc/phpmyadmin/config.inc.php');

// Set the default server if there is no defined
if (!isset($cfg['Servers'])) {
    $cfg['Servers'][1]['host'] = 'localhost';
}

$cfg['Servers'][1]['host'] = "dbserver.mydomain.com";

// Set the default values for $cfg['Servers'] entries
for ($i=1; (!empty($cfg['Servers'][$i]['host']) || (isset($cfg['Servers'][$i]['connect_type']) && $cf$
    if (!isset($cfg['Servers'][$i]['auth_type'])) {
        $cfg['Servers'][$i]['auth_type'] = 'cookie';
    }
    if (!isset($cfg['Servers'][$i]['host'])) {
        $cfg['Servers'][$i]['host'] = 'localhost';
    }
    if (!isset($cfg['Servers'][$i]['connect_type'])) {
        $cfg['Servers'][$i]['connect_type'] = 'tcp';
    }
    if (!isset($cfg['Servers'][$i]['compress'])) {
        $cfg['Servers'][$i]['compress'] = false;
    }
    if (!isset($cfg['Servers'][$i]['extension'])) {
        $cfg['Servers'][$i]['extension'] = 'mysql';
    }
}
Regards

Regards
Reply With Quote
  #3  
Old 19th February 2011, 11:23
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

Furthermore if a database is not enabled for the remote connection the phpmyadmin doesn't accept the requests.

If the DBServer is configured with the multiserver setup, the users permissions must be set with the host webserver.mydomain.com otherwise they cannot connect using the phpmyadmin software.

The workaround is enable them to using a remote connection and this is not a good idea at all. So why ispConfig doesn't set the right permission?

thanks
Reply With Quote
  #4  
Old 19th February 2011, 16:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

You can configure the phpMyAdmin link in ISPConfig's system settings.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 19th February 2011, 19:56
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

Hi Falko,

anyway the databases can be read only if I select the remote access in the control panel. Is there a way to solve this problem?

thanks
Reply With Quote
  #6  
Old 20th February 2011, 23:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by mturillo View Post
Hi Falko,

anyway the databases can be read only if I select the remote access in the control panel. Is there a way to solve this problem?

thanks
Are the databases installed on a different server than phpMyAdmin?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 20th February 2011, 23:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by Bashewa View Post
Hi Ive installed ISPconfig3 on Debian Squeeze on a dedicated server with 3 available IP's and everything works fine except for phpmyadmin.

When I create a database I can access phpmyadmin from the ISPconfig panel by clicking the connection to phpmyadmin from the sites/database interface, but I cannot login with the username and password I just set up.


I can login to mysql server from command line by doing

mysql -u root -p

so mysql server is running

remote access is also ticked

Ive set phpmyadmin interface on ISPconf to http://xx.xx.149.228/phpmyadmin/ which I can open but wont except username and password ( #1045 Cannot log in to the MySQL server
)

Any ideas how to start fault tracing?
Please open a new thread.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 21st February 2011, 04:13
dvancamp dvancamp is offline
Junior Member
 
Join Date: Mar 2008
Location: Delray Beach, FL
Posts: 7
Thanks: 0
Thanked 1 Time in 1 Post
 
Default Sorry to jump in

I'm experiencing the same issue as mturillo on the multi-server setup outlined in the manual. PhpMyAdmin ends up on the webserver and is configured to connect to the localhost while the ISPConfig interface is creating client's databases on the dedicated database server.

I manually added my db host to /etc/phpmyadmin/config.inc.php like mturillo but you still run into the problem of clients having to allow remote access to the entire internet or knowing the IP address of your main ISPConfig server.

My first instinct was to change the defaults in the interface form (ispconfig/interface/web/sites/form/database.tform.php) and prefill the checkbox and IP address. Obviously kind of a hack that wouldn't survive upgrades.

I see in that same database.tform.php script it pulls the database server names out of the configuration. Would it make sense to automatically grant remote access to nodes configured as webservers? Leaving the remote access checkbox and IPs to servers outside of ISPConfig control...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian 5.0 'hangs' GHz Installation/Configuration 5 1st October 2009 12:57
i am having some problem ? cobro Installation/Configuration 20 30th April 2008 16:26
https protocol stops page load tjd General 7 18th November 2007 18:06
Installation Troubles bswinnerton Installation/Configuration 4 29th July 2007 16:56
ISPC install stops str2etboy Installation/Configuration 19 28th January 2006 07:18


All times are GMT +2. The time now is 13:11.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.