Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 9th February 2011, 11:03
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

Yes of course Till. He was quite clear.
Anyway can be useful for all the SysAdmin know a Physical Perfect Install for ISPConfig. It's just for completing the Perfect Install tutorials.

Regards
Reply With Quote
Sponsored Links
  #12  
Old 10th February 2011, 17:19
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

I have followed these steps:

1. I have set all the servers eth0 cards with a public IP.
2. I have connected all the servers to the switch in unmanaged mode.
3. I have connected the public network cable in the switch too.

All the computers would be on the web but know a question comes:

Do the Servers communicate between themselves and resolving the IP internally ?

For instance:

Public IP:
122.112.33.80 WEB Server
122.112.33.81 DB Server
122.112.33.82 MAIL Server
122.112.33.83 Switch

If the WEB server wants to know some information from the db server must resolve the path to reach the db server in the right way?

thanks
Reply With Quote
  #13  
Old 11th February 2011, 16:29
kendel kendel is offline
HowtoForge Supporter
 
Join Date: Aug 2010
Posts: 132
Thanks: 4
Thanked 1 Time in 1 Post
Default

The best way and this works for me.

Get a gigabit switch...
Set IPs for each server... Make sure you are able to ping each server...

Get a router to the internet and connect the switch to the router.

Configure the router to forward all ports to each specific server...
Reply With Quote
  #14  
Old 11th February 2011, 16:30
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

So I have to handle the switch in Managed mode, right?
Reply With Quote
  #15  
Old 11th February 2011, 16:34
kendel kendel is offline
HowtoForge Supporter
 
Join Date: Aug 2010
Posts: 132
Thanks: 4
Thanked 1 Time in 1 Post
Default

No an unmanaged switch will work just fine, regardless of what OS you run Linux or Gaycrosoft you can set IPs through the OS.... Then ping each server through the commang line
Reply With Quote
  #16  
Old 11th February 2011, 16:36
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

Just a question:

How have I set the forwarding rules if it is in unmanaged mode?
Reply With Quote
  #17  
Old 11th February 2011, 16:42
kendel kendel is offline
HowtoForge Supporter
 
Join Date: Aug 2010
Posts: 132
Thanks: 4
Thanked 1 Time in 1 Post
Default

looks like u need some networking 101.. (i have to start charging you) anyways.. this is where you router comes in.. you forwards the right ports to the right IP addresses
Reply With Quote
  #18  
Old 11th February 2011, 16:45
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

Yes I am learning everyday new things.
You have not answer me.

In unmanaged mode you cannot access directly to the software switch, so how have I do?

thanks
Reply With Quote
  #19  
Old 11th February 2011, 16:51
kendel kendel is offline
HowtoForge Supporter
 
Join Date: Aug 2010
Posts: 132
Thanks: 4
Thanked 1 Time in 1 Post
 
Default

You don't need to access the switch at all... only things you need access to is the router and the command line on your servers...
__________________
If you are looking for examples of an ISPConfig 3 Multiserver Setup, Visit my website Here!!!
Reply With Quote
Reply

Bookmarks

Tags
ispconfig 3, multiserver, networking, physical connections

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
problems mails powaserv Installation/Configuration 9 31st January 2011 19:30
Stange mail problem The-Ghost Installation/Configuration 6 25th April 2010 19:59
Getting e-mail working hansoffate Installation/Configuration 29 13th August 2008 16:33
debian etch courier pop3 issue docean Installation/Configuration 6 20th March 2008 15:38
Perfect Xen 3.0 setup for Debian gurneyzap HOWTO-Related Questions 4 26th March 2006 11:30


All times are GMT +2. The time now is 13:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.