Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th February 2011, 19:32
celia_ccs celia_ccs is offline
Junior Member
 
Join Date: Feb 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default configure SSL for a domain alias

Hi,

I'm tryin to configure a SSL certificate for a website that will be access under the url https://extranet.mydomain.com

However as I have my subdomains for mydomain.com and to avoid conflicts with .htaccess, each subdomain.mydomain.com is created as a seperate site. I then create an alias for the site.

So I have the following configuration :
SITES | ALIAS
wiki.com | wiki.mydomain.com
extranet.com | extranet.mydomain.com
...

So I'm not sure that if I purchase a certificate for extranet.mydomain.com it will work. In ISPconfig to create the certificate I can only do it on the fake domain extranet.com.

Do you know if it would work. Or how I should configure it to actually work?

Thanks,
Celia
Reply With Quote
Sponsored Links
  #2  
Old 10th February 2011, 19:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
 
Default

If you create an SSL cert for extranet.mydomain.com and then access the site using extranet.com, you will get a warning in your browser because of a domain mismatch.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Tags
alias, ssl, ssl on ispconfig

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Should I go for dedicated SSL or free shared SSL? What's the deal? calvinrobinson Smalltalk 3 3rd November 2010 17:57
Alias domain Toucan General 2 11th August 2010 00:54
ERROR: Connection dropped by IMAP server. [Centos 5.4, courier imap,squirrel, etc] darevil HOWTO-Related Questions 7 9th June 2010 14:49
post fix error after a year aberrio Server Operation 5 5th May 2009 21:33
CentoS doesn't send the emails vaio1 Installation/Configuration 18 5th November 2008 17:51


All times are GMT +2. The time now is 10:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.