#11  
Old 6th February 2011, 22:46
Breezer Breezer is offline
Junior Member
 
Join Date: Jan 2011
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have checked pureftpd.log file and it was nothing there.... and these are all the log files under that directory.... and no authentication log.... should i look at any other log files?

acpid / ispconfig / rpmpkgs.1
anaconda.log / ispconfig_install.log / rpmpkgs.2
anaconda.syslog / lastlog / rpmpkgs.3
anaconda.xlog / mail / samba
audit / maillog / scrollkeeper.log
boot.log / maillog.1 / secure
boot.log.1 / maillog.2 / secure.1
boot.log.2 / maillog.3 / secure.2
boot.log.3 / mcelog / secure.3
btmp / messages / setroubleshoot
clamav / messages.1 / spooler
conman / messages.2 / spooler.1
conman.old / messages.3 / spooler.2
cron / mysqld.log / spooler.3
cron.1 / pm / squid
cron.2 / ppp / tallylog
cron.3 / prelink wtmp
cups / pureftpd.log / Xorg.setup.log
dmesg / rkhunter.log / yum.log
fail2ban.log / rkhunter.log.old / yum.log.1
faillog / rpmpkgs
httpd
Reply With Quote
Sponsored Links
  #12  
Old 7th February 2011, 18:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Please check /var/log/messages for authentication errors.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #13  
Old 9th February 2011, 01:29
gummiv gummiv is offline
Junior Member
 
Join Date: Feb 2011
Location: Iceland
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey there,

I´m having the exact same problem as Breezer here.

I have created an ftp user under a client and that user is marked as active. When I try to connect via filezilla, I get the same error messages as posted earlier in this thread. I can however connect as root, even though root is present in ftpusers under /etc

Here is what pops up in the auth.log:

sshd[18060]: Invalid user **** from 192.168.255.3
sshd[18060]: Failed none for invalid user **** from 192.168.255.3 port 53982 ssh2
sshd[18060]: pam_unix(sshd:auth): check pass; user unknown
sshd[18060]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=192.168.255.3

So obviously the ftp does not recognize the user I created in ISPConfig, so the question is why not?
Reply With Quote
  #14  
Old 9th February 2011, 14:22
Breezer Breezer is offline
Junior Member
 
Join Date: Jan 2011
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have checked there there is no authentication log... but there was pureftpd.log i have checked it out and there is nothing there...
Reply With Quote
  #15  
Old 9th February 2011, 18:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Did you check /var/log/messages?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #16  
Old 9th February 2011, 18:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by gummiv View Post
Hey there,

I´m having the exact same problem as Breezer here.

I have created an ftp user under a client and that user is marked as active. When I try to connect via filezilla, I get the same error messages as posted earlier in this thread. I can however connect as root, even though root is present in ftpusers under /etc

Here is what pops up in the auth.log:

sshd[18060]: Invalid user **** from 192.168.255.3
sshd[18060]: Failed none for invalid user **** from 192.168.255.3 port 53982 ssh2
sshd[18060]: pam_unix(sshd:auth): check pass; user unknown
sshd[18060]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=192.168.255.3

So obviously the ftp does not recognize the user I created in ISPConfig, so the question is why not?
Please open a new thread.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #17  
Old 9th February 2011, 18:39
Breezer Breezer is offline
Junior Member
 
Join Date: Jan 2011
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yes i did this is what it was showing when i was trying to log in with the user that i created through ispconfig 3

Feb 9 09:30:02 server1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
Feb 9 09:30:02 server1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.
Feb 9 09:30:59 server1 ntpd[4533]: time reset -0.467956 s
Feb 9 09:31:42 server1 clamd[4546]: SelfCheck: Database status OK.
Feb 9 09:34:27 server1 ntpd[4533]: synchronized to LOCAL(0), stratum 10
Feb 9 09:35:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
Feb 9 09:35:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.
Feb 9 09:36:37 server1 ntpd[4533]: synchronized to 216.194.70.2, stratum 2
Feb 9 09:40:02 server1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
Feb 9 09:40:02 server1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.
Feb 9 09:41:42 server1 clamd[4546]: SelfCheck: Database status OK.
Feb 9 09:45:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
Feb 9 09:45:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.
Feb 9 09:50:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
Feb 9 09:50:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.
Feb 9 09:51:42 server1 clamd[4546]: SelfCheck: Database status OK.
Feb 9 09:55:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
Feb 9 09:55:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.
Feb 9 10:00:02 server1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
Feb 9 10:00:02 server1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.
Feb 9 10:01:42 server1 clamd[4546]: SelfCheck: Database status OK.
Feb 9 10:05:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
Feb 9 10:05:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.
Feb 9 10:10:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
Feb 9 10:10:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.
Feb 9 10:11:42 server1 clamd[4546]: SelfCheck: Database status OK.
Feb 9 10:15:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
Feb 9 10:15:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.
Feb 9 10:20:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
Feb 9 10:20:01 server1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.


this happens all the time even if i do not try to log in....
Reply With Quote
  #18  
Old 9th February 2011, 19:40
Breezer Breezer is offline
Junior Member
 
Join Date: Jan 2011
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've been doing little bit of research... and i have came across this

Then, you have to run the pure-ftpd command with '-l mysql:' (it's an 'ell'
not a 'one') followed by the path of that configuration file. Here's an
example with tcpserver:

tcpserver -DHRl0 0 21 /usr/local/bin/pure-ftpd -l mysql:/etc/pureftpd-mysql.conf &

You can mix different authentication methods. For instance, if you want to
use system (/etc/passwd) accounts when an account is not found in a MySQL
database, use -l mysql:/etc/pureftpd-mysql.conf -l unix


now is it possible that ftp is not pointed into the appropriate directory, as in its only pointed to mysql and not etc/passwd so thats why i can only log in with my root sql password... ?

if so how can i fix this so its pointed to both directories.... if NOT disregard this thought...
Reply With Quote
  #19  
Old 9th February 2011, 19:53
lightning200mph lightning200mph is offline
Junior Member
 
Join Date: Feb 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

This may have already been said but I didn't read all the post completely.
Your user name you are log in in with might be the problem, I also had this problem until I figured it out. So when you create a client lets say "Website1" then next step is the FTP-user "ftp1" under websites. So the log in name should be "website1ftp1" for the log in to work.

You will see [clientname]"username" on the ftp user name screen. So I put them together and it worked for me

Zach
Reply With Quote
  #20  
Old 9th February 2011, 20:07
Breezer Breezer is offline
Junior Member
 
Join Date: Jan 2011
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

No that is not the issue... I have already tried that and made sure that i am using the full name ie website1ftp1, and the right password... also tried the different transfer settings : default / active / passive and none of them work.
I get the same response all the time

Response: fzSftp started
Command: open "website1ftp1@555.555.555.555" 22
Command: Pass: ********
Error: Authentication failed.
Error: Critical error
Error: Could not connect to server

thats why it makes me think that the pureftpd is not looking at the same folder that the the ispconfig creates the usernames and passwords for ftp.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow download from own FTP (vsftpd + proftpd) Overcrook Installation/Configuration 0 12th January 2010 22:41
Troubleshooting FTP bswinnerton Installation/Configuration 4 10th October 2008 20:34
proFTPd passive mode problems bisbell Server Operation 8 6th August 2008 22:12
Question about Virtual Hosting With Proftpd And MySQL (Incl. Quota) On Debian Etch ikkem HOWTO-Related Questions 30 26th February 2008 20:38
Website users? ctroyp General 25 6th January 2006 19:02


All times are GMT +2. The time now is 00:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.