Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 2nd February 2011, 17:19
savago savago is offline
Member
 
Join Date: May 2008
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Skype™ to savago
Default

Quote:
Originally Posted by falko View Post
Are the MySQL details in that line ok (DB name, username, password)?
New one:
Code:
Feb  2 18:04:10 server1 amavis[19715]: (19715-03) (!)WARN: Using cpio instead of pax can be a security risk; please add:  $pax='pax';  to amavisd.conf and check that the pax(1) utility is available on the system!
This is happen not regularly,you can see here:
Code:
Jan 30 23:41:20 server1 amavis[2632]: (02632-19) NOTICE: reconnecting in response to: err=2006, HY000, DBD::mysql::st execute failed: MySQL server has gone away at (eval 86) line 166, <GEN241> line 5.
Jan 30 23:41:22 server1 amavis[2632]: (02632-19) Passed CLEAN, [94.156.xxx.yy] [94.156.1xx.yy] <smokeping@ns2.somesite.com> -> <nikolay@somesite.eu>, Message-ID: <20110130214120.7FCBB3A017A@server1.somesite.eu>, mail_id: rm8jz3t6xsCK, Hits: 0, size: 1354, queued_as: 374EB3A030B, 1681 ms
Jan 31 03:00:07 server1 amavis[2633]: (02633-20) NOTICE: reconnecting in response to: err=2006, HY000, DBD::mysql::st execute failed: MySQL server has gone away at (eval 86) line 166, <GEN250> line 5.
Jan 31 03:00:10 server1 amavis[2633]: (02633-20) Passed CLEAN, [94.156.xxx.yy] [94.156.xxx.yy] <root@ns2.somesite.com> -> <nikolay@somesite.eu>, Message-ID: <E1Pji7h-0002jX-Hs@ns2.somesite.com>, mail_id: gyuJ81R101hZ, Hits: 0.212, size: 5983, queued_as: 0D9DF3A030E, 2278 ms


And normal :
Code:
Feb  2 16:02:06 server1 postfix/smtpd[20094]: setting up TLS connection from mh1.hostmu.com[78.46.230.211]
Feb  2 16:02:06 server1 postfix/smtpd[20094]: Anonymous TLS connection established from mh1.hostmu.com[78.46.230.211]: TLSv1 with cipher ADH-AES256-SHA (256/256 bits)
Feb  2 16:02:06 server1 postfix/smtpd[20094]: F27A63A030D: client=mh1.hostmu.com[78.46.230.211]
Feb  2 16:02:07 server1 postfix/cleanup[20098]: F27A63A030D: message-id=<20110202140223.ce5ef21ca504@www.howtoforge.com>
Feb  2 16:02:07 server1 postfix/qmgr[2829]: F27A63A030D: from=<www-data@http4.howtoforge.com>, size=2227, nrcpt=1 (queue active)
Feb  2 16:02:07 server1 postfix/smtpd[20094]: disconnect from mh1.hostmu.com[78.46.230.211]
Feb  2 16:02:08 server1 postfix/smtpd[20102]: connect from localhost[127.0.0.1]
Feb  2 16:02:08 server1 postfix/smtpd[20102]: B94463A0310: client=localhost[127.0.0.1]
Feb  2 16:02:08 server1 postfix/cleanup[20098]: B94463A0310: message-id=<20110202140223.ce5ef21ca504@www.howtoforge.com>
Feb  2 16:02:08 server1 postfix/smtpd[20102]: disconnect from localhost[127.0.0.1]
Feb  2 16:02:08 server1 postfix/qmgr[2829]: B94463A0310: from=<www-data@http4.howtoforge.com>, size=2698, nrcpt=1 (queue active)
Feb  2 16:02:08 server1 amavis[3866]: (03866-20) Passed CLEAN, [78.46.230.211] [188.40.103.101] <www-data@http4.howtoforge.com> -> <nikolay@somesite.eu>, Message-ID: <20110202140223.ce5ef21ca504@www.howtoforge.com>, mail_id: vU9doEvwqBT5, Hits: 0, size: 2225, queued_as: B94463A0310, 1724 ms
Feb  2 16:02:08 server1 postfix/smtp[20099]: F27A63A030D: to=<nikolay@somesite.eu>, relay=127.0.0.1[127.0.0.1]:10024, delay=1.8, delays=0.08/0.03/0.01/1.7, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=03866-20, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as B94463A0310)
Feb  2 16:02:08 server1 postfix/qmgr[2829]: F27A63A030D: removed
Feb  2 16:02:08 server1 dovecot: auth-worker(default): mysql: Connected to localhost (dbispconfig)
Feb  2 16:02:08 server1 deliver(nikolay@svilengrad.eu): msgid=<20110202140223.ce5ef21ca504@www.howtoforge.com>: saved mail to INBOX
Feb  2 16:02:08 server1 postfix/pipe[20104]: B94463A0310: to=<nikolay@somesite.eu>, relay=dovecot, delay=0.08, delays=0.01/0.02/0/0.05, dsn=2.0.0, status=sent (delivered via dovecot service)
Feb  2 16:02:08 server1 postfix/qmgr[2829]: B94463A0310: removed
Feb  2 16:05:01 server1 dovecot: pop3-login: Disconnected: rip=127.0.0.1, lip=127.0.0.1, secured
Feb  2 16:05:01 server1 dovecot: imap-login: Disconnected: rip=127.0.0.1, lip=127.0.0.1, secured
Feb  2 16:05:01 server1 postfix/smtpd[20148]: connect from localhost[127.0.0.1]
Feb  2 16:05:01 server1 postfix/smtpd[20148]: lost connection after CONNECT from localhost[127.0.0.1]
Feb  2 16:05:01 server1 postfix/smtpd[20148]: disconnect from localhost[127.0.0.1]
Feb  2 16:05:27 server1 postfix/anvil[20096]: statistics: max connection rate 1/60s for (smtp:78.46.230.211) at Feb  2 16:02:06
Feb  2 16:05:27 server1 postfix/anvil[20096]: statistics: max connection count 1 for (smtp:78.46.230.211) at Feb  2 16:02:06
Feb  2 16:05:27 server1 postfix/anvil[20096]: statistics: max cache size 1 at Feb  2 16:02:06

Last edited by savago; 2nd February 2011 at 17:22.
Reply With Quote
Sponsored Links
  #12  
Old 3rd February 2011, 14:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by savago View Post
New one:
Code:
Feb  2 18:04:10 server1 amavis[19715]: (19715-03) (!)WARN: Using cpio instead of pax can be a security risk; please add:  $pax='pax';  to amavisd.conf and check that the pax(1) utility is available on the system!
Please open /etc/amavis/conf.d/50-user and add
Code:
$pax='pax';
in the middle.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #13  
Old 9th January 2012, 11:57
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,262
Thanks: 78
Thanked 24 Times in 20 Posts
Default

$pax='pax';

solved the same problem for me but what exactly does that directive do?
Reply With Quote
  #14  
Old 10th January 2012, 16:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=517156
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 27th January 2012, 10:03
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,262
Thanks: 78
Thanked 24 Times in 20 Posts
Default

still getting this occasionally, kinda a few times a day:

Quote:
Jan 27 09:51:22 h1870666 amavis[19528]: (19528-17) NOTICE: reconnecting in response to: err=2006, HY000, DBD::mysql::st execute failed: MySQL server has gone away at (eval 103) line 166, <GEN307> line 5.
Mysql is running, username and password are ok since it is only occasionally not working. Oh and I haven't hit the limits of mysql I have munin running here: http://zice.ro/munin/serverkompetenz...net/index.html

any other hints?
Reply With Quote
  #16  
Old 27th January 2012, 10:22
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,388 Times in 4,233 Posts
Default

Do you have any "real" problems like non delivered emails? As far as I see, this message indicates just that amavisd is doing a reconnect to mysql which is a normal action, it has the level "NOTICE" so this indicates not a problem.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #17  
Old 27th January 2012, 17:04
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,262
Thanks: 78
Thanked 24 Times in 20 Posts
Default

nope, no real problems, at least I haven't noticed any yet.

was just making sure everything runs smoothly. mysql timeouts are ok, never had any problems with websites accessing mysql.

I guess I can leave it like this then. will amavisd report "real" problems into the same log file though?
Reply With Quote
  #18  
Old 27th January 2012, 17:19
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,388 Times in 4,233 Posts
Default

Quote:
will amavisd report "real" problems into the same log file though?
All reports should be in that log as far as I know, but the level should be Different from NOTICE.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #19  
Old 27th January 2012, 17:22
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,262
Thanks: 78
Thanked 24 Times in 20 Posts
 
Default

great, I checked that file and "grepped" for amavis and those were the only lines popping up. I'll rest my case then and leave it as is.

thanks Till
Ovidiu
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to connect to mysql server Can't connect to local MySQL server through socket c7p Installation/Configuration 11 21st July 2009 10:27
What can be wrong martin_rudowicz Installation/Configuration 9 11th May 2008 19:42
Management/system config/settings & /server/settings not working!! dactor Installation/Configuration 9 6th February 2008 09:11
The Perfect Setup - Debian Etch (Debian 4.0) some trouble daniel80 HOWTO-Related Questions 26 1st February 2008 16:30
Rejecting outbound mail tristanlee85 General 11 20th May 2007 17:04


All times are GMT +2. The time now is 16:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.