Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th January 2011, 10:20
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,263
Thanks: 216
Thanked 649 Times in 295 Posts
Default Rounded corners (CSS) does not work on Debian ISPConfig3 server

Hi Till & Falko,

It's known that IE7 & IE8 are not the best browsers as it comes to CSS.
So, rounded corners defined in css does not work without a fix.
But, when using a fix, it is possible to see rounded corners if you using IE7 or IE8, as you can see here: http://109.71.49.185/fileadmin/ind.html
However, when we use the same html-file on our own Debian ISPConfig3 server, we can not see the rounded corners in IE7 and IE8: http://wonnebald.typo3surfer.eu/file...e/csv/ind.html

So, I had a look at the content of the file /etc/mime.types.
There we have have a line, like:
text/x-component htc

Do you know why the rounded corners on our Debian ISPConfig3 server are not shown when IE7 or IE8 is used?
I wonder what else needs to be configured, to make it possible.
__________________
Hans

MrHostman | Managed Hosting
Reply With Quote
Sponsored Links
  #2  
Old 24th January 2011, 12:06
CSsab CSsab is offline
Senior Member
 
Join Date: Apr 2010
Posts: 174
Thanks: 19
Thanked 32 Times in 27 Posts
Default Border radius

IE doesn't support border-radius.

You could try this possible fix described here:
http://dimox.net/cross-browser-borde...unded-corners/
Reply With Quote
  #3  
Old 24th January 2011, 12:13
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,263
Thanks: 216
Thanked 649 Times in 295 Posts
Default

Yes i know, but as you can see here: http://109.71.49.185/fileadmin/ind.html WITH IE7 or IE8, you see a border radius.
But, when i visit exactly the same file on our ISPConfig3 server, with IE7 or IE8 at http://wonnebald.typo3surfer.eu/file...e/csv/ind.html, the border radius is NOT shown!
So the question is, what needs to be configured to make it possible on the ISPConfig3 server as well.
__________________
Hans

MrHostman | Managed Hosting
Reply With Quote
  #4  
Old 24th January 2011, 12:19
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,733
Thanks: 840
Thanked 5,597 Times in 4,407 Posts
Default

Css is a browser side technology like javascript. It is not related to any server setting and it does not matter which controlpanel, operating system, webserver etc. you use to deliver the web pages, so this is not related to ispconfig in any way.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 24th January 2011, 12:34
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,263
Thanks: 216
Thanked 649 Times in 295 Posts
Default

Thanks both for your help!
And yes i realize that Till, but do you have an explanation then?
I mean, when i visit the html file on the first server i can see the border-radius and on the ISPConfig3 server not???
Same pc, same browser, same html file, different servers (but both Debian).
__________________
Hans

MrHostman | Managed Hosting
Reply With Quote
  #6  
Old 24th January 2011, 13:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,733
Thanks: 840
Thanked 5,597 Times in 4,407 Posts
Default

Might be a browser extension or any setting on your windows workstation that e.g. handles that one site is a trusted system and the oter one not or you have any browser extension installed that loades a different rendering engine for one IP etc.

Another option might be that the file is not the same or that the file has any relative links or includes to css or javascript or images that are missing.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.

Last edited by till; 24th January 2011 at 14:04. Reason: typos
Reply With Quote
  #7  
Old 24th January 2011, 13:35
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,263
Thanks: 216
Thanked 649 Times in 295 Posts
Default

Thanks Till for your help! We will investigate that.
__________________
Hans

MrHostman | Managed Hosting
Reply With Quote
  #8  
Old 26th January 2011, 10:50
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,263
Thanks: 216
Thanked 649 Times in 295 Posts
Default

The issue with the rounded corners fix for IE7/8 is solved. The htc file was not loaded correctly. The path to the htc file was incorrect. After fixing this we discovered another issue. The htc solution will only fix the rounded borders issue for all borders, but not if you only want to change the radius of one or two borders. Thank you for trying to help us out!
__________________
Hans

MrHostman | Managed Hosting
Reply With Quote
  #9  
Old 14th November 2014, 13:19
ezifor ezifor is offline
Junior Member
 
Join Date: Nov 2014
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Did you use vendor prefixes for border-radius property? You should use it in the following way: box with rounded corners using CSS3. And for IE of versions 8 and 7 you need to use PIE.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getmail problem cante93 Installation/Configuration 6 20th September 2010 15:40
Can't start apache Musty Server Operation 12 9th March 2008 14:58
The Perfect Setup - Debian Etch (Debian 4.0) some trouble daniel80 HOWTO-Related Questions 26 1st February 2008 17:30
Rejecting outbound mail tristanlee85 General 11 20th May 2007 18:04
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 03:30


All times are GMT +2. The time now is 02:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.