Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 9th January 2011, 20:55
riccardobenetti riccardobenetti is offline
Junior Member
 
Join Date: Jan 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation How to configure DNS templates

Good afternoon,
I saw that I set in ISPConfig 3 DNS templates, and I wonder if the two models below are correct and if not how can I fix so I can have templates for clients using Google Apps customers and do not use it, follow the templates I have:

Default template:
[ZONE]
origin = {} DOMAIN.
ns = ns1.vidit.com.br.
mbox = {EMAIL}.
refresh = 28800
retry = 7200
expires = 604800
minimum = 3600
ttl = 14400

[DNS_RECORDS]
A | {} DOMAIN. | {ip} | 0 | 86400
A | www | {ip} | 0 | 86400
A | mail | {ip} | 0 | 14400
NS | {} DOMAIN. | ns1.vidit.com.br. | 0 | 14400
NS | {} DOMAIN. | ns2.vidit.com.br. | 0 | 14400
NS | {} DOMAIN. | ns3.vidit.com.br. | 0 | 14400
MX | {} DOMAIN. | mail. {} DOMAIN. | 10 | 86400

Template Google Apps:
A|{DOMAIN}.|{IP}|0|86400
A|www|{IP}|0|86400
CNAME|mail|ghs.google.com.|0|14400
CNAME|docs|ghs.google.com.|0|14400
CNAME|agenda|ghs.google.com.|0|14400
NS|{DOMAIN}.|ns1.vidit.com.br.|0|14400
NS|{DOMAIN}.|ns2.vidit.com.br.|0|14400
NS|{DOMAIN}.|ns3.vidit.com.br.|0|14400
MX|{DOMAIN}.|aspmx.l.google.com.|10|14400
MX|{DOMAIN}.|alt1.aspmx.l.google.com.|20|14400
MX|{DOMAIN}.|alt2.aspmx.l.google.com.|20|14400
MX|{DOMAIN}.|aspmx2.googlemail.com.|30|14400
MX|{DOMAIN}.|aspmx3.googlemail.com.|30|14400
MX|{DOMAIN}.|aspmx4.googlemail.com.|30|14400
MX|{DOMAIN}.|aspmx5.googlemail.com.|30|14400
TXT|"v=spf1 include:_spf.{DOMAIN} include:_spf.google.com ~all"|14400

And use these settings to get the message example below:
dns_master_load: /etc/bind/pri.almeidasports.com:10: syntax error
zone almeidasports.com/IN: loading from master file /etc/bind/pri.almeidasports.com failed: syntax error
zone almeidasports.com/IN: not loaded due to errors.
_default/almeidasports.com/IN: syntax error

What am I doing wrong and how to configure? as much help and templates setup.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Companion Script #2 for The Perfect Server - Fedora 13 x86_64 [ISPConfig 3]" MrCompTech Tips/Tricks/Mods 0 10th July 2010 06:11
Squid Proxy Caching on Linux obzerver Installation/Configuration 4 13th August 2008 20:51
Google Apps dayjahone General 19 29th March 2008 18:25
DNS Configuration Problems VMartins Installation/Configuration 10 24th July 2007 15:40
Unable send receive emails vassilis3 Installation/Configuration 15 19th May 2007 15:34


All times are GMT +2. The time now is 06:22.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.