#1  
Old 21st December 2010, 14:23
nfomaniak nfomaniak is offline
Junior Member
 
Join Date: Dec 2010
Posts: 11
Thanks: 1
Thanked 2 Times in 2 Posts
Default ISPConfig 2 Backup Issue

Hey guys.

I just enabled the backup feature in ISPConfig but it does not seem to be backing everything up.

The backup zip files only have two files in them, backup.dat and a db file, such as web3db1.sql.

I am running ISPConfig 2.2.35.

The other strange thing is that it is replacing the previous nights backups.

Here is my crontab -l output for root

30 00 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/logs.php &> /dev/null
59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/ftp_logs.php &> /dev/null
59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/mail_logs.php &> /dev/null
59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/cleanup.php &> /dev/null
0 4 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/webalizer.php &> /dev/null
0 4 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/awstats.php &> /dev/null
0,30 * * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/check_services.php &> /dev/null
15 3,15 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/quota_msg.php &> /dev/null
40 00 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/traffic.php &> /dev/null
05 02 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/backup.php &> /dev/null
45 * * * * wget -O - -q -t 1 http://www.example.com/cron.php

If I run the command manually as root
/root/ispconfig/php/php /root/ispconfig/scripts/shell/backup.php

It works and the backups are created correctly, however, they are overwritten the next evening at 2:05am with the incomplete backups.

Any help would be greatly appreciated.
Reply With Quote
Sponsored Links
  #2  
Old 21st December 2010, 17:33
nfomaniak nfomaniak is offline
Junior Member
 
Join Date: Dec 2010
Posts: 11
Thanks: 1
Thanked 2 Times in 2 Posts
Default

I was just looking more closely at the Logwatch from last night and noticed a lot of entries in the Sudo (secure-log).

I also noticed the backup script says sudo must be enabled.

Do i need to enable sudo for each user?
Reply With Quote
  #3  
Old 21st December 2010, 21:01
nfomaniak nfomaniak is offline
Junior Member
 
Join Date: Dec 2010
Posts: 11
Thanks: 1
Thanked 2 Times in 2 Posts
Default

OK. I figured it out

My sudoers file had requiretty enabled and i was getting an error in /var/log secure

root : sorry, you must have a tty to run sudo

After commenting out Default requiretty it is working now.
Reply With Quote
  #4  
Old 22nd December 2010, 14:17
nfomaniak nfomaniak is offline
Junior Member
 
Join Date: Dec 2010
Posts: 11
Thanks: 1
Thanked 2 Times in 2 Posts
Default

Just in case it might be useful to someone else

to prevent the backups from being overwritten each time the script is run

remove this from backup.php

else {
exec("rm -rf $backup_dir/*");
}
Reply With Quote
The Following User Says Thank You to nfomaniak For This Useful Post:
falko (22nd December 2010)
  #5  
Old 30th December 2010, 16:36
nfomaniak nfomaniak is offline
Junior Member
 
Join Date: Dec 2010
Posts: 11
Thanks: 1
Thanked 2 Times in 2 Posts
 
Default

I have been noticing that the backup script is eating a whole lot of memory, about 700~800 MB out of the 2GB total RAM on my system.

Is this normal?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ftp problems timeout reny2000 General 6 23rd December 2009 11:09
Setting up a backup mail server setup with two installations of ISPConfig zitch Tips/Tricks/Mods 7 30th December 2006 10:07
HELP: ispconfig startup issue..need help quickly csharp2a General 1 8th September 2006 11:31
Backup to get Ispconfig running gregh General 3 23rd August 2006 11:12
Don't Backup, ispconfig, function? misterm Installation/Configuration 3 26th October 2005 11:52


All times are GMT +2. The time now is 23:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.