Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th December 2010, 11:37
pjack pjack is offline
Junior Member
 
Join Date: Dec 2010
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
Default Apache stops working after about 20 minutes

Apache seems to just stop working after about 20 minutes and I have to restart the service. I saw this person with a similar issue

http://www.howtoforge.com/forums/sho...ghlight=apache

I don't know if this is my problem but I'm not sure how to go about fixing it or why it's doing this.

Any help please?
Reply With Quote
Sponsored Links
  #2  
Old 27th December 2010, 04:59
pjack pjack is offline
Junior Member
 
Join Date: Dec 2010
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Does anyone know anything about this?
Reply With Quote
  #3  
Old 27th December 2010, 21:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Are there any errors in Apache's error log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 27th December 2010, 21:18
pjack pjack is offline
Junior Member
 
Join Date: Dec 2010
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
Default

line 148.
piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
Can't locate Date/Format.pm in @INC (@INC contains: /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/5.8.8) at /usr/local/ispconfig/server/scripts/vlogger line 148.
BEGIN failed--compilation aborted at /usr/local/ispconfig/server/scripts/vlogger line 148.
piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
Can't locate Date/Format.pm in @INC (@INC contains: /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/5.8.8) at /usr/local/ispconfig/server/scripts/vlogger line 148.
BEGIN failed--compilation aborted at /usr/local/ispconfig/server/scripts/vlogger line 148.

I didn't install Vlogger, would that cause the issue? It shouldn't have anything to do with apache though right?
Reply With Quote
  #5  
Old 27th December 2010, 21:26
pjack pjack is offline
Junior Member
 
Join Date: Dec 2010
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Ok, I installed Vlogger to make sure there was nothing up with that.
Reply With Quote
  #6  
Old 28th December 2010, 23:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

The Date::Format Perl module isn't installed. Which distribution do you use?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 29th December 2010, 10:04
alleks alleks is offline
Senior Member
 
Join Date: Nov 2010
Posts: 157
Thanks: 9
Thanked 9 Times in 9 Posts
 
Default

go install Date::Format into pearl and see if keeps failing

How to install

Code:
#perl -MCPAN -e shell
#perl install Date::Format
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache stops woring. azler.meh Installation/Configuration 5 27th December 2010 21:20
Possible httpd server attack, may need to harden ISPCONFIG or apache isn Server Operation 6 7th December 2010 11:56
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
Loadbalanced Apache Cluster Help brianwebb01 Installation/Configuration 2 18th October 2006 17:01
Server name change stops webmail working shajazzi Installation/Configuration 3 16th May 2006 16:00


All times are GMT +2. The time now is 19:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.