#1  
Old 28th December 2010, 17:00
tuxillo tuxillo is offline
Junior Member
 
Join Date: Dec 2010
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default server.sh not starting up

Hi all,

It seems my server.sh is not starting up anything, and it says nothing when executed manually. This is a Centos5 VZ container running on a Proxmox VZ host.

# /usr/local/ispconfig/server/server.sh
finished.
# ps aux | grep '/usr/local/ispconfig/server/[s]erver.php'
# id
uid=0(root) gid=0(root) grupos=0(root),1(bin),2(daemon),3(sys),4(adm),6(di sk),10(wheel)

Nothing on port 8080:

# netstat -an | grep 8080
#

Cron schedule seems to be okay:

# crontab -l
* * * * * /usr/local/ispconfig/server/server.sh &> /dev/null
30 00 * * * /usr/local/ispconfig/server/cron_daily.sh &> /dev/null

# php -v
PHP 5.2.10 (cli) (built: Nov 13 2009 11:24:03)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies

Thanks,
Antonio Huete
Reply With Quote
Sponsored Links
  #2  
Old 29th December 2010, 16:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

What's the output of
Code:
cat /proc/user_beancounters
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 29th December 2010, 16:44
tuxillo tuxillo is offline
Junior Member
 
Join Date: Dec 2010
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default server.sh not starting up

Hi Falko,

See this paste: http://pastebin.com/FEePL9A1

Cheers,
Antonio Huete
Reply With Quote
  #4  
Old 30th December 2010, 14:14
tuxillo tuxillo is offline
Junior Member
 
Join Date: Dec 2010
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default server.sh not starting up

Hi again,

I've rebooted the container and server.sh didn't start up, but when I tried to run it manually I saw this:

[root@napalm ~]# /usr/local/ispconfig/server/server.sh
which: no vzctl in (/usr/kerberos/sbin:/usr/kerberos/bin:/sbin:/usr/sbin:/bin:/usr/bin:/usr/local/sbin:/usr /local/bin:/usr/X11R6/bin)
which: no vzctl in (/usr/kerberos/sbin:/usr/kerberos/bin:/sbin:/usr/sbin:/bin:/usr/bin:/usr/local/sbin:/usr /local/bin:/usr/X11R6/bin)
/usr/bin/fail2ban-client
finished.

A re-run shows:

[root@napalm ~]# /usr/local/ispconfig/server/server.sh
finished.

Cheers,
Antonio Huete
Reply With Quote
  #5  
Old 30th December 2010, 18:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by tuxillo View Post
Hi Falko,

See this paste: http://pastebin.com/FEePL9A1

Cheers,
Antonio Huete
Looks ok.

Code:
[root@napalm ~]# /usr/local/ispconfig/server/server.sh
which: no vzctl in (/usr/kerberos/sbin:/usr/kerberos/bin:/sbin:/usr/sbin:/bin:/usr/bin:/usr/local/sbin:/usr /local/bin:/usr/X11R6/bin)
which: no vzctl in (/usr/kerberos/sbin:/usr/kerberos/bin:/sbin:/usr/sbin:/bin:/usr/bin:/usr/local/sbin:/usr /local/bin:/usr/X11R6/bin)
/usr/bin/fail2ban-client
finished.
Did you see this in the container or on the OpenVZ host?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 30th December 2010, 18:37
tuxillo tuxillo is offline
Junior Member
 
Join Date: Dec 2010
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default server.sh not starting up

Hi Falko,

I see it in the container, there's no ISPConfig installation in the Proxmox VZ host.

Cheers,
Antonio Huete
Reply With Quote
  #7  
Old 30th December 2010, 18:54
tuxillo tuxillo is offline
Junior Member
 
Join Date: Dec 2010
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default server.sh not starting up

Hi,

I've managed to turn on debugging and I can see this message:

30.12.2010-17:50 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
30.12.2010-17:50 - DEBUG - No Updated records found, starting only the core.
30.12.2010-17:50 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock

Could be that a bad shutdown, mismatched or wrong entries in sys_datalog table are avoiding a proper startup of the server with all the modules?

Thanks,
Antonio Huete
Reply With Quote
  #8  
Old 31st December 2010, 15:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by tuxillo View Post
Could be that a bad shutdown, mismatched or wrong entries in sys_datalog table are avoiding a proper startup of the server with all the modules?
Well, maybe it is a problem with your database. Have you tried to check/repair it in phpMyAdmin?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 31st December 2010, 15:14
tuxillo tuxillo is offline
Junior Member
 
Join Date: Dec 2010
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default server.sh not starting up

Hi,

[root@napalm ~]# mysqlcheck -u root -p --auto-repair --check --optimize --all-databases
Enter password:

(...)
dbispconfig.attempts_login Table is already up to date
dbispconfig.client Table is already up to date
dbispconfig.client_template Table is already up to date
dbispconfig.country Table is already up to date
dbispconfig.cron Table is already up to date
dbispconfig.dns_rr Table is already up to date
dbispconfig.dns_slave Table is already up to date
dbispconfig.dns_soa Table is already up to date
dbispconfig.dns_template Table is already up to date
dbispconfig.domain Table is already up to date
dbispconfig.firewall Table is already up to date
dbispconfig.ftp_user Table is already up to date
dbispconfig.mail_access Table is already up to date
dbispconfig.mail_content_filter Table is already up to date
dbispconfig.mail_domain Table is already up to date
dbispconfig.mail_forwarding Table is already up to date
dbispconfig.mail_get Table is already up to date
dbispconfig.mail_greylist Table is already up to date
dbispconfig.mail_mailman_domain Table is already up to date
dbispconfig.mail_relay_recipient Table is already up to date
dbispconfig.mail_traffic Table is already up to date
dbispconfig.mail_transport Table is already up to date
dbispconfig.mail_user Table is already up to date
dbispconfig.mail_user_filter Table is already up to date
dbispconfig.monitor_data Table is already up to date
dbispconfig.remote_session Table is already up to date
dbispconfig.remote_user Table is already up to date
dbispconfig.server Table is already up to date
dbispconfig.server_ip Table is already up to date
dbispconfig.shell_user Table is already up to date
dbispconfig.software_package Table is already up to date
dbispconfig.software_repo Table is already up to date
dbispconfig.software_update Table is already up to date
dbispconfig.software_update_inst Table is already up to date
dbispconfig.spamfilter_policy Table is already up to date
dbispconfig.spamfilter_users Table is already up to date
dbispconfig.spamfilter_wblist Table is already up to date
dbispconfig.support_message Table is already up to date
dbispconfig.sys_config Table is already up to date
dbispconfig.sys_datalog Table is already up to date
dbispconfig.sys_dbsync Table is already up to date
dbispconfig.sys_filesync Table is already up to date
dbispconfig.sys_group Table is already up to date
dbispconfig.sys_ini Table is already up to date
dbispconfig.sys_log OK
dbispconfig.sys_remoteaction Table is already up to date
dbispconfig.sys_session Table is already up to date
dbispconfig.sys_user Table is already up to date
dbispconfig.web_database Table is already up to date
dbispconfig.web_domain Table is already up to date
(...)

[root@napalm ~]# /usr/local/ispconfig/server/server.sh
31.12.2010-14:12 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
31.12.2010-14:12 - DEBUG - No Updated records found, starting only the core.
31.12.2010-14:12 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
finished.
[root@napalm ~]# ps aux |grep '/usr/local/ispconfig/server/[s]erver.sh'
[root@napalm ~]#

Regards,
Antonio Huete
Reply With Quote
Reply

Bookmarks

Tags
server.sh startup

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
coexistence of php4 and php5 on ISPC3 AceLine Tips/Tricks/Mods 5 5th November 2010 15:56
Here is how to run server.sh from PHP zabersoft Developers' Forum 4 21st September 2010 17:02
Problem with services!! banzaiwebstudio.com Installation/Configuration 7 19th May 2010 22:13
High on Lenny - Lvm Mount Problem Serverman Technical 1 23rd June 2009 17:26
dns server error Hellbound General 7 2nd August 2007 10:18


All times are GMT +2. The time now is 20:04.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.