#11  
Old 18th December 2010, 20:36
qiubosu qiubosu is offline
Senior Member
 
Join Date: Jan 2010
Posts: 141
Thanks: 2
Thanked 0 Times in 0 Posts
Default

i'm setting up drupal multisites (shared codebase) in the same server, ISPConfig 3 hosting server. does anyone know and have successfully made roundcube webmail working for all the multisites, e.g. http://www.site-1.com/webmail, http://www.site-2.com/webmail, http://www.site-3.com/webmail etc, with the shared drupal codebase? if yes, it is much appreciated if you can provide the information? if not, can you provide some helpful information as well. thanks.

Environment:

RoundCube 0.3.1-3
ISPConfig 3.0.3.1
Ubuntu 10.04 LTS
Reply With Quote
Sponsored Links
  #12  
Old 19th December 2010, 13:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by qiubosu View Post
i'm setting up drupal multisites (shared codebase) in the same server, ISPConfig 3 hosting server. does anyone know and have successfully made roundcube webmail working for all the multisites, e.g. http://www.site-1.com/webmail, http://www.site-2.com/webmail, http://www.site-3.com/webmail etc, with the shared drupal codebase? if yes, it is much appreciated if you can provide the information? if not, can you provide some helpful information as well. thanks.

Environment:

RoundCube 0.3.1-3
ISPConfig 3.0.3.1
Ubuntu 10.04 LTS
Please open a new thread.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #13  
Old 19th December 2010, 18:56
qiubosu qiubosu is offline
Senior Member
 
Join Date: Jan 2010
Posts: 141
Thanks: 2
Thanked 0 Times in 0 Posts
Default

hello falko, i have already made it working. no issue now on this now.
Reply With Quote
  #14  
Old 22nd December 2010, 02:52
entertheraptor entertheraptor is offline
Member
 
Join Date: Dec 2010
Location: Melbourne, Australia
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to entertheraptor
Default

OK, the problem was that both the "main.inc.php" and "db.inc.php" files were missing the closing "?>"

So it's all working now. I did actually think of that but thats how Roundcube presented those files to me during the instillation process with the instructions to save the files exactly as they were to the appropriate directory so I figured that they knew what they were doing.

The issue I have now is getting "mydomain.com/webmail" to redirect to the directory that Roundcube is installed in. I followed the instructions above and created the "roundcube.conf" file but now when I go to "mydomain.com/webmail" the browser wants to download a file. When I download the file and open it in Notepad it has the following contents.

<?php

/**
* index.php
*
* Redirects to the login page.
*
* @copyright 1999-2010 The SquirrelMail Project Team
* @license http://opensource.org/licenses/gpl-license.php GNU Public License
* @version $Id: index.php 13893 2010-01-25 02:47:41Z pdontthink $
* @package squirrelmail
*/

// Are we configured yet?
if( ! file_exists ( 'config/config.php' ) ) {
echo '<html><body><p><strong>ERROR:</strong> Config file ' .
'&quot;<tt>config/config.php</tt>&quot; not found. You need to ' .
'configure SquirrelMail before you can use it.</p></body></html>';
exit;
}

// If we are, go ahead to the login page.
header('Location: src/login.php');

?>

...which appears (based on my very limited programming knowledge) to be a script that checks to see if "SquirrelMail" is configured and if so go to the "SquirrelMail" login page. Perhaps a conflict between "Roundcube" and "SquirrelMail"???

Maybe also has something to do with the fact that I have to append :81 to the end of the domain name before the /webmail when accessing the server on a local machine because my server is listening on port 81 due to my routers refusal to forward to port 80.

Help please.
Reply With Quote
  #15  
Old 23rd December 2010, 03:33
entertheraptor entertheraptor is offline
Member
 
Join Date: Dec 2010
Location: Melbourne, Australia
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to entertheraptor
 
Default

Update;

OK, I got around things by changing the alias (in the instructions provided by TheWierd) from "webmail" to "mailbox" and now I get a server error 500 when trying to access mydomain.com/mailbox. I tried replacing this system with a symlink in the mydomain.com/web directory using the command ln -s /path/to/roundcube mydomain.com/mailbox which appears to have created the symlink OK and when I use ls -l the symlink appears to point to the roundcube directory but when I access mydomain.com/mailbox I get a server error again.

Any ideas?
Reply With Quote
Reply

Bookmarks

Tags
roundcube, webmail

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Webmail on ISPConfig 3 Master One Installation/Configuration 8 6th June 2013 09:27
Webmail use log Hagforce General 2 11th November 2010 08:14
Pointing Webmail and Postfix Mail Server to Static IP Address need_a_linux_brain Installation/Configuration 0 12th May 2009 22:28
RoundCube Webmail "AllowOverride Options" Location fdsg72-lux Installation/Configuration 1 13th November 2008 12:25
Webmail alias aethiolas HOWTO-Related Questions 2 21st November 2005 18:21


All times are GMT +2. The time now is 00:04.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.