Prev Previous Post   Next Post Next
  #1  
Old 4th December 2010, 11:27
rzlines rzlines is offline
Junior Member
 
Join Date: Oct 2009
Posts: 27
Thanks: 10
Thanked 0 Times in 0 Posts
Default DNS configuration worries

Hello,

I have been following the ISPConfig 3 tutorial for CentOS and have completed the setup successfully.

My current server connects to the internet via a router and hence I have configured it to use a private ip i.e. 192.168.*.* series during the install process.

At the moment I am unable to access the server from the internet nor can I link up the DNS to any domain I try to host or the domain of the server, do I have to configure the router in anyway to allow the server to be online? I have 2 static ip's given to me by my ISP but I'm at a loss of how to configure the router to allow the server ip (local) to translate the the public static ip. I could be wrong here but I think that is the problem in my case.

Please guide me appropriately.


EDIT: I looked at this post after I posted here and realized that I have to port forward my server's ip address. I had already configured an A record on my domain to point to my static IP address and it does indeed currently point to my router. I have port forwarded the local ip address of my server to forward port 80 and port 8080 but it still points to the router.

- I have added a DNS zone using the DNS Zone Wizard, but I have a query about it - should I add the public ip address here or the private (local) ip of my server (192.168.*.*) ? (configured this using the ISPConfig 3 manual)

- What happens in a multi-server setup? Do I have to also port foward all my other server's IP's and will it work with just 1 public ip?

Last edited by rzlines; 4th December 2010 at 13:57.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP DNS and DHCP I AM LOST krisarmstrong Server Operation 0 18th August 2009 23:27
DNS worries csupport Installation/Configuration 2 18th August 2009 13:35
Urgent Help in NEED with DNS installation and Configuration! FirFYPJ Server Operation 6 9th March 2009 18:37
Squid Proxy Caching on Linux obzerver Installation/Configuration 4 13th August 2008 19:51
ISPConfig 2.2.21 | Debian 4.0 | DNS configuration question iceget Installation/Configuration 8 17th February 2008 18:25


All times are GMT +2. The time now is 06:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.