Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 29th November 2010, 20:24
wildnux wildnux is offline
Junior Member
 
Join Date: Sep 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Opensuse 11.3 ispconfig3 ssh, sftp, issues

I set up a lamp server following the guide for a perfect opensuse server. But I had a few issues. I want to solve them one by one, so i am discussing only one here. I will start a new thread for other problems. I can log in to the machine perfectly with a real user name and password with ssh,or winscp (SFTP protocol), but the virtual users, that were created by ispconfig cannot log in via winscp with sftp protocol. It has to have 'scp', selected. Also my friend had a mac and he was trying to log in to the machine, but could not because none of those client programs had an option to specify scp. Is there any way that the virtual users can log in to my machine as a normal user would(chrooted though).

Since yesterday, as soon as anyone logs in, the connection gets, disconnected. It just says connection closed when you do ssh from a unix computer, as soon as it logs in.

I searched a lot for similar problems, but most of the issues are either solved by deleting the ips from the block lists by fail2ban or the forums are dead without any solutions. I checked on mine but there was none of them blocked in the iptables.

So i thought, i might have missed something when setting up the server, and thought of starting once again. Thus, formatted the partitions, installed fresh opensuse 11.3 and did a zypper update and reboot. This time set up a perfect server with the
script for automatically setting up perfect server
.

the problem remains. Cannot log into the system using sftp, while scp and ssh gets disconnected as soon as i log in. I tried to log in from my internal network and still the same result.

I am trying to learn so many things here so i would really like to know "why is it happening" rather than just solving the problem only. I hope this thread will help a lot of newbies like me to start with. Please guide me
Reply With Quote
Sponsored Links
 

Bookmarks

Tags
connection closed, ispconfig 3, opensuse 11.3, sftp, ssh

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrade OpenSuse 11.0 to 11.3 metaldrummer Installation/Configuration 3 13th October 2010 18:06
ISPConfig3 on SuSe 11.3 ftp and quota issues RKB Server Operation 2 13th September 2010 23:30
amavis rejects all inbound emails aclhkaclhk Installation/Configuration 5 28th February 2010 04:24
ISPConfig3 - SFTP peterspoon Installation/Configuration 3 1st November 2009 11:09
How to setup SFTP accounts via SSH? webwizzy Server Operation 3 4th March 2009 13:58


All times are GMT +2. The time now is 06:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.